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List of Abbreviations

BSC beam simulation configuration
DHCP dynamic host configuration protocol
FFT Fast Fourier transform
FTP file transfer protocol
IP internet protocol
LAN local area network
LW lateral wave
MFC Microsoft foundation class
ML material loss
PA phased array
PID proportional integral derivative (controller)
PRF pulse repetition frequency
RAM random-access memory
RDTIFF R/D Tech proprietary file format
SAFT synthetic aperture focusing technique
SNR signal-to-noise ratio
TOFD time-of-flight diffraction
UAC user account control
US United States
USB universal serial bus
UT ultrasonic testing
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Important Information — Please Read Before Use

Intended Use

TomoView software is designed to perform nondestructive inspections on industrial 
and commercial materials. 

Software Compatibility

Refer to the following table to confirm that TomoView is compatible with the ancillary 
equipment being used.

Table 1  Evident Data Acquisition Units compatible with TomoView

Family Models

MultiScan MultiScan MS5800 (acquisition in UT mode only)

OmniScan OmniScan MX
OmniScan MX2
OmniScan iX (in Analysis mode only)

TomoView FOCUS LT
FOCUS LT Rackmounted
Important Information — Please Read Before Use    13
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Safety Symbols

The following safety symbols might appear on the instrument and in the instruction 
manual:

 General warning symbol:
This symbol is used to alert the user to potential hazards. All safety messages that 
follow this symbol shall be obeyed to avoid possible harm.

 High voltage warning symbol:
This symbol is used to alert the user to potential electric shock hazards greater 
than 1,000 volts. All safety messages that follow this symbol shall be obeyed to 
avoid possible harm.

Safety Signal Words

The following safety symbols might appear in the documentation of the instrument:

The DANGER signal word indicates an imminently hazardous situation. It calls 
attention to a procedure, practice, or the like, which, if not correctly performed or 
adhered to, could result in death or serious personal injury. Do not proceed beyond a 
DANGER signal word until the indicated conditions are fully understood and met.

The WARNING signal word indicates a potentially hazardous situation. It calls 
attention to a procedure, practice, or the like, which, if not correctly performed or 
adhered to, could result in death or serious personal injury. Do not proceed beyond a 
WARNING signal word until the indicated conditions are fully understood and met.
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The CAUTION signal word indicates a potentially hazardous situation. It calls 
attention to an operating procedure, practice, or the like, which, if not correctly 
performed or adhered to, could result in minor or moderate personal injury, material 
damage, particularly to the product, destruction of part or all of the product, or loss of 
data. Do not proceed beyond a CAUTION signal word until the indicated conditions 
are fully understood and met.

Note Signal Words

The following safety symbols could appear in the documentation of the instrument:

The IMPORTANT signal word calls attention to a note that provides important 
information, or information essential to the completion of a task.

The NOTE signal word calls attention to an operating procedure, practice, or the like, 
which requires special attention. A note also denotes related parenthetical 
information that is useful, but not imperative.

The TIP signal word calls attention to a type of note that helps you apply the 
techniques and procedures described in the manual to your specific needs, or 
provides hints on how to effectively use the capabilities of the product.

Warranty Information

Evident guarantees your Evident product to be free from defects in materials and 
workmanship for a specific period, and in accordance with conditions specified in the 
Terms and Conditions available at https://www.olympus-ims.com/en/terms/.
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The Evident warranty only covers equipment that has been used in a proper manner, 
as described in this instruction manual, and that has not been subjected to excessive 
abuse, attempted unauthorized repair, or modification.

Inspect materials thoroughly on receipt for evidence of external or internal damage 
that might have occurred during shipment. Immediately notify the carrier making the 
delivery of any damage, because the carrier is normally liable for damage during 
shipment. Retain packing materials, waybills, and other shipping documentation 
needed in order to file a damage claim. After notifying the carrier, contact Evident for 
assistance with the damage claim and equipment replacement, if necessary.

This instruction manual explains the proper operation of your Evident product. The 
information contained herein is intended solely as a teaching aid, and shall not be 
used in any particular application without independent testing and/or verification by 
the operator or the supervisor. Such independent verification of procedures becomes 
increasingly important as the criticality of the application increases. For this reason, 
Evident makes no warranty, expressed or implied, that the techniques, examples, or 
procedures described herein are consistent with industry standards, nor that they 
meet the requirements of any particular application.

Evident reserves the right to modify any product without incurring the responsibility 
for modifying previously manufactured products.

Technical Support

Evident is firmly committed to providing the highest level of customer service and 
product support. If you experience any difficulties when using our product, or if it 
fails to operate as described in the documentation, first consult the user’s manual, and 
then, if you are still in need of assistance, contact our After-Sales Service. To locate the 
nearest service center, visit the Service Centers page on the Evident Scientific Web site.
16    Important Information — Please Read Before Use
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Introduction

TomoView is powerful and versatile software for nondestructive ultrasonic testing 
(UT). TomoView features functions for the acquisition of ultrasonic signals, for real-
time imaging of these signals, and for the analysis of previously acquired data files.

TomoView has many advanced functions and features to efficiently acquire and 
analyze data during UT inspections. An ideal tool for either on-site or laboratory 
work, TomoView runs under Microsoft Windows 7, Windows Vista or Windows XP 
Professional.

TomoView handles data files up to 2 GB in size for a 64-bit operating systems (OS) 
and up to 1 GB for a 32-bit OS, allowing you to perform complex inspections not 
possible with standalone inspection instruments.

TomoView offers a flexible graphical user interface allowing you to customize, save, 
and retrieve layouts containing various views, thus facilitating your work during UT 
inspections.

In addition to generic graphical features such as measurement cursors, zooming 
operations, and color-palette modifications, TomoView also provides automated tools 
to facilitate industrial standard compliant advanced data analysis. You can simply 
outline flawed areas and configure TomoView to automatically find and display the 
peak amplitude and the length of the flaw. The TomoView reporting functions allow 
you to include flaw information in an indication table, together with essential 
TomoView setup parameters.

Using TomoView, you can analyze previously acquired files or files that are being 
acquired. You can select and zoom on portions of a view, and perform flaw 
measurements, while the same file is still being filled with acquisition data.
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1. Getting Started

This chapter contains information to allow you to quickly begin using TomoView.

1.1 Minimum Computer Requirements

The minimum computer requirements for TomoView software are:

• 2 GB RAM memory or higher (4 GB recommended for large data files and high- 
speed acquisitions)

• 100 GB free hard disk space for optimal performance in analysis and acquisition.
• 1280 × 1024 or higher display adaptor and monitor resolution
• One USB port for the HASP security hardware key
• One 100 Mbit/s network adaptor dedicated to the acquisition unit (for 

acquisition). The computer needs a second network adaptor if you want to 
simultaneously connect it to a local area network and to a data acquisition unit.

• A keyboard and a pointing device
• One of the following operating systems:

— Microsoft Windows XP, XP Pro, XP Family Edition (Service Pack 2 or higher)
— Microsoft Windows Vista Business, Home Basic, Enterprise, Home Premium, 

Starter, Ultimate but the user account control (UAC) is not supported
— Microsoft Windows 7
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You can install TomoView on a drive other than the drive used for Windows. In that 
case, the TomoView installer still requires 150 MB where Windows resides, to install 
the hardware security key driver, the Direct X updates, the Windows temporary 
installation, and the MFC (Microsoft Foundation Class) files.

In this document, TomoView screen captures were taken on a computer running 
Windows 7. The look of the screen captures could differ if you are using TomoView 
on a computer running another operating system. 
For most examples presented in this document, TomoView was arbitrarily configured 
to use the metric measurement units (see section 3.14.1 on page 211 to find how to 
change measurement units). 

1.2 Compatible Data Acquisition Units

TomoView operates with Evident ultrasonic instruments to acquire data in the 
Inspection mode and to analyze data files created with these instruments. Table 2 on 
page 22 provides the list of the compatible instruments.

Table 2  Evident Data Acquisition Units compatible with TomoView 

Family Models

MultiScan MultiScan MS5800 (acquisition in UT mode only)

OmniScan OmniScan MX
OmniScan MX2
OmniScan iX (in Analysis mode only)

TomoScan FOCUS LT
FOCUS LT Rackmount
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1.3 TomoView Editions

TomoView is available in four editions: 

Inspection
A full-featured mode providing all the inspection and analysis functions. With 
the TomoView Inspection edition license, you can also choose to start the other 
TomoView editions (see section 1.9 on page 41 for details). 

Analysis
Provides all analysis functions but no inspection functions.

Lite Weld
Provides a set of analysis functions optimized for weld applications (see 
Figure 1-1 on page 24): 

• Conventional UT (pulse-echo and TOFD) analysis based on the B-scan
• Phased array angle beam analysis based on the S-scan
• Analysis of one-line scan inspections
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Figure 1-1  TomoView Lite Weld edition display example

Lite Aero
Provides a set of analysis functions optimized for aerospace applications (see 
Figure 1-2 on page 25): 

• Conventional UT analysis based on the C-scan
• Phased array 0-degree analysis based on the C-scan
• Analysis of raster scan inspection
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Figure 1-2  TomoView Lite Aero edition display example

TomoViewer
A free viewer that allows you to visualize TomoView data files.

At startup, you need to select which TomoView edition you want to run (see 
Figure 1-3 on page 26). Table 3 on page 26 presents the features available for each 
edition.
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Figure 1-3  The Startup Selection dialog box

Table 3  TomoView edition feature comparison 

Features
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TomoView
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Ability to switch between metric and US Customary Units ✓  ✓  ✓  ✓  ✓
Zoom in/out  ✓  ✓  ✓  ✓  ✓
Ability to import OmniScan data files  ✓  ✓  ✓  ✓  ✓
Software gain adjustment  ✓  ✓  ✓  ✓  ✓
Ability to view conventional UT groups  ✓  ✓  ✓  ✓  ✓
Ability to view phased array groups  ✓  ✓  ✓  ✓  ✓
Predefined display layouts  ✓  ✓  ✓  ✓  ✓
Color contrast adjustment  ✓  ✓  ✓  ✓  ✓
Ability to view TOFD groups  ✓  ✓   ✓  ✓
Volumetric Merge tool (automatic or manual)  ✓  ✓   ✓  ✓
Ability to view indication table  ✓  ✓  ✓  ✓  ✓
Ability to preview and print reports  ✓  ✓  ✓  ✓  ✓
Ability to modify/create color palette   ✓  ✓  ✓  ✓
Built-in report generator   ✓  ✓  ✓  ✓
Ability to display rebounds (skips)   ✓  ✓  ✓  ✓
Ability to save custom layouts   ✓  ✓  ✓  ✓
Ability to display custom weld overlay (.dxf)   ✓  ✓  ✓  ✓
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The About TomoView dialog box, accessible by selecting Help > About on the menu, 
reports which edition of TomoView is currently running (see Figure 1-4 on page 28).

Sound axis calibration   ✓  ✓  ✓  ✓
Ability to display and edit indication table   ✓  ✓  ✓  ✓
Selectable information groups (readings)   ✓  ✓  ✓  ✓
C-Scan Merge tool   ✓  ✓  ✓  ✓
Zone tool for statistical measurements   ✓  ✓  ✓  ✓
Data-File Merge tool   ✓  ✓  ✓  ✓
Off-line gate adjustment   ✓  ✓  ✓  ✓
Ability to add/modify/delete indication   ✓  ✓  ✓  ✓
Multiple-group combined display   ✓   ✓  ✓
Phased array and TOFD combined display   ✓   ✓  ✓
Predefined weld overlay display   ✓   ✓  ✓
Ability to add binarized C-scan images    ✓  ✓  ✓
SNR measurement on C-scans    ✓  ✓  ✓
Extra software C-scans   ✓  ✓  ✓  ✓
Off-line A-scan resynchronization    ✓  ✓  ✓
TOFD manager (LW removal, resynchronization)     ✓  ✓
Ability to modify probe offsets and skew angles     ✓  ✓
Ray tracing     ✓  ✓
Ability to open multiple files simultaneously     ✓  ✓
Ability to export data group in .txt files     ✓  ✓
Layout creation     ✓  ✓
3-D cursor     ✓  ✓
FFT calculation     ✓  ✓
Hysteresis correction     ✓  ✓
Log to linear conversion     ✓  ✓
Microsoft Excel exchange     ✓  ✓
Ability to import PASS files     ✓  ✓
Data acquisition capabilities      ✓

Table 3  TomoView edition feature comparison (continued)
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Figure 1-4  The About TomoView dialog box indicating the TomoView edition

1.4 Security Hardware Key

TomoView needs to detect an HASP security hardware key connected to the 
computer to operate. The HASP security USB hardware key supplied with your 
TomoView copy contains the authorization code needed to operate the TomoView 
edition that you purchased.

Before starting TomoView, connect the HASP hardware key to the USB port of your 
computer. You can still use a parallel port key from a previous TomoView version (see 
Figure 1-5 on page 28) as long as it contains authorization codes to run 
TomoView 2.10.

Figure 1-5  The HASP security hardware key models

Edition currently
running

USB key Legacy parallel port key
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When you start TomoView with no security hardware key connected to the computer, 
TomoViewer is the only enabled edition in the Startup Selection dialog box (see 
Figure 1-6 on page 29).

Figure 1-6  The Startup Selection dialog box with no security hardware key

If you disconnect the security hardware key while TomoView is running, the message 
shown in Figure 1-7 on page 29 appears 30 seconds later. After clicking OK, when 
needed, TomoView proposes to save unsaved data, and then closes.

Figure 1-7  Missing hardware key message box

When you purchase both the Inspection and Analysis editions of TomoView, two 
security hardware keys are delivered, one for each edition. 
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1.5 Installing TomoView

The installation of TomoView is simple.

To install TomoView

1. On the computer on which you want to install TomoView, log on with a user 
account that has administrator rights.

2. Run the TomoView installer program from the Evident distribution disk.
3. Follow the on-screen TomoView installer wizard steps.

The wizard installs TomoView, the Advanced Calculator, and the Bootp Server.
4. You need to disable the sleep mode on the computer to prevent a connection loss 

with the data acquisition unit:
a) For Windows 7, on the Windows taskbar, select Start > Control Panel > 

Hardware and Sound > Power Options, and then click Change Plan 
Settings. 

b) In the pop-up menu that appears, set Turn off the display and Put the 
computer to sleep both to Never. (see Figure 1-8 on page 30).

c) Click Save Changes. 

Figure 1-8  Configuring power options for Windows 7

OR
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 For Windows XP, on the Windows taskbar, select Start > Control Panel > 
Power Options, and then select Never for both System standby and System 
hibernates (see Figure 1-9 on page 31).

Figure 1-9  Configuring power options for Windows XP

The TomoView installer configures the Windows firewall to allow the communication 
between the acquisition unit and the TomoView and Bootp Server programs. If you 
use a third-party firewall on the computer running TomoView, refer to section 9.2 on 
page 435 for configuration information.

1.6 About the Bootp Server

The TomoView installer automatically installs the Bootp Server. The role of the Bootp 
Server is to provide a valid IP address to a starting Evident data acquisition unit 
connected to the computer.
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The Bootp Server is configured to automatically to start with Windows. The Bootp 

Server Monitor icon ( ) appears in the Notification Area of the Windows taskbar 
(see Figure 1-10 on page 32). The Bootp Server Monitor icon includes an indicator 
showing the state of the server (see Table 4 on page 32). 

A tooltip appears when you bring the mouse pointer over the Bootp Server Monitor 
icon (see Figure 1-10 on page 32).

Figure 1-10  The Bootp Server Monitor icon and tooltip

The Bootp Server contextual menu appears when you right-click the Bootp Server 
Monitor icon (see Figure 1-11 on page 33).

Table 4  Bootp Server Monitor states 

Icon Bootp Server state

The Bootp Server is operating normally with no active pod.

The Bootp Server is operating normally with at least one active 
pod.

The Bootp Server is not operating normally.
Refer to section 9.3 on page 436 for troubleshooting information.

Bootp Server Monitor tooltip

Bootp Server Monitor icon
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Figure 1-11  The Bootp Server Monitor icon and contextual menu

You can use the contextual menu commands to configure and diagnose the operation 
of the Bootp Server. For example, when the Bootp Server Monitor icon includes a red 
indicator (error condition), click Check Status in the contextual menu. The Bootp 
status dialog box opens, displaying diagnostic information (see Figure 1-12 on 
page 33). Refer to section 9.3 on page 436 for more troubleshooting information.

Figure 1-12  Bootp status dialog box content example

Bootp Server Monitor
contextual menu

Bootp Server Monitor icon
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1.7 Starting a FOCUS LT to Connect to TomoView

TomoView can acquire ultrasonic data using a FOCUS LT or a FOCUS LT Rackmount 
unit.

To start a FOCUS LT to connect to TomoView

1. Start the computer but do not start TomoView yet.
2. Ensure that the power is turned off on the FOCUS LT unit.
3. Connect a crossover Ethernet cable to the network adaptor of the FOCUS LT unit.
4. Connect the other end of the crossover Ethernet cable to the network adaptor 

dedicated to the FOCUS LT on the computer.

When your computer has more than one network adaptor, ensure to connect the 
crossover Ethernet cable to the network adaptor configured to connect to the 
acquisition unit.

5. Turn on the data acquisition unit: 
 For a FOCUS LT, press the power button on the front panel (Figure 1-13 on 

page 35), and then wait for the STBY indicator to stop blinking, indicating that 
the unit is ready to operate.
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Figure 1-13  The FOCUS LT front panel

OR
For a FOCUS LT Rackmount, press the power button on the front panel 
(Figure 1-14 on page 35), and then wait for the READY indicator to stop 
blinking and to turn green, indicating that the unit is ready to operate.

Figure 1-14  The FOCUS LT Rackmount front panel

Power button Indicators

Network adaptor

Power buttonIndicators
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6. On the computer, bring the pointer over the Bootp Server Monitor icon ( ) in 
the Navigation Area of the Windows taskbar.
A tooltip appears (see Figure 1-15 on page 36).

Figure 1-15  The Bootp Server icon when ready for operation

7. From the tooltip information, confirm that the Bootp Server is running and that it 
recognizes the FOCUS LT.

8. Start TomoView (see section 1.9 on page 41).

1.8 Starting an OmniScan and Connecting to TomoView

TomoView can acquire ultrasonic data using an OmniScan MX or MX2 unit that runs 
the TomoView Control program.

When you use TomoView to acquire ultrasonic data with an OmniScan unit, you need 
to start the OmniScan before starting TomoView. 

To start an OmniScan to connect to TomoView

1. Start the computer but do not start TomoView yet.
2. Ensure that the power is turned off on the OmniScan unit.
3. Connect a crossover Ethernet cable to the OmniScan network adaptor (see 

Figure 1-16 on page 37). 

Bootp Server Monitor tooltip

Bootp Server Monitor icon

Server running and FOCUS LT unit 
connected
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Figure 1-16  The network adaptor on the OmniScan MX

4. Connect the other end of the crossover Ethernet cable to the appropriate network 
adaptor on the computer.

When your computer has more than one network adaptor, ensure to connect the 
crossover Ethernet cable to the network adaptor configured to connect to the 
acquisition unit.

5. On the OmniScan unit (see Figure 1-17 on page 38): 
a) Ensure that a memory card containing the TomoView Control application is 

inserted into its slot on the right side of the unit.
b) On the front panel, press the green Power key to turn on the power of the 

OmniScan.
The OmniScan initial screen appears (see Figure 1-18 on page 38).

Network adaptor
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Figure 1-17  The OmniScan MX unit

Figure 1-18  Example of the OmniScan initial screen

Memory card slot

Power key

TomoView Control
[1.7R4]

Activate Option
[1.0R2] Auto Startup OFF

OmniScan
[MXU - 2.0R20

MXU-M Weld
[2.2R3]
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c) Choose TomoView Control.
d) If a dialog box appears requesting an option key number, type your new 

option key number (see Figure 1-19 on page 39) to activate the TomoView 
Control program on the current module.
If you do not have an option key number, and you want to upgrade your 
system, please contact your local Evident sales representative.

Figure 1-19  The dialog box to type a new option key number

The application appears on the OmniScan screen showing a log of successful 
operations (Figure 1-20 on page 40).
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Figure 1-20  Example of the TomoView Control application screen

If an operation fails, a logged message appears in red. Review the message 
and take the necessary action to correct the problem.

By default, the screen saver turns the screen off after 10 seconds. Press any function or 
parameter key to reactivate the screen. Select Pause timer to stop the screen saver 
count down.

6. On the computer, bring the pointer over the Bootp Server Monitor icon ( ) in 
the Navigation Area of the Windows taskbar.
A tooltip appears (see Figure 1-21 on page 41).

Auto Startup OFFPause timer

5) BootP registration success. IP address: 192.168.0.11
4) DSP initialization success (1)
3) Driver initialization success
2) FPGA loaded successfully
1) Socket initialization success

The screen will close in: 9s

Internal temperature (C): 38.4
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Figure 1-21  The Bootp Server icon when ready for operation

7. From the tooltip information, confirm that the Bootp Server is running and that it 
recognizes the OmniScan.

8. Start TomoView (see section 1.9 on page 41).

1.9 Starting TomoView

TomoView operates with or without an acquisition unit. When you use TomoView 
without an acquisition unit, you can only perform analysis tasks on existing data.

To start TomoView

1. Connect the security hardware key to the appropriate port of the computer. 
TomoView needs to detect the security hardware key to operate, with or without 
being connected to an acquisition unit.

2. Turn on the computer and wait for Windows to complete its starting process. Do 
not start TomoView yet. 

The computer must be operational before you turn the acquisition unit power on, as 
the acquisition unit gets its IP address from the computer.

3. Connect the data acquisition unit to the appropriate network adaptor of the 
computer, and then start it (see section 1.8 on page 36 for an OmniScan and 
section 1.7 on page 34 for a FOCUS LT).

4. Start TomoView by: 

a) Double-clicking the TomoView icon  on the Windows desktop.

OR 

Bootp Server Monitor tooltip

Bootp Server Monitor icon

Server running and OmniScan unit 
connected
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Clicking Start > All Programs > Evident NDT > TomoView 2.10 on the 
Windows taskbar.

5. In the Startup Selection dialog box that appears (see Figure 1-22 on page 42), 
click the button associated with the desired TomoView edition.

Figure 1-22  The Startup Selection dialog box

If you do not want the Startup Selection dialog box to appear each time you start 
TomoView, select the Do not show next time check box. 

To reactivate the Startup Selection dialog box, select File > Preferences > General 
Settings tab in TomoView, and then deselect Startup Selection in the Dialog Bypass 
group box.

The TomoView splash screen appears briefly indicating that the application is 
starting up.

6. When you start the Inspection edition, the Select Device Configuration dialog 
box appears (see Figure 1-23 on page 43). In the dialog box, do one of the 
following: 
 Select the acquisition unit or units that you want to include in your 

configuration, and then click OK.
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With its multipod capability, TomoView can acquire data from up to three FOCUS LT 
units in parallel, offering up to a threefold increase in acquisition speed.

OR
When your computer is not connected to an acquisition unit, click Cancel to 
use TomoView only in the Analysis mode. In this case, the Setup and 
Inspection modes will be unavailable.

Figure 1-23  Example of the Select Device Configuration dialog box

The list in the Select Device Configuration dialog box is empty when TomoView fails 
to detect hardware devices either because supported acquisition units are not 
connected, are not turned on, or are not correctly installed. Refer to section 9.3 on 
page 436 for troubleshooting information.

7. In the Configuration Selection dialog box that appears (see Figure 1-24 on 
page 44), select one of the following setup loading options, and then click OK.
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Open the last configuration
Select this option to load the last configuration used, whose name is indicated 
in the box. By default, the box indicates the name of the default configuration 
(Default_PA.acq, Default_UT.acq and more). 

Open an existing configuration
Select this option to access the Open dialog box. You can use this dialog box 
to browse through the folders and choose a configuration file (file name 
extension .acq).

Create a new configuration
Select this option to start a new configuration from a default configuration.

Figure 1-24  The Configuration Selection dialog box

A configuration file (.acq) is a complete description of the TomoView workspace. The 
file includes the acquisition unit hardware setup and the TomoView layout 
environment. 

If you click Cancel, the default configuration loads (Default_PA.acq for a phased 
array instrument or Default_UT.acq for a UT conventional instrument).
Once the selected setup is loaded, the TomoView window appears.
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2. TomoView User Interface

2.1 TomoView User Interface and Software Principles

TomoView provides features needed to perform nondestructive inspections based on 
ultrasonic technology. It combines setup, inspection, and analysis functions in one 
software package. TomoView can also be used in a stand-alone mode to analyze 
previously acquired data. 

The TomoView user interface (see Figure 2-1 on page 46) provides toolbars and 
menus for quick access to main commands. Using TomoView, you can conveniently 
present data imaging in multiple simultaneous views, such as in the example in 
Figure 2-1 on page 46. In this example, one document window is divided into four 
splitter windows. Each splitter window contains one or more (in the case of the upper 
right window) panes. Each pane contains one data view. 
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Figure 2-1  TomoView user interface example

Document windows

In TomoView, a document is related to the concept of an “inspection recording” and 
the associated data shown in a document window. You can use the application to 
consult and/or edit many document windows simultaneously. 

Splitter windows

You can subdivide a document window into splitter windows and panes. Splitter 
windows have the advantage of being easily resized while maintaining the “tiled” 
nature of the various panes in the window. 

TomoView 
Manager 
toolbar

Menus Button 
toolbars

Splitter 
window

Document 
window

Pane
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Window panes

The window pane is each of the nonoverlapping areas in a splitter window. Document 
windows can be split into any number of panes. Each pane can be user defined to 
contain any of the possible view types generated by TomoView. For further 
information concerning the different types of views, see section 3.7.1 on page 99.

In TomoView, panes also offer flexibility for the location of readings: cursor positions, 
statistics, scale settings, etc. These fields can be dynamically placed and customized 
within any view. For further information concerning the readings, see section 4.10 on 
page 276.

Layout

A layout is a complete set of display-related settings. You can save and load a layout 
to quickly return to a desired view configuration. Layout configurations are included 
in data files so that recorded data can be viewed through the original layouts that 
existed at data-recording time, or through the current system layouts. 

Template layouts are also provided as a reference for the most common inspection 
types. A menu on the TomoView Manager toolbar provides quick access to existing 
template layouts installed in TomoView (see section 4.8 on page 261 for more 
information on using layouts). 

Setup

 A setup file is a complete set of TomoView settings and contains the settings that an 
operator can access while using the TomoView interface. Setup files may contain one 
or more layouts, and files can be saved and restored on demand.

Normally, a setup represents a procedure for a specific application that is to be 
performed with the equipment. 

2.2 TomoView Interface

This section provides a description of the TomoView interface. Figure 3-1 on page 83 
shows an example of a data file representation and identifies the main TomoView 
interface elements.
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Figure 2-2  The TomoView interface

The main TomoView interface elements shown in Figure 2-2 on page 48 are the 
following:

1. Toolbars
2. Title bar of the main window
3. Menu bar
4. Reference cursor (red) with label
5. Title bar of the active pane
6. Color palette
7. Pane (data display area)

8. TomoView Manager toolbar
9. Status bar
10. Measurement cursor (blue) with 

label
11. Ruler
12. Zoom bar
13. Gate selector

1 2 3 4 5

8 9 10 11 12 13

6 7
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2.3 Main Window

The main window (see Figure 2-2 on page 48) contains the following elements:

Title bar

Displays the program icon, the program identification, and the name of the active file, 
as well as control buttons on the right end of the bar.

Menu bar

Displays the names of the various menus.

Toolbar

Displays command buttons, which can be clicked to carry out various commands.

Document windows

There is a document window, or shell window, for each file opened. Document 
windows provide a primary view of file content. The windows can be overlapping, in 
which case the topmost window is the active one. The document windows can also be 
arranged as tiles or in a cascade by means of Window menu commands. The active 
window is always identified by a highlighted title bar.

2.4 Menu Bar

This section describes the TomoView menu bar. The menu bar (see Figure 2-3 on 
page 49) is the horizontal bar displayed at the top of the main window, below the title 
bar, and provides access to commands. To open a menu, click the menu name. To 
activate a menu command, click its name in the menu, or type the keyboard shortcut 
if there is one indicated. 

Figure 2-3  The Menu bar
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The following subsections describe the commands available in each menu. Note that, 
depending on the operation mode and the type of hardware connected, the content of 
the menus could differ from what is presented in this manual. 

2.4.1 File Menu

The File menu (see Figure 2-4 on page 50) contains the commands that manage data 
files and the general preferences of the software. 

Figure 2-4  The File menu 

The File menu commands are the following:

Load Default Configuration 
Loads the default configuration used. 

Open
Opens a standard Open dialog box, from which you can select and load a setup or 
a data file.
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Load Layout
Opens a standard Open dialog box, from which you can select and open a layout 
file. 

Save Layout As (*.rst)
Opens a Save As dialog box, from which you can save the current layout and 
define it as the default layout. 

Save Custom Layout
Opens a Save Custom Layout dialog box (see Figure 2-5 on page 51), from which 
you provide a name for the current layout and save it as one of the five custom 
layouts. 

Figure 2-5  The Save Custom Layout dialog box

Save Configuration As
Opens a standard Save As dialog box, from which you can browse through 
folders, and save the active setup.

Import (*.law)/(*.pac) file
Opens a dialog box (see Figure 2-6 on page 52) from which you can select and 
load a *.law or a *.pac file used to configure the beam parameters for either the 
current Group, or a new one. 
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Figure 2-6  Importing .law or .pac files dialog box 

Import OmniScan File 
Opens a standard Open dialog box, from which you can select and load an 
OmniScan data file. This menu item is equivalent to the OmniScan File 
Converter button on the Main toolbar (see Table 5 on page 68 for details). 

Import PASS File
Opens a standard Open dialog box, from which you can select and load a PASS 
file. PASS files are used to simulate the beam propagation inside various types of 
materials and geometries. See section 10.1 on page 445 for more information. 

Import SRD File
Opens a standard Open dialog box, from which you can select and load an SRD 
file. SRD are legacy setup files used with older acquisition units. See section 6.1.3 
on page 322 for more information. 

Merge Files
Opens the dialog box shown in Figure 2-7 on page 53, from which different data 
files can be selected and merged into a single data file. See section 6.1.3 on 
page 322 for more information. 
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Figure 2-7  Data File Merge dialog box

Export Datagroup to File
Opens the dialog box shown in Figure 2-8 on page 53, which can be used to 
export an A-scan or a C-Scan to a *.txt file. See section 7.16 on page 422 for more 
information.

Figure 2-8  Export Datagroup dialog box
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Save Screen as Bitmap
Opens a menu which allows you to take snapshots of the screen which then can 
be saved on the computer as *.bmp files. See section 10.6 on page 461 for more 
information. 

Save Active View as Image 
Takes a snapshot of the current view and saves it on the computer as either a 
*.bmp or *.tif file. 

Preferences
Opens the Preferences dialog box, used to set various basic parameters related to 
general use of the software (see section 3.14 on page 210 for details).

Exit
Closes opened data files and quits TomoView.

2.4.2 Toolbars Menu

Figure 2-9  The Toolbars menu

The Toolbars menu (see Figure 2-9 on page 54) contains commands relating to the 
display of toolbars. The View menu commands are the following:

Document Toolbar
Alternately displays and hides the document toolbar.

Components Toolbar
Alternately displays and hides the Component toolbar.

Status Bar
Alternately displays and hides the status bar at the bottom of the views.

Toggle Toolbar
Alternately displays and hides the View toolbars.
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2.4.3 Part & Overlay Menu

Figure 2-10  The Part & Overlay menu

The Part & Overlay menu (see Figure 2-10 on page 55) contains the commands used 
to manage and edit parts and overlays. The Part & Overlay menu commands are the 
following:

Part Definition
Opens the Part Definition dialog box, from which you define the geometry of flat 
or cylindrical parts.

Weld Definition
Opens the Predefined Weld dialog box, from which you select a weld type and 
define its geometry. 

Import 2-Dim DXF file
Specimen submenu

Opens the Select file name dialog box, from which you browse to find and 
open a DXF file containing a drawing of the specimen. 

Weld submenu
Opens the Select file name dialog box, from which you browse to find and 
open a DXF file containing the drawing of a weld. 

Edit Overlay
Opens the Edit Overlays dialog box, from which you can rename, relocate, or 
delete a component. 
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Load (*.rsp)
Opens a standard Open dialog box, from which you can select and load an 
overlay defined in an .rsp file.

Save As (*.rsp)
Opens a standard Save As dialog box, from which you can browse through 
folders, type a new file name if necessary, and then save the current overlay to an 
.rsp file. 

2.4.4 View Menu

Figure 2-11  The View menu

The View menu (see Figure 2-11 on page 56) contains the following commands that 
manage pane displays, properties, and contents.

Delete 
Removes the active pane from the current display. 

Empty
Empties the active pane of its view contents.

Maximize/Minimize
Maximizes the size of the active pane by hiding the other panes. Choosing this 
command when the pane is already maximized restores the pane to its original 
size and displays the other panes.
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Splitting
Opens a submenu that contains various split commands that can be used to create 
subdivisions in the active pane. 

Readings
Opens a submenu that contains various commands that can be used to customize 
the readings in the active pane.

View Information
Opens a submenu (see Figure 2-11 on page 56) that gives access to various 
readings to customize options (see section 4.10 on page 276 for more information 
on how to use the readings). 

Save as Preference
Saves the current active pane settings as the default property settings 
(preferences).

Apply Preference
Applies the default settings (preferences) to the active pane.

Properties
Opens the View Properties dialog box, used to consult and modify the various 
properties of the active pane (see section 3.12 on page 162 for more details).

Contents
Opens the Contents dialog box, used to select the data view types to be displayed 
in the active pane (see section 4.8.2 on page 263 for more details).
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2.4.5 Layout Menu

Figure 2-12  The Layout menu

The Layout menu (see Figure 2-12 on page 58) contains commands that control 
toolbar and note display, and manage the layouts. The Layout menu commands are 
the following:

Add New Note
Adds a balloon-shaped pop-up window that is displayed on top of the pane 
contents to point out and comment on a given element. Note that frames can be 
freely moved and resized according to your needs. Notes will be added to the 
printout but cannot be saved.

Delete All Notes
Removes all notes at once from the pane contents.

Delete Active Note
This command (or its shortcut, the DELETE key) removes the active note from the 
pane contents.

The other menu items are default factory layouts that you can replace with your own. 

Layout 1, 2, 3,…, 8, 9, 10
These commands represent the available layouts. Choosing a command from this 
list applies the corresponding layout to the active window.
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Save Current Layout
Opens a submenu (see Figure 2-13 on page 59) listing the available commands 
used to save layouts. Choosing a command from this list saves the layout of the 
active window under the corresponding layout number. A dialog box appears, 
which you can use to save the layout under the name of your choice.

Figure 2-13  The Save Current Layout submenu
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2.4.6 Processing Menu

Figure 2-14  The Processing menu

The Processing menu (see Figure 2-14 on page 60) contains commands that apply 
various processing options to the data displayed in the active view. The Processing 
menu commands are the following:

Automatic Volumetric Merge
Performs a volumetric merge of all focal laws for all groups using the default 
parameters. See section 7.2 on page 335 for more information. 

Automatic Volumetric Merge by Group
Performs a volumetric merge of all focal laws for each corresponding group using 
the default parameters. See section 7.2 on page 335 for more information.

Volumetric Merge
Opens the Volumetric Merge dialog box, used to perform a volumetric merge of 
recorded data in analysis mode. See section 7.2 on page 335 for more information.

Batch Volumetric Merge
Opens a submenu giving access to two commands:

• Create: Opens an Open dialog box, used to select and open a batch 
volumetric merge file.
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• Execute: Opens an Open dialog box, used you to select and execute a batch 
volumetric merge file.

C-Scan Merge
Opens the C-Scan Merge dialog box, used to perform a C-scan merge of recorded
data in analysis mode. See section 7.7 on page 363 for more information. 

Perform Hysteresis Correction 
Opens the Hysteresis Correction dialog box, which can be used to improve the 
visualization of previously recorded ultrasonic data from bidirectional scanning 
sequences by drastically reducing the effect of the mechanical backlash of the 
manipulator on the scan axis. See section 7.17 on page 424 for more information. 

Create Soft C-Scan 
Opens the Create Soft C-Scan dialog box, which can be used to create position 
and amplitude C-Scan data from previously recorded A-scan data. See section 7.9 
on page 375 for more information. 

Create Thickness C-Scan
Opens the Create Thickness C-Scan dialog box, which can be used to create 
thickness C-Scan data by performing subtractions on data originating from two 
gates. See section 7.1 on page 333 for more information. 

Matrix Filters 
Opens the Matrix Filters dialog box, which can be used to reduce the noise 
observed on the C-Scan data in order to provide a much clearer representation of 
the data for analysis in noisy environments. See section 7.14 on page 400 for more 
information. 

Rectify Data
Applies a software rectification to the signal data in the active view.

Set A-Scan Resynchronization Gate
Defines the resynchronization gate (purple) in the A-scan display using the 
reference (red) and the measurement (blue) cursors. See section 7.13 on page 398 
for more information. 

Resynchronize A-Scans
Uses the resynchronization gate parameter to align A-scan peaks to zero depth. 
See section 7.13 on page 398 for more information.

Convert Log to Linear
Converts A-scan logarithmic data into linear data. See section 7.18 on page 427 for 
more information. 
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Excel Exchanges
Opens the Excel Exchanges dialog box, used to dynamically send the parameters 
available in the Readings to a Microsoft Excel spreadsheet. The results of the 
computation in Excel can then be dynamically sent back to TomoView as Custom 
info fields of the View Information. See section 10.4 on page 452 for more 
information. 

2.4.7 Tools Menu

Figure 2-15  The Tools menu

The Tools menu (see Figure 2-15 on page 62) contains commands that set display 
parameters for the active view. The Tools menu commands are the following:

Edit User Fields
Opens the Edit User Fields dialog box, used to define and edit the user fields (see 
section 4.8 on page 261 for more details).

Change Group
Opens the Change Group dialog box, used to select a channel from a list.
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Previous Group 
Decreases the Current Group value by one unit in the order followed for the 
Group Creation. 

Next Group
Increases the Current Group value by one unit in the order followed for the 
Group Creation.

Previous Beam
Decreases the Current Beam value by one unit in the regular beam numbering 
order. 

Next Beam
Increases the Current Beam value by one unit in the regular beam numbering 
order. 

Zoom
Enables the zoom tool, used to select and zoom in a specific region on a view.

3-D Cursor
Enables the 3-D Cursor tool (also called segment), used to make 3-D 
measurements. See section 7.12.3 on page 397 for more information. 

Zone
Enables the zone tool, used to select a region on a view. See section 7.12.2 on 
page 394 for more information. 

Hide 3-D Cursor
Hides the 3-D Cursor tool in all views.

Hide Zone
Hides the zone tool in all views.
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2.4.8 Components 

Figure 2-16  The Components dialog box

The Components menu (see Figure 2-16 on page 64) contains commands that set 
display parameters for the active view. The Components menu commands are the 
following:

Beam Simulation Window 
Opens the Beam Simulation Window, used to simulate the trajectories and 
dimensions of ultrasonic beams generated by conventional and phased array 
probes in a user-defined geometry. See section 7.7 on page 363 for more 
information. 

Indication Table Window
Opens the Indication Table Window, used to manage indication information and 
to create reports. See section 6.2 on page 324 for more information. 

Firing Sequencer Window
Opens the Firing Sequencer Window, used to modify the order in which the 
ultrasonic beams are fired. See section 4.14 on page 289 for more information. 

TomoView Manager Window 
Opens the TomoView Manager Window, used to select the mode and access the 
group, scan, and layout parameters. See section 2.6 on page 73 for more 
information. 
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FFT Window 
Opens the FFT Window, used to calculate the Fast Fourier transformation. See 
section 10.9 on page 473 for more information. 

Palette and Software Gain Window
Opens the Palette and Software Gain Window, used to set the software gain and 
to dynamically change the color palette’s maximum and minimum values. See 
section 7.5 on page 349 for more information. 

Scan and Mechanical Settings Window 
Opens the Scan and Mechanical Settings Window, used to define the scan and 
perform the settings for the mechanical scanning system. See section 3.11 on 
page 148 for more information. 

Phased Array Calibration Window
Opens the Phased Array Calibration Window, used to calibrate the phased array 
beams. See section 4.3 on page 245 for more information. 

TOFD Manager Window 
Opens the TOFD Manager Window, used to analyze time-of-flight diffraction 
inspection data. See section 7.6 on page 350 for more information. 

UT Settings Window 
Opens the UT Settings Window, used to configure the ultrasonic setup 
parameters. See section 3.10 on page 117 for more information. 

SNR Analysis Window
Opens the SNR Analysis Window, used to compute the signal-to-noise ration 
indicators. See section 7.8 on page 368 for more information. 

Position Dependent Setup 
Opens the Position Dependent Setup Window, used to synchronize the different 
setup and data files on predefined encoder positions. See section 5.4 on page 315 
for more information. 
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2.4.9 Window Menu

Figure 2-17  The Window menu

The Window menu (see Figure 2-17 on page 66) contains commands that manage 
windows. The Window menu commands are the following:

Cascade
Arranges the windows so that they overlap. The title bar of each window remains 
visible, making it easy to select any window.

Tile
Arranges the windows side by side, so that each window is completely visible 
and none overlap.

Close All Files (.rdt)
Closes all currently opened data files. 

Opened Window
Choosing a name from this list makes an opened document window active. All 
document windows currently opened are listed, including those that have been 
reduced to icons.

2.4.10 Help Menu

Figure 2-18  The Help menu

The Help menu (see Figure 2-18 on page 66) contains commands that provide access 
to information about TomoView.
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Help
Opens a window providing access to complete TomoView documentation.

About
Opens a dialog box indicating which version and edition of TomoView you are 
running. See Figure 2-19 on page 67.

Figure 2-19  The About TomoView dialog box

2.5 Toolbars

The TomoView toolbars contain buttons that are used as shortcuts for frequently 
accessed dialog boxes or commands.

The toolbars are located by default at the top of the window but can be dragged 
anywhere as a floating toolbar on the screen. Inversely, you can drag and dock a 
floating toolbar to a window edge. 

To hide or show a toolbar

 On the Toolbars menu, select or unselect the desired toolbar.

2.5.1 Component Toolbar

The Component toolbar, shown in Figure 2-20 on page 68 contains buttons to access 
basic TomoView components (see Table 5 on page 68 for details).

Edition
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Figure 2-20  The Component toolbar

Table 5  The Component toolbar buttons 

Icon Component Description

Beam Simulation To simulate the trajectories and dimensions of 
ultrasonic beams generated by conventional and 
phased array probes in a user-defined geometry.

Firing Sequencer To modify the order in which the ultrasonic beams 
are fired.

TomoView Manager To select the mode and access the group, scan, and 
layout parameters.

Fast Fourier 
Transform

To calculate the Fast Fourier transform FFT.

Gain Information To set the software gain and dynamically change 
color palette maximum and minimum values.

Scan and Mechanical 
Settings

To define the scan and to perform the settings for 
the mechanical scanning system

Phased Array 
Calibration

To calibrate all phased array beams.

TOFD Manager To analyze time-of-flight diffraction inspection 
data.

Screen Capture To take a capture of the current display, which 
then can be saved as a .bmp file. 

UT Settings To configure the ultrasonic setup parameters.

OmniScan File 
Converter

To create a TomoView data file from an OmniScan 
data file (.opd, .oud) and to open the TomoView 
file (.rdt).
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2.5.2 Document Toolbar

The Document toolbar (see Figure 2-21 on page 69) contains standard document 
management functions to open and save files, and to manage arrangements of 
multiple document windows (see Table 6 on page 69).

Figure 2-21  The Document toolbar

The Document toolbar is not available in the Lite edition.

SNR Analysis Utility To compute the signal-to-noise ratio indicators.

Indication Table To manage indication information and create 
reports.

Binarizer To convert a view into a two-color threshold-
based representation.

Position Dependent 
Setup 

To synchronize the different setup and data files 
on predefined encoder positions. 

Table 6  The Document toolbar buttons 

Icon Function Description

 Open To open a standard Open dialog box, used to 
select and load a data file or a predefined setup.

Table 5  The Component toolbar buttons (continued)

Icon Component Description
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2.5.3 View Toolbars

The View toolbars (see Figure 2-22 on page 70) contain various commands related to 
the management and properties of the views (see Table 7 on page 71 for details). 

Figure 2-22  The View toolbars

 Save As To open a standard Save As dialog box, used to 
browse through folders, type a new file name, if 
necessary, and then save the active setup.

 Cascade To arrange the document windows in a cascade 
pattern.

 Tile Horizontally To arrange the document windows in horizontal 
tiles.

 Tile Vertically To arrange the document windows in vertical 
tiles.

 Close All Data Files To close all opened data files.

Table 6  The Document toolbar buttons (continued)

Icon Function Description
70    Chapter 2

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Table 7  The View toolbar buttons 

Icon Name Function

Zoom tool To select and zoom in a specific region on a view.

3-D Cursor tool To make 3-D measurements on a C-scan view by 
clicking and dragging. Also works on Top/Side/End 
views.

Zone tool To select a region on a top, side, end, or C-scan view by 
clicking and dragging.
Tip: When the Zone tool is not selected, press and hold 
the CTRL key, and then click and drag on a view to 
perform the same task.

Move tool To move the graphical data relative to the view frame.

Split view 
horizontally in two 

To divide the active view into two views with the same 
horizontal dimension.

Split view vertically 
in two

To divide the active view into two views with the same 
vertical dimension.

Split view in four To divide the active view into four views with the same 
horizontal and vertical dimensions.

Delete view To delete the active view.

Empty view To remove the contents of the active view.

Maximize view To maximize the size of the active view by hiding the 
other views. Clicking this button when the view is 
already maximized restores the view to its original size 
and displays the other views.

Edit view properties To open the View Properties dialog box, used to 
configure the parameters of the active view.

Edit view contents To open the Contents dialog box, used to select the 
data type and the view type to be displayed in the 
active view.
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Toggle echo 
dynamics curves 

To toggle the display of the echo dynamics curve on 
the active view. This button is available only for top, 
side, end, and C-scan views.

Toggle view 
information group 1 

To toggle the display of information group 1 in the 
active view (reference cursor parameters by default).

Toggle view 
information group 2 

To toggle the display of information group 2 in the 
active view (measurement cursor parameters by 
default).

Toggle view 
information group 3 

To toggle the display of information group 3 in the 
active view (by default, parameters related to the 
combination of the reference and measurement 
cursors).

Toggle view 
information group 4 

To toggle the display of information group 4 in the 
active view (3-D cursor, Zone tool, and acquisition 
parameters by default).

Hide view 
information groups 

To hide all information groups displayed in the active 
view.

Edit view 
information groups 
contents

To open the Information Groups dialog box, used to 
edit information group contents, that is, the parameter 
sets displayed in the information groups. You can also 
double-click a reading to open this dialog box.

Envelope Toggles the activation of the envelope mode for the 
online and off-line A-scan view.

Rectify data To apply a software rectification to unrectified signal 
data. 

Fit image to view To display the complete data contents of the active 
view.

Fit inspection 
domain to view 

To display the complete inspection domain in the 
active view.

Toggle reference 
cursor

To toggle the display of the active view reference 
cursors.

Table 7  The View toolbar buttons (continued)

Icon Name Function
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2.6 The TomoView Manager Dialog Box

The TomoView Manager dialog box is where you pilot the operations in TomoView. 
The TomoView Manager contains the mode, group, scan, and layout parameters that 
you need to define before performing an inspection (see Figure 2-23 on page 74).

Toggle measurement 
cursor

To toggle the display of the active view measurement 
cursors.

Add a note To add a callout on top of a view to point out and 
comment on a given element. You can freely move and 
resize the callout. The callout notes are included in 
screen captures but cannot be saved.

US Customary units In TomoView Lite and TomoViewer editions only, 
changes length measurement units to US Customary 
when pressed. 

Table 7  The View toolbar buttons (continued)

Icon Name Function
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Figure 2-23  Components of the TomoView Manager dialog box

2.7 Document Windows

TomoView is a multi document software. This means that you can open one or more 
documents at a time. However, only one setup can be open at a time. The data for an 
opened document appears in a document window (see Figure 2-24 on page 75).

UT Settings
To define beams, signal processing and 
acquisition

Mode button
see section 3.1 on page 84

Advanced Calculator
To define probe, wedge, part, and

calculate beams

Predefined layouts

Scan and mechanical settings
To configure encoders and define scan 
sequences

View properties
To define data type, cursors, rulers, 
zoom bars, overlays, colors, and units

Acquisition speed

Scan sequences
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Figure 2-24  Example of a document window containing three views

You can cascade or tile multiple document windows using the Document toolbar (see 
section 2.5.2 on page 69), or using the Windows menu.

You can add, remove, or empty views in a document window using the View toolbars 
(see section 2.5.3 on page 70), or using the View menu. Two or more views appear 
side by side, never overlapping. You activate any view by clicking on it. 

2.8 Layouts

In TomoView, a layout is an organization of two or more views appearing in the 
document window. Layouts offer extensive flexibility in how you present your 
inspection data.

TomoView offers a set of ten layouts that are available from the TomoView Manager 
dialog box for quick selection (see Figure 2-25 on page 76). You can also select one of 
the layouts from the Layout menu. A set of ten layouts is saved in an .rst file.

Title bar
Shows name of data

file and layout

Views
Data presented in one

of the view types

View border
Click and drag to

resize the view
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Figure 2-25  The set of ten layouts

2.9 The Status Bar

The status bar appears at the bottom of the document windows (see Figure 2-26 on 
page 76) when you select Toolbars > Status Bar on the menu.

Figure 2-26  The Status Bar

The status bar displays the following information relative to the state of the system:

Scan
Position on the scan-axis from the encoder or from the 1-axis internal clock. 

Index
Position on the index-axis from the encoder or from the 2-axis internal clock.

Set Encoders
Sets the encoder position of the Scan and Index axes to the Preset values defined 
in the Scan and Mechanical settings dialog box.

Currently selected layout

Set of ten available layouts
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Acq. speed
Maximum acquisition speed with the current settings, directly related to current 
PRF value as specified by the following equation:

where:

PRF:
The pulse repetition frequency is set in the UT Settings dialog box > Digitizer 
tab > PRF group > Current parameter.

Scan Resolution:
The scan resolution is set in the UT Settings dialog box > Digitizer tab > Data 
group > Resolution parameter.

You can adjust the Acq. speed by changing the PRF value (in the Digitizer  tab of the 
UT Settings dialog box) and the Resolution value (in the Scan  tab of the Scan and 
Mechanical Settings dialog box). Note however that a too high Acq. speed value can 
generate ghost echoes. For example, with a scanner that can move a probe up to 
100 mm/s and a scan resolution of 2 mm, in the TomoView Manager, set the Acq. 
speed to 100 mm/s. TomoView automatically sets the PRF value to 50 Hz. For manual 
encoder inspections, set the Acq. speed value between 50 mm/s and 100 mm/s.

Mode
Current mode (from Setup, Inspection, or Analysis).

Al.
Alarm indicator state for the Alarm 1, Alarm 2, and Alarm 3 (from left to right) 
described in Table 8 on page 78. The alarm indicators appear only when you 
define at least one alarm in the Alarms tab of the UT Settings dialog box.

Acq. speed PRF Scan resolution=
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Link
Indicator color reporting the state of the communication with the acquisition unit 
as given in Table 9 on page 78.

Acq. Unit
Internal temperature of the acquisition unit (for OmniScan and FOCUS LT only). 
The background color of the value changes when it is out of the normal value 
range as shown in Table 10 on page 78.

Table 8  Alarm (Al.) indicator states 

Indicator color Alarm state

Active

Not active

Not defined

Table 9  Link indicator states 

Indicator color Communication with acquisition unit

Correctly established

Not established

No attempt

Table 10  Interpretation of OmniScan MX and FOCUS LT internal temperature 

Status Internal temperature 
range [°C]

Indicator example

Normal operation 0 to 59.9

High temperature 60 to 61.9

Overheating warning 62 to 64.9
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2.10 UT Settings Dialog Bar

Clicking the UT Settings button ( ) on the Main and TomoView Manager toolbars 
toggles the visibility of the UT Settings dialog box. The UT Settings dialog box 
contains eight basic tabs: General, Gate, TCG, Digitizer, Pulser/Receiver, Probe, 
Alarms, and I/O (see Figure 2-22 on page 70). When you use a phased array unit such 
as the Focus LT, this dialog box also includes two additional tabs: Transmitter and 
Receiver. For more details on the different tabs of the UT Settings dialog box, see 
section 3.10 on page 117.

Figure 2-27  The UT Settings dialog box

2.11 Scan and Mechanical Settings Dialog Box

Clicking the Scan and Mechanical Settings button ( ) on the Main and TomoView 
Manager toolbars toggles the visibility of the Scan and Mechanical Settings dialog 
box that contains four basic tabs: Scan, Scan Controls, Encoders, and Options (see 
Figure 2-28 on page 80). When working in Master mode, this dialog also includes two 
additional tabs: MCDU Control and MCDU I/O. For more details on the different 
tabs of the Scan and Mechanical Settings dialog box, see section 3.11 on page 148. 

Critical overheating 65 to 67.9

Automatic shutdown ≥ 68 N/A

Table 10  Interpretation of OmniScan MX and FOCUS LT internal temperature 

Status Internal temperature 
range [°C]

Indicator example
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Figure 2-28  The Scan and Mechanical Settings dialog box

2.12 The View and Pane Properties

Clicking the View and Pane Properties button ( ) on the Main and TomoView 
Manager toolbars toggles the visibility of the View and Pane Properties dialog bar. 
The Info, Display, Echo Dynamics, Overlay, Palette, Data Source, Parameters, Units, 
View Linking, Rebounds, and Strip tabs are available in the Pane Properties dialog 
box, depending on the data type contained in the active view. For more details on the 
different tabs of the View and Pane Properties dialog bar, see section 3.12 on 
page 162. 

Figure 2-29  The View Properties dialog box
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2.13 Docking Dialog Boxes

TomoView allows you to dock the main dialog boxes on a window border. A docking 
dialog box aligns itself with an edge of the window. By dragging its title bar, you can 
move the docking dialog box anywhere on the screen as a floating dialog box. 
Inversely, you can drag and dock the floating dialog box to one of the window edges. 
See Figure 2-30 on page 81. 

Figure 2-30  Floating (top) and docking (bottom) of a dialog box

Using the thumbtack function, you can specify if the dialog box remains displayed, or 
not when you open other docking dialog boxes. For this purpose, you can click the 
thumbtack icon, located in the upper-left corner of the dialog box, to toggle between 
the two following options:

Double-click the title
bar to dock the dialog

box

Click to float the dialog
box
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Tacked option icon ( )
The dialog box remains open when you open other docking dialog boxes.

Untacked option icon ( )
The dialog box closes when you open other docking dialog boxes.
82    Chapter 2

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
3. TomoView Concepts and Operational Mode

The TomoView user interface shown in Figure 3-1 on page 83 provides toolbars, 
dockable dialog boxes, a data display, and a status bar.

Figure 3-1  The main elements of the TomoView user interface

Toolbars

Dockable vertical
dialog box

Document window
with data display

views

Status bar

Dockable
horizontal dialog

box
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3.1 About the TomoView Modes

TomoView has three modes:

Setup
Mode in which you set up the various hardware and software parameters 
(ultrasonic, scan, and window layout settings). TomoView starts in the Setup 
mode when it is connected to an acquisition unit. 

Inspection
Mode in which you perform data acquisition. The Inspection mode is available 
only when TomoView is connected to an acquisition unit. 

Analysis
Mode in which you carry out analysis and produce reports for recorded data. 
TomoView starts in the Analysis mode when it is not connected to an acquisition 
unit. 

To go from one mode to the another, on the TomoView Manager, click the mode 
button (see Figure 3-2 on page 85). The mode button changes depending on the 
current mode. 
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Figure 3-2  Switching between modes

The status bar, visible when selecting Toolbars > Status Bar on the menu, includes the 
Mode parameter that indicates the current mode (see Figure 3-3 on page 85). 

Figure 3-3  The mode indicated in the status bar

3.2 About Groups

In TomoView, a group is a named configuration of parameters required to generate 
one or more ultrasonic beams. A group can use conventional or phased array probes. 
A group can pulse and receive on the same probe or use two different probes to pulse 
on one and receive on the other. A probe can be used by more than one group. 

Setup mode 
To configure TomoView for the 
setup and the parts to inspect

Inspection mode
To perform the inspection and 

acquire data

Analysis mode
To analyze the acquired data TomoView Manager 

mode button

Mode
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Assembling different beams in one group allows you to set the same parameters for 
all the beams at one time. This also allows you to display images built from all beams 
(ex: sectorial scan). Depending on the application, it might be helpful to use different 
settings for different beams (ex: different band-pass filters), justifying the creation of 
one group per beam.

You can create, delete, select, and configure groups from the TomoView Manager 
dialog box (see Figure 3-4 on page 86).

Figure 3-4  The Group area in the TomoView Manager dialog box

For example, you can create a first phased array group to generate a linear scan, a 
second group to generate a sectorial scan, and then display them concurrently in a 
layout (see Figure 3-5 on page 87). 

Name of the active group

Add a group

Delete a group

Basic A-scan parameters

Basic C-scan parameters
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Figure 3-5  Example of two scans from two different groups

3.3 About the Advanced Calculator

The Advanced Calculator is an Evident software that comes with TomoView. You start 
the Advanced Calculator from the TomoView Manager dialog box, by clicking the 

Beam Calculator button ( ). From TomoView, use the Advanced Calculator to 
specify the probe and wedge used in the inspection, the geometry and material of the 
inspected part, and the beam configuration (see Figure 3-159 on page 219). The 
Advanced Calculator calculates the beams and returns the information to TomoView. 

Refer to the Advanced Calculator User’s Manual (p/n: DMTA080-01EN) for more details.

3.4 About Scan Sequences

In TomoView, you can configure scan sequence parameters and save them as a named 
scan. You can quickly select a scan sequence from the TomoView Manager. TomoView 
comes with useful predefined scan sequences (see Figure 3-6 on page 88). 
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Figure 3-6  Predefined scan sequences available from the TomoView Manager

You can edit, delete, or create a scan sequence configuration (including predefined 
scan sequences) using the Scan and Mechanical Settings dialog box (see Figure 3-7 
on page 88). The scan sequence data is saved in the hardware setup (.acq) file.

Figure 3-7  The Scan tab of the Scan and Mechanical Settings dialog box for the 
Encoded - 2 axis predefined sequence

The predefined scan sequences are:

Free running
Scan where data is acquired at the rate specified under PRF on the Digitizer tab 
of the UT Settings dialog box. The data is recorded at only one position, at the 
origin of the scan and index axes.

Encoded - 1 axis
Scan using one position encoder to determine the position during the acquisition 
along a linear path. The data is recorded at every interval (corresponding to the 
resolution setting) along the path from the start position to the end position of the 
scan axis.

Scan and mechanical settings
To configure encoders and define scan 
sequencesPredefined scan sequences
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Encoded - 2 axis
Scan using two position encoders to determine the position during the acquisition 
on a bidimensional surface-scan. The data is recorded at every interval 
(corresponding to the resolution setting) along the path from the start position to 
the end position of both the scan and index axes.

Inter. clock - 1 axis
Scan using the internal clock (PRF) to determine the position during the 
acquisition along a linear path. The data is recorded at every interval 
(corresponding to the resolution setting) along the path from the start position to 
the end position of the scan axis.

Inter. clock - 2 axis
Scan using the internal clock (PRF) to determine the position during the 
acquisition on a bidimensional surface-scan. The data is recorded at every interval 
(corresponding to the resolution setting) along the path from the start position to 
the end position of both the scan and index axes.

When you modify or delete predefined scan sequences, you can restore them by 
opening a default hardware setup (.acq) file.

3.5 About Probe Orientation Conventions

This section describes the conventions used in TomoView for the probe and the 
wedge orientations relative to the axes.

The probes and wedges are illustrated schematically as shown in Figure 3-8 on 
page 90. The probe element number of a phased array generally increases from the 
back to the front of the probe/wedge assembly. 
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Figure 3-8  Example of a probe and a wedge illustration

In rare applications where the probe connector or wire is physically interfering with 
other inspection setup components, you can mount the probe in a reverse position on 
the wedge. To notify TomoView about this, in the Advanced Calculator, select the 
Reverse primary axis check box under the Probe area. The check box is automatically 
selected when you select a reversed wedge model.

The probe skew is defined as the angle between the primary axis of the probe and the 
scan-axis. The skew has a value of 0° when the beam direction points parallel to the 
scan axis in the positive direction. The skew angle increases clockwise. 

In the example shown in Figure 3-9 on page 91, the angle beam probe is moving on 
the inspected part along the scan axis following a raster scan pattern. The beam 
direction is parallel to the scan axis. Consequently, the probe skew is equal to 0°.

Probe

Elements

Wedge

Probe

Elements

Wedge

Probe/wedge front

Probe/wedge front

Side view

Top view

Beam direction
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Figure 3-9  Raster scan plate inspection with 0° probe skew

In the example shown in Figure 3-10 on page 92, the probe is moving on the inspected 
part along the scan axis. The beam direction is along the ultrasound axis but the beam 
electronic scanning direction is parallel to the index axis. Consequently, the probe 
skew is equal to 90°.
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Figure 3-10  Plate inspection with 90° probe skew

In the example shown in Figure 3-11 on page 92, the angle beam probe is moving on 
the inspected part along the scan axis and the beam direction is parallel to the scan 
axis. Consequently, the probe skew is equal to 0°.

Figure 3-11  Rivet inspection with 0° probe skew
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In the example shown in Figure 3-12 on page 93, a mechanical scanner is holding two 
angle beam PA probes and two angle beam UT probes. The four angle beam probes 
are moving on the inspected part along the scan axis and the along the weld. The 
direction of the beam is parallel to the index axis. Consequently, the probe skews are 
equal to 90° or to 270°. 

Figure 3-12  Weld inspection using a scanner with 90° and 270° probe skews

In the example shown in Figure 3-13 on page 94, the angle beam probes are moving 
on the inspected disc or wheel circumference along the scan axis. The beam direction 
is parallel to the scan axis. Consequently, the probe skews are equal to 0° or to 180°.
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Figure 3-13  Disc or wheel inspection with 0° and 180° probe skews

In the example shown in Figure 3-14 on page 95, two facing angle beam PA probes are 
moving on the inspected tube along the scan axis along the weld. The scan axis, 

represented by the symbol  in Figure 3-14 on page 95, is oriented in the third 
dimension perpendicular to the plan of the figure and increases toward inside the 
page. The beam directions are parallel to the index axis. Consequently, the probe 
skews are equal to 90° and 270°.
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Figure 3-14  Tube weld inspection with 90° and 270° probe skews

3.6 About Layouts

In TomoView, a layout is an organization of two or more views appearing in the 
document window. Layouts offer extensive flexibility in how you present your 
inspection data.

TomoView offers a set of ten layouts that are available from the TomoView Manager 
dialog box for quick selection (see Figure 3-15 on page 96). You can also select one of 
the layouts from the Layout menu. A set of ten layouts is saved in an .rst file.

12.00°12.08° Probe Index 
Offset > 0

Index axis

Probe skew = 

90°

Probe Index 
Offset < 0

Probe skew = 270°

0
Scan axis
TomoView Concepts and Operational Mode    95

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Figure 3-15  The set of ten layouts

The predefined layouts button of the TomoView Manager dialog box allows you to 
quickly load a set of predefined layouts adapted to an application (see Figure 3-16 on 
page 96). 

Figure 3-16  Selecting predefined layouts

3.7 About Views

A view displays the data for the current document in one of the data view types. 
Figure 3-17 on page 97 gives an example of a view showing an A-scan data view type.

Currently selected layout

Set of ten available layouts

Predefined layouts button
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Figure 3-17  Example of an active A-scan view

A view contains the following elements:

Title bar
The title bar of the active view is highlighted with a light-blue background as 
shown in Figure 3-18 on page 97.

Figure 3-18  Example of the title bar of an active view

The title bar contains information describing the data in the view:

<Group Number><Group Name>[S: <Skew Angle>, A: <Beam Angles>]
where:

<Group Number>: Sequential number identifying the group (e.g.: Gr1).

<Group Name>: Name of the group (ex: Sectorial 1)

<Skew Angle>: Skew angle of the current group (e.g.: 90°) taking into account 
the skew angle of the probe and of the beam.

<Beam Angles>: Angle or range of beam angles (e.g.: 40° to 60°)

Title bar

Zoom bar

Ruler

Cursor

Note

Gate
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Rulers
The rulers are scales displayed at the left and at the bottom of a view. The color of 
the ruler identifies the axis. The units and number of precision digits can be 
adjusted using the View and Pane Properties > Units tab. 

Zoom bar
Zoom bars appear at the left and bottom edges of a view. Each zoom bar contains 
a zoom box, which enables you to set the visible part of the view. The zoom box 
shows the relative position and the proportion of data currently visible in the data 
display area relative to the contents of the entire inspection domain. The color of 
the zoom bar identifies the axis on the different views. You can resize the zoom 
bar by dragging its ends to zoom in or out and scroll the zoom bar to see other 
parts of the data. You can use the mouse wheel with or without the Ctrl key to 
scroll the zoom bars.

Grid
The grid consist of thin horizontal and vertical lines that are displayed in the 
curve area to facilitate measurements and correspondence with the rulers. 
Depending on the distance between lines, the grid might be coarse, medium, or 
fine. The grid can be activated and customized using the View and Pane 
Properties > Display tab. 

Cursors
The cursors are thin horizontal and vertical lines that are used to measure the data 
displayed in views and to identify a region in the view. A label indicates the exact 
measure of each cursor. Two cursor types are available for a view: reference and 
measurement cursors. 
You can quickly display the reference cursor by double-clicking in a view with the 
left mouse button. Similarly, double-click in a view with the right mouse button to 
display the measurement cursor.

Notes
A note is a callout text box note that points to an element of the view (see 

Figure 3-17 on page 97 for an example). The Note icon button ( ) can be used 
to add a new note. 
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3.7.1 Data View Types

The data view types are graphical representations of the ultrasonic data. There are 
three types of ultrasonic views:

1. Basic views:
• A-scan
• S-scan

2. Volumetric views: 
• Side (B)
• Top (C)
• End (D)
• Polar

3. Scrolling views:
• Scrolling B-scan
• Scrolling strip chart (position)
• Scrolling strip chart (amplitude)

You can select the data view type for a view by selecting the view, and then selecting 
View > Contents on the menu or pressing Shift + Enter to open the Contents window 
(see example in Figure 3-19 on page 99). In the Contents dialog box, the available data 
view types depend on various parameters including the acquisition type 

(conventional  or phased array ) and the mode (Setup, Inspection, or Analysis).

Figure 3-19  Example of data view types available for phased array data in the 
Contents window
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A view appears empty when its content (conventional  or phased array ) is not 
available in the current data file.

3.7.1.1 Basic Views

The following is a description of each type of view:

A-scan View

The A-scan view is the basis for all other views. It is a representation (view) of the 
received ultrasonic pulse amplitude versus time of flight (ultrasonic path), or a 
waveform. The Online A-Scan view (see example in Figure 3-20 on page 100) is a 
real-time display of the received ultrasonic pulse amplitude versus the time of flight. 
A peak in the signal is associated with the echo of a defect or a discontinuity in the 
specimen. Peaks at the start and the end of the ultrasonic axis are generally associated 
with the echo of the specimen’s entry surface and the back-wall.

Figure 3-20  Example of an Online A-Scan view
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Sectorial Views

Sectorial views are only available for phased array channels.

Sectorial views are representations of the juxtaposition of the A-scans associated with 
each focal law of a phased array scan. They present a 2-D view of the sector covered 
by the scan. Figure 3-21 on page 101 shows the three types of sectorial representation 
for a given data set. 

Figure 3-21  Example of Uncorrected (top-left), USound corrected (top-right) and 
VC sectorial (bottom-left) scans
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The three sectorial scan view types are:

Uncorrected sectorial scan
View where the A-scan of each focal law (see top-left view of the example in 
Figure 3-21 on page 101) is represented by a horizontal line on which the 
amplitude is color-coded. The displayed real-time data shows the focal laws 
stacked (vertically in the example) in the order that they were generated. 

Sectorial scan (Usound corrected)
View similar to the uncorrected sectorial scan except that the A-scans are 
corrected for delay and true depth so that their positions are accurate relative to 
the ultrasonic axis (see top-right view of the example in Figure 3-21 on page 101). 

VC sectorial scan
Volume-corrected view similar to the uncorrected sectorial scan except that the 
A-scans are corrected for delay and refracted angle so that the positions are 
accurate relative to the ultrasonic and scan axes. A typical S-scan sweeps through 
a range of angles using the same focal distance and elements. The horizontal axis 
corresponds to the projected distance (test-piece width) from the exit point for a 
corrected image and the vertical axis corresponds to the depth (see bottom-left 
view of the example in Figure 3-21 on page 101). 

When an azimuthal scan is defined by the calculator, the sectorial-scan view 
represents an angular sector where each line of this view corresponds to the A-scan of 
a different angle. Therefore, when a linear scan is defined, the sectorial-scan view 
represents the beam movement. Each line then corresponds to an A-scan of different 
aperture. Finally, when a depth scan is defined, the sectorial-scan view then 
represents the beam focusing at different depths. Each line then corresponds to a 
different A-scan.

3.7.1.2 Volumetric Views

Volumetric views are color-coded images built from successive A-scans projected on 
different planes defined by the ultrasound, scan, and index axes. The most important 
views, similar to 2-D projections of a technical drawing, are presented in Figure 3-22 
on page 103.
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Figure 3-22  Example of ultrasonic views [Top (C), Side (B), and End (D)] with probe 
skew angle of 90°

In Figure 3-22 on page 103, if the probe skew angle is 0° (or 180°), the Side (B) view 
becomes the End (D) view, and vice versa. The Side (B) view is defined by the depth 
and probe-movement axes. The End (D) view is defined by the depth and the 
electronic-scan axis.

Side (B)

The Side (B) view (see Figure 3-23 on page 104) is a two-dimensional graphical 
representation of the recorded data. One of the axes is the scan axis; the other is the 
uncorrected ultrasonic (USound) path. The position of the displayed data is related to 
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the encoder positions at the moment of acquisition. At a given position on the 
projected image, the color corresponds to the maximum amplitude at this position as 
detected in the considered index-axis range.

Figure 3-23  Example of Side (B) view

Top (C)

The Top (C) view (see Figure 3-24 on page 105) is a two-dimensional graphical 
representation of the recorded data displayed as a top view of the test specimen. One 
of the axes is the scan axis; the other is the index axis. The position of the displayed 
data is related to the encoder positions at the moment of acquisition. At a given 
position on the projected image, the color corresponds to the maximum amplitude at 
this position as detected in the considered true-depth range.
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Figure 3-24  Example of Top (C) view

End (D)

The End (D) view (see Figure 3-25 on page 106) is a two-dimensional graphical 
presentation of the recorded data. One of the axes is the defined index axis; the other 
is the uncorrected ultrasonic (USound) path. The position of the displayed data is 
related to the encoder positions at the moment of acquisition. At a given position on 
the projected image, the color corresponds to the maximum amplitude at this position 
as detected in the considered scan-axis range.
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Figure 3-25  Example of End (D) view

Polar View

The Polar view is available only when the geometry of the specimen is identified as 
cylindrical. This can be done by selecting Part and Overlay > Part Definition in the 
menu, and defining the part as Cylindrical. 

The Polar view (see Figure 3-26 on page 107) is a two-dimensional representation of 
the recorded data in a realistic cylindrical geometry. It is used in analysis mode. The 
polar coordinates ID depth or OD depth (radial coordinate) and Position (angular 
coordinate) are calculated taking into account the previously defined specimen.
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Depending on the orientation of the scan axis relative to the cylindrical geometry, and 
the skew angle of the considered probe, the polar view is the cylindrical equivalent of 
either the VC-Side (B) view or the VC-End (D) view. Either distance units (mm or in.) 
or rotational units (°) can be used and displayed in the circumferential direction of the 
cylinder.

The polar view is only supported for skew angles of 0°, 90°, 180°, and 270°; for data 
with other skew angle values, however, the Cylindrical Correction View Information 
can be used to calculate the correct position and size of indications. 

Figure 3-26  Example of a Polar View

3.7.1.3 Scrolling Views 

Scrolling views add data dynamically, from an active acquisition unit to a scrolling
axis. 
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Scrolling B-Scan

In the Scrolling B-Scan view (see Figure 3-27 on page 108), each A-scan is represented 
by a horizontal line on which the amplitude is color-coded. The lines are added 
consecutively in real time, from the bottom, so that the resulting image scrolls up. 
Therefore, the data view shows the real time vertically, versus the time of flight of the 
received ultrasonic pulse horizontally. 

Figure 3-27  Example of Scrolling B-Scan view
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Strip Charts - Amplitude and Position Scrolling Views 

The amplitude and/or position scrolling views are only available when the options for 
the recording of the selected amplitude and/or position data are enabled in the Gates 
section of the UT Settings dialog bar (see section 3.10.2 on page 123).

In an amplitude or position scrolling view, the data of the signal crossing the 
associated gate is represented by a color-coded Scrolling View which is displayed 
inside a Strip Chart view. The Scrolling View can be configured using the 
Configuration tab of the View and Pane Properties dialog bar (available only when a 
Strip Chart view is selected). 

Figure 3-28  Example of Scrolling View 

3.7.2 View Contextual Menu

Once a data view type is assigned to a view, display options are available from a 
contextual menu. The contextual menu appears when you right-click on the title bar 
of a view (see example shown in Figure 3-29 on page 110). 
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Figure 3-29  Example of the contextual menu for a view

The view contextual menu changes depending on the view type. The possible view 
contextual menu commands are the following:

Data commands

Set Active Data Group Settings
Provides one or more choices (Active Group, Active Law, and Active Gate) to set 
the view to show data for the active item (group, beam, or gate), automatically 
following changes of the active selection.

Set Single Slice (Projection)
Toggles between single- and projection-data display in the view. The command is 
also available in the Data Source tab of the View Properties dialog box.

Set Data Group Representation
Provides one or more choices for sectorial scans (Sector (S) and TOF), and for 
C-scans (Stacked, Single Beam, Strip, and Scrolling Strip).
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Restore Initial Gates 
Only available in Analysis mode, this selection is used to reposition all gates 
either for the current group or for all groups to the positions where they were 
when the data was originally acquired.

Set Dynamic Mode
Only available in setup and Inspection mode, this selection is used to toggle 
between the dynamic state and the analysis state (offline).

Show commands 

Show Info Group
Toggles the appearance of the information groups below the title bar of the view. 

Show Gate Selectors
Toggles the appearance of the gate selectors on the selected view. 

Show Zoombar and Rulers
Toggles the appearance of the zoom bars and the rulers. The command is also 
available in the Display tab of the View Properties dialog box. 

Show Echo Dynamics
Toggles the appearance of the echo-dynamics signals next to the relevant axis. The 
echo-dynamic curves show the maximum amplitude (or minimum position) 
between the measurement and reference cursors (see example shown in 
Figure 3-30 on page 112). The command is also available in the Echo Dynamics 
tab of the View Properties dialog box.

Show Skip Overlays
Toggles the appearance of the overlay lines representing the skips. The command 
is also available in the Overlay tab of the View Properties dialog box.

Show Rebounds
Toggles the appearance of the rebounds (see example shown in Figure 3-30 on 
page 112).
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Figure 3-30  Examples of shown echo dynamics curves and rebound

Show Gates
Toggles the appearance of the gates. This option is only available for A-scan and 
S-scan views. The command is also available in the Overlay tab of the View 
Properties dialog box.

Display mode commands

Set 1:1 Ratio Display Mode
Displays the view with the same scale on both axes. The command is also 
available in the Display tab of the View Properties dialog box.

Set Smoothing Display Mode
Enables the smoothing function. The command is also available in the Display tab 
of the View Properties dialog box.

Set Volume Corrected Display Mode
Toggles the A-scan correction for delay and refracted angle so that the positions 
are accurate, relative to the ultrasonic and scan axes.

Rotate View
Rotates the data so that the two axes interchange. The command is also available 
in the Display tab of the View Properties dialog box.

Echo dynamics Rebound
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Color palette commands

The following contextual menu commands are also available from the Palette tab of 
the View Properties dialog box. These commands are available on the menu only 
when the view supports a color palette. 

Select Color Palette
Used to select one of the available color palettes (Rainbow, Gray, Thickness, or 
Balanced).

Set Color Palette Compression Mode
Toggles the state of the color palette compression. When you reduce the range for 
the 256 colors of a palette without compression, you remove colors from the 
palette. With compression, all palette colors are compressed in the new range.

Edit Color Palette
Opens the Palette Editor dialog box, where you can edit existing color palettes or 
create new color palettes.

Display preferences commands

Save Display Preference
Saves the current view properties as the default properties.

Apply Display Preference
Applies the default view properties to the currently selected view. 

On the keyboard, press F4 and SHIFT-F4 to respectively activate the Save Display 
Preference and the Apply Display Preference commands.

Ultrasound axis commands

Reverse USound Axis
Reverses the direction of the ultrasound axis. The command is only available for 
the A-scan view. The command is also available from the Display tab of the View 
Properties dialog box.
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Change USound True Depth / Half Path
Toggles the ultrasound axis unit between true depth and half path. The command 
is only available for the A-scan view when the ultrasound axis is set to either true 
depth or half path.

Change USound TOFD / Time
Toggles the ultrasound axis ruler between TOFD and time. The command is only 
available for the A-scan view when the ultrasound axis is set to either time of 
TOFD.

You can set the type and the units of USound axis in the Units tab of the View 
Properties dialog box.

Calibrate UT Axis
Available only in Analysis mode, opens the dialog box for the calibration of the 
True Depth, the Half Path, or the TOFD on the ultrasound axis. The command is 
also available from the Units tab of the View Properties dialog box and in Setup 
mode, from the General tab of the UT Settings dialog box.

3.8 About Readings and Information Groups

TomoView computes reading values for various parameters to help you analyze your 
ultrasonic data. Readings are calculated using cursor, zone, acquisition, or segment 
(3-D Cursor) parameters.

You can select to display one or more groups of readings at the top of a view (see 
Figure 3-31 on page 115). 
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Figure 3-31  Example of reading groups appearing at the top of a view

Refer to section  4.10 on page 276 for more information on how to customize the 
reading groups. 

3.9 About Gates

A gate is a signal processing tool that isolates a time domain region of the received 
ultrasonic signal on which further processing is performed. In an A-scan view, a gate 
appears as an horizontal line ending at both ends with short vertical lines. The vertical 
position of the gate line indicates the signal detection threshold (see Figure 3-32 on 
page 116). When the rectification of the receiver is set to RF, the threshold of a gate can 
be positive or negative.

Reading groups
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Figure 3-32  Example of gate A in an A-scan

In an S-scan view, the gate start and end positions appear as horizontal dashed lines 
(see Figure 3-33 on page 116). When the time base mode is set to true depth, the area 
in between is the gated zone for all beams. When the time base mode is set to half 
path, the area between the dashed lines is the gated zone for the current beam only. 
The dashed lines of the gate automatically move to the appropriate location when you 
change the current beam.

Figure 3-33  Example of gate A in an S-scan

Gate threshold

Gate length

Gate start position

Gate start

Gate length
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TomoView supports up to five gates (gate I, gate A, gate B, gate C, and gate D), 
allowing you to perform complex signal processing. The function of gate I, the 
interface gate, is to identify the interface of the inspected part. Gate A, B, C, and D are 
general purpose gates (see section 4.11.5 on page 287). Each gate has its own color to 
easy identification (see Figure 3-34 on page 117).

Figure 3-34  Gate colors

Gate C and gate D are available only with a Focus LT acquisition unit.

3.10 UT Settings Dialog Box

Clicking the UT Settings button ( ) on the Main and TomoView Manager toolbars 
toggles the visibility of the UT Settings dialog box. The UT Settings dialog box 
contains eight basic tabs and two additional tabs: General, Gate, TCG, Digitizer, 
Pulser/Receiver, Probe, Alarms, and I/O (see Figure 2-22 on page 70). When you use 
a phased array unit such as the Focus LT, this dialog box also includes two additional 
tabs: Transmitter and Receiver. For more details on the different tabs of the UT 
Settings dialog box, see section 3.10 on page 117.

This section describes the different tabs available in the UT Settings dialog box. 
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Figure 3-35  The UT Settings dialog box

All beams
When this checkbox is activated, modifying a parameter causes all focal laws to 
be affected by the modification.
If this checkbox is not selected, modifying a parameter causes only the active focal 
law to be affected by the modification.

Interleaved
Used to change the firing order of the different focal laws (see section 4.14 on 
page 289 for more information on using this function). 

Linear merged
Selecting this check box activates the linear merged mode, which performs the 
dynamic merging of the individual firings. (For proper data display, this mode 
should only be used with 0° linear focal laws). 

3.10.1 General Tab

The General tab (see Figure 3-36 on page 118) contains options that are used to 
configure the basic ultrasonic parameters.

Description of the General tab

Figure 3-36  The General tab
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The General tab is subdivided into the Gain, Time base and Auto Values group 
boxes.

Gain group box

Figure 3-37  The Gain group box

Group
Sets the gain value in decibels (dB) for the receiver of the active group. The 
group gain is added to the beam gain (when a phased array unit is connected 
to the system). See Figure 3-37 on page 119. 

When the TCG (time-corrected gain) function is used, the gain programmed 
in the TCG curve (see section 3.10.3 on page 127) is added to this gain value to 
produce the total input gain.

Beam
Sets the gain value in decibels (dB) for the active beam’s receiver. 

Apply
This box displays the applied gain, considering the sum of the group and 
focal law gain.

Ref.
This box displays the reference gain that you have set by using the Set 
Reference button.

Auto Set
This button automatically sets the amplitude of the echo between the cursors 
to the value specified in the Ref. amplitude box.

Set Reference
This button transfers the Apply value into the Ref. box.

Reset Beam
This button resets the gain of the active beam to 0 dB. 
TomoView Concepts and Operational Mode    119

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Time base group box

Figure 3-38  The Time base group box 

Start
Sets the delay in the material at which the acquisition starts. This value can be 
displayed in distance or time units, according to the unit chosen in the Mode 
drop-down list box. See Figure 3-38 on page 120. 

Range
Sets the acquisition range in the material (according to the unit set in the 
Mode drop-down list box).

Note: The maximum range value is determined by the maximum number of 
samples allowed for an A-scan.

Mode
Selects the unit mode used to set the time base:

• Time: Time base values are expressed in ultrasonic time-of-flight units: 
µs (microseconds).

• Full path: Time base values are expressed in distance units: in. (inches) or 
mm (millimeters). The value entered is equal to the time of flight 
multiplied by the ultrasonic velocity in the material.

• Half path: Time base values will be expressed in distance units: in. 
(inches) or mm (millimeters). The values are equal to half the total 
distance traveled by the ultrasonic wave (Full path divided by 2).

• TOFD: Time base values will be expressed in distance units, in function 
of the TOFD calibration: in. (inches) or mm (millimeters).

• True depth: Time base values will be expressed in distance units: in. 
(inches) or mm (millimeters). The calculated true depth is a function of 
the beam angle in the material.
120    Chapter 3

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
This button appears in a phased array setup when True depth is selected in the
Mode drop-down list box. Clicking this button takes the true depth Start and
Range values of the active focal law and applies the corresponding half path Start
and Range values to all focal laws in the active group.

This button appears in a phased array setup when True depth is selected in the
Mode drop-down list box. Clicking this button takes the true depth Start and
Range values of the active focal law and applies them to focal laws in the active
group.

Set Auto 
This button sets the ultrasonic scale (Start and Range of the Time base group box)
according to the values specified in the Full Range Start and Full Range boxes of
the Auto Values dialog box.

Set Range
This button sets the ultrasonic scale (Start and Range of the Time base group box)
according to the positions of the reference and measurement cursors in an online
A-scan view.

Auto Values group box

Figure 3-39  The Auto Values group box

Ref. amplitude
Indicates the reference amplitude that has been specified in the Auto Values 
dialog box (opened with the Auto Values button). See Figure 3-39 on 
page 121.
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Full range start
Indicates the full range start on the ultrasonic axis, according to the value 
specified in the Auto Values dialog box.

Full range
Indicates the distance on the ultrasonic axis corresponding to the full range, 
according to the value specified in the Auto Values dialog box.

Auto Values
This button opens the Auto Values dialog box, used to define the automatic 
values. See Figure 3-40 on page 122.

Figure 3-40  The Auto Values dialog box

In this dialog box, enter the Ref. Amplitude, Ultrasound start and Ultrasound range 
values that should be programmed when the Set Auto button is clicked. Click Ok to 
accept values, or Cancel to return to previous values. 

Calibrate
This button opens a dialog box, used to calibrate the ultrasonic velocity or delay 
according to the reference cursor position. See Figure 3-41 on page 123.

To use this function, select a side view (corrected for the angle) and then place the 
cursors on two reflectors at known positions and click the Calibrate button. In the 
calibration dialog box that pops up, enter the know depths of the two selected 
reflectors and the values shown in the Results section of this dialog box will be 
calculated automatically. To accept these values, click Ok. TomoView will 
program the calculated values. 
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Figure 3-41  The Calibrate dialog box in True Depth mode

3.10.2 Gate Tab

The Gate tab (see Figure 3-42 on page 124) contains options that are used to define the 
detection gate parameters. Detection gates are used to extract information from the 
A-scan and form the C-scan data groups.

Whenever a gate is enabled, it is represented on the corresponding A-scan view by a 
horizontal line with small vertical lines on both ends. In addition, each time a 
detection gate is defined and enabled, a new data group is added in the left section of 
the Contents dialog box.

You can define four detection gates for each channel, in addition to the 
synchronization gate. Gate I is the synchronization gate, and gates A, B, C, and D are 
the acquisition gates. The A-scan signal that is viewed and acquired can be 
synchronized on pulse or on echo in the main gate. Each gate is defined by a starting 
position, a gate length, a threshold level, and an alarm level. Detection occurs when a 
portion of the signal exceeds the threshold level during the time interval specified by 
the starting position and gate length.
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The setting of the gates can be done either by filling the Start and Length boxes for 
each gate, or by positioning both cursors (reference and measurement) on the A-scan 
and clicking the set button of the gate, or interactively. The basic procedure to follow 
for the definition of the gates is described later in this section. For the procedure to 
define gates see section 4.11 on page 282. 

Description of the Gates tab

Figure 3-42  The Gates tab

The Gates tab contains the following group boxes:

Set Gate buttons
Sets the start position, the length, and the threshold of synchronization of the
selected gate according to the position of the reference cursor and the
measurement cursor in time, and the reference cursor in level.

Start
Sets the start position of the corresponding gate. The position is expressed in the
unit chosen in the Mode drop-down list box of the General tab.

Length
Sets the length of the corresponding gate. The length is expressed in the unit
chosen in the Mode drop-down list box of the General tab.

Threshold
Sets the threshold level of the corresponding gate. The level is expressed as a
percentage (%) of the full screen height.

Alarm level
Sets the alarm level of the corresponding gate. The level is expressed as a
percentage (%) of the full screen height.
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POS and AMP checkboxes
When enabled, the position and amplitude data of the corresponding gate will be
recorded. 

POS B - POS A
When enabled, a differential-position data group in which the position of a signal
above gate A threshold is subtracted from the position of a signal above gate B
threshold will be recorded.

Type
This drop-down combo box allows the user to select one of the following
detection types according to the detection gate: 

Maximum 
The position and amplitude data of the detected maximum signal peak inside 
the gate will be recorded (respectively P1 and A1 in Figure 3-43 on page 125). 

Figure 3-43  Maximum gate detection

Crossing 
The position data of the first peak crossing the gate and the amplitude data of 
the maximum detected signal peak inside the gate will be recorded. 
(respectively P1 and A1 in Figure 3-44 on page 126). 
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Figure 3-44  Crossing gate detection

First Peak Maximum
The position and amplitude data of the first signal peak detected inside the 
gate will be recorded (respectively P1 and A1 in Figure 3-45 on page 126). 

Figure 3-45  First peak maximum gate detection
126    Chapter 3

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
First Peak Crossing 
The position data of the first peak crossing the gate and the amplitude data of 
the first detected signal peak inside the gate will be recorded (respectively P1 
and A1 in Figure 3-46 on page 127). 

Figure 3-46  First peak maximum gate detection

Link 
This drop-down combo box can be used to synchronize the start of the 
corresponding gate with respect to the previous gate. 

3.10.3 TCG Tab

The TCG tab (see Figure 3-47 on page 128) contains the options that can be used to set 
the time-corrected gain (TCG) for the current group. The TCG function operates by 
modifying the receiver gain during data acquisition to compensate for the attenuation 
of the ultrasonic wave in the material. The TCG curve defines the gain values that are 
added to the group gain. 
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Description or the TCG tab

Figure 3-47  The TCG tab

The TCG tab contains the following group boxes:

Enable
This check box alternately activates and deactivates the TCG function according 
to the values set on the TCG tab.

Display
This check box alternately displays and hides the TCG curve in an area covering 
25 % of the A-scan view.

Reset
This button resets the TCG curve, by clearing all currently defined points. 

Ref. level
Sets the wanted reference level, in percent, for the next point.

Maximum slope
Displays the maximum slope between two TCG points.

Position
Indicates the position of the TCG points on the ultrasonic axis. These points are 
represented by red dots when the TCG curve is displayed at the top of the 
corresponding A-scan view. The position is expressed in the unit chosen in the 
Units box of the Units tab of the Pane Properties dialog box.

Gain
Indicates the gain level for the TCG points.

Add Point
This button adds a new point to the TCG curve which will be placed in a position 
corresponding to the maximum amplitude that is read between the reference and 
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measurement cursors. The gain associated with the TCG point will correspond to 
the theoretical gain required to reach the reference level.

Remove Point
This button removes the selected point from the grid. The TCG curve is then 
recalculated according to the remaining points. The gain and slope parameters 
are updated for the current position.

New Line
This button adds a new point to the TCG curve, following the rightmost point.

Import/Export
These buttons allow the user to export the TCG curve applied to the current 
group or import a TCG curve from a .csv file. For more information on the TCG 
curve import/export function, see section 4.7.4 on page 260. 

3.10.4 DGS tab 

The DGS tab contains the parameters that can be used to configure a DGS curve. The 
distance gain size (DGS) is method for sizing indications based on a calculated DGS 
curve for a given transducer, material, and a known reflector size. For more 
information on how to use the DGS, see section 4.9 on page 267. 

Figure 3-48  The DGS tab

3.10.5 Digitizer Tab

The Digitizer tab (see Figure 3-49 on page 130) contains options that are used to set 
the basic digitizer and data-acquisition parameters. The Digitizer tab is subdivided 
into the Digitizing, PRF, Data Sample Size, Data, and Multipeak group boxes. 
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Description of the Digitizer tab

Figure 3-49  The Digitizer tab

The Digitizer tab (see Figure 3-50 on page 130) contains the following:

Figure 3-50  The Digitizing group box 

Frequency
Allows the user to select the digitizer frequency, specified in megahertz 
(MHz). 

Recurrence
The recurrence is the firing recurrence frequency (pulse repetition frequency, 
or PRF) which is defined independently for every group. The effective 
recurrence is the number of ultrasonic pulses generated per second. 

Averaging
Indicates the number of A-scans acquired for each A-scan that is returned. 
The returned A-scan is obtained by calculating, for each sample, the average 
value over all the acquired A-scans.

The averaging can be used to reduce the effect of noise; however, using a 
great number of acquisitions for the averaging will decrease the maximum 
acquisition rate.

Synchro
Selects the synchronization mode:
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• Pulse: the acquisition is synchronized on the ultrasonic firing pulse.
• Echo: the acquisition is synchronized on the echo crossing gate 1.
• External: the acquisition is synchronized by an external signal.

The PRF group box (see Figure 3-51 on page 131) contains the following:

Figure 3-51  The PRF group box

Target
This box can be used to select whether or not the PRF should be set to the 
maximum possible value in hertz, or to a custom defined value which 
TomoView will try to match as closely as possible. 

Current
Indicates the current PRF value in hertz.

Data Sample Size group box (see Figure 3-52 on page 131): 

Figure 3-52  The Data Sample Size group box

The selected data sample size indicates the resolution of the amplitude 
digitalization. This resolution will influence the size of an elementary data sample 
and therefore the size of the resulting data file. 
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The Data group box (see Figure 3-53 on page 132) contains the following choices: 

Figure 3-53  The Data group box

Samples
Indicates the number of samples per data acquisition, that is, the number of 
points that compose the A-scan. This number is directly related to the Range 
(General tab) and Digitizing frequency values. If the Units parameter is in 
time (microseconds), multiplying the Range value (in seconds) by the 
Digitizing frequency value (in hertz) will give the number of points. This has 
an effect on the Compression.

Resolution
Indicates the digitizer resolution in the UT scale unit.

Compression

This box is used to set the digitizer compression ratio. You can reduce the 
sample quantity, and thus the data file size, by keeping the position of the first 
sample with the maximum amplitude (see example shown in Figure 3-54 on 
page 133). This box is only available for certain acquisition units. 
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Figure 3-54  Example of a compression ratio of 4

A-scan
Creates the A-scan data group.

A-scan video
Creates the video A-scan data group. (This data cannot be acquired.)

Multipeak
Creates a compressed A-scan showing only peak data.

Conditional
Selecting this option will allow the A-scan to be recorded only when an alarm 
was triggered. For more details about this function, see section 4.15 on 
page 292.

The Multipeak group box (see Figure 3-55 on page 133) has the following choices:

Figure 3-55  The Multipeak group box
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Source
Selects the peak detection source (this box is available only if the Peak check 
box is selected).

Quantity
Sets the number of peaks used to produce the A-scan peak data group. This 
box is available only if the Peak check box is selected.

Threshold
Sets the level for the peak detection.

3.10.6 Pulser/Receiver Tab

The Pulser/Receiver tab (see Figure 3-56 on page 134) contains options that you can 
use to configure the pulser and receiver used for the inspection. 

Description of the Pulser/Receiver tab

Figure 3-56  The Pulser/Receiver tab

The Pulser/Receiver tab is subdivided into the following sections: Configuration, 
Pulser, Receiver, and Filter group boxes. See Figure 3-56 on page 134. 
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Configuration group box

Figure 3-57  The Configuration group box

Configuration
Indicates the current group configuration from the following choices: 
Conventional pitch-and-catch, Phased array pulse-echo, Phased array pitch-
and-catch, Conventional pulse-echo, and TOFD. 

Pulser group box

Figure 3-58  The Pulser group box

Connector 
For a Conventional UT group, this box allows you to select the connector that 
will be used for the pulser. For a Phased array group, it indicates the number 
of the first element used in emission. 

Voltage (all groups)
Sets the pulse voltage of the pulser, which is the same for all groups, in volts 
(V).

Pulse width
Sets the pulse width of the pulser in nanoseconds.
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Receiver group box

Figure 3-59  The Receiver group box

Connector 
For a Conventional UT group, this box allows you to select the connector that 
will be used for the receiver. For a Phased array group, it indicates the 
number of the first element used in reception.

Scale Type
Indicates the receiver type between LIN (linear receiver), LOG (logarithmic 
receiver), and LOGDAC (receiver with a logarithmic DAC function). 

Rectification
Allows you to select the rectification type between RF (the A-scan signal is 
displayed without any rectification), HW+ (only the positive part of the signal 
is kept), HW- (only the negative part of the signal is kept), and FW (the 
negative part of the signal is brought back to the positive part). 

Filters group box

Figure 3-60  The Filters group box

High-pass
Selects the frequency of the high-pass filter used to filter the group signal. 

Low-pass
Selects the frequency of the low-pass filter used to filter the group signal. 
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Smoothing
Selects the video filtering of the rectified signal in order to smooth the curve. 
The smoothing function creates an envelope on the rectified signal to 
eliminate the effects of the original RF signal (alternating positive and 
negative amplitudes).

3.10.7 Probe Tab

The Probe tab (see Figure 3-61 on page 137) contains options that are used to set the 
parameters of the probes used for the inspection. 

Description of the Probe tab

Figure 3-61  The Probe tab

The Probe tab is subdivided into Material and Interface, Selection, Position, and 
Beam Orientation group boxes. 

Material and interface group box

Figure 3-62  The Material and Interface group box

Wave type
Allows you to select the wave type: Longitudinal or Transverse.
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Sound velocity
Sets the sound velocity in the inspected material for each wave type. This 
value must be determined with precision as it will be used to convert time 
units into distance units. 

Wedge delay
Sets the total wedge delay of the probe. The wedge delay is calculated as 
follows:

Selection group box

Figure 3-63  The Selection group box

Show total
Disables the probe and law parameters modification.

Modify probe
Allows you to modify the probe parameters. 

Modify beam
Allows you to modify the beam parameters. 

T/R radio buttons 
When a Pulse-Echo group is selected, the T button transfers the pulse-
receiver probe parameters. When a Pitch-and-catch, or a TOFD group is 
selected, the T button transfers the pulser probe parameters and the R button 
transfers the receiver probe parameters. 

Wedge delay Ultrasound path in wedge
Sound velocity in wedge
-------------------------------------------------------------=
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Position group box

Figure 3-64  The Position group box

Scan offset
The scan offset represents the distance between the beam direction and the 

scan origin, which can be positive or negative (click on the  button to view 
a graphical representation of this offset). This box sets the scan offset of the 
probe or the beam depending on whether the Modify probe or Modify beam 
option was chosen in the Selection group box. See Figure 3-64 on page 139.

Index offset
The index offset represents the distance between the beam exit point and the 

index origin, which can be positive or negative (click on the  button to view 
a graphical representation of this offset). This box sets the scan offset of the 
probe or the beam depending on whether the Modify probe or Modify beam 
option was chosen in the Selection group box. 

Separation
Specifies the distance between the probes (available only with an active TOFD 
group).

Parallel/perpendicular to beam radio buttons 
Specifies the beam orientation as parallel or perpendicular to the scan 
direction (available only with an active TOFD group).

Adjust Resolution
This button opens the dialog box shown in Figure 3-65 on page 140 which can 
be used to adjust the data group resolution. 

(1) Min. 
Sets the minimal offset difference, ensuring that there will be no data 
fusion among the data groups, although acquisition gaps may occur. 
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(2) Max.
Sets the minimal offset difference, ensuring that there will be no 
acquisition gap among the data groups, although data fusion may occur. 

(3) Average 
Sets an average of the offset difference, therefore providing a good 
compromise between acquisition gaps and data fusion among data 
groups.

(4) User 
Sets a user-defined offset difference, allowing you to select a data group 
resolution between the minimum and maximum offset differences. 

Figure 3-65  The Adjust Scan data group resolution dialog box

Beam orientation group box

Figure 3-66  The Beam orientation group box

Refracted angle
Defines the refracted angle of the probe beam.
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The refracted angle () (see Figure 3-67 on page 141) is calculated from the 
probe incidence angle (), sound velocity in wedge, and sound velocity in 
material according to the following formula (Snell’s law):

Figure 3-67  Refracted angle

Skew angle
Sets the skew angle of the probe, which is defined as the angle between the 
primary axis of the probe and the scan axis. For more details on the probe 
orientation convention, see section 3.5 on page 89.

3.10.8 Alarms Tab

The Alarms tab (see Figure 3-68 on page 141) contains options that are used to define
the alarms. For more information on defining the alarms, see section 4.12 on page 288.

Description of the Alarms tab

Figure 3-68  The Alarms tab

sin
sin

----------- Sound velocity in wedge
Sound velocity in material
---------------------------------------------------------------=




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The Alarms tab contains the following group boxes:

Output line
Selects the alarm output line to be used when the alarm condition is met.

Conditions group box
Not

When selected, these check boxes add the operator NOT to the next condition 
to the right.

Synchro
This box is used to select the logical operator relative to the synchronization 
gate (Gate I): Unused and Detect.

Gates A, B, C, and D
These boxes are used to select the conditions relative to gates A, B, C, and D 
(Unused and Detect). 

Alarm conditions are defined independently for each channel. 

3.10.9 I/O Tab

The I/O tab (see Figure 3-69 on page 142) contains options that are used to enable and 
disable the analog input and output lines. Description of the I/O tab

Figure 3-69  The I/O tab

The I/O tab is subdivided into the following group boxes: Analog Inputs, General 
Outputs, and Digital out. 
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Analog inputs group box

Figure 3-70  The Analog inputs group box

Name
Selecting these check boxes enables the corresponding analog input line. The 
name of the analog input line can be edited by double-clicking the current 
name. See Figure 3-70 on page 143. 

Multiplier
Defines the multiplier value to convert the current analog input value (in 
volts) to a meaningful value.

Offset
Defines the offset value to convert the current analog input value (in volts) to 
a meaningful value. The offset value is added after the Multiplier value.

Measure type
Defines the type of measurement made with the associated analog input line.

Unit
Defines the unit of the converted value of the associated analog input line.

Current
Displays the current value (in volts) of the associated analog input line.

Converted
Displays the converted value of the associated current value of the analog 
input line.
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General outputs group box

Figure 3-71  The General outputs group box

General outputs
Selecting the check boxes enables the corresponding general output lines 
(only available for the MS5800 acquisition unit). See Figure 3-71 on page 144.

Digital out group box 

Figure 3-72  The Digital out group box

Active
Selecting this checkbox enables the External trig (Trig out) function, which 
sends an external signal to the Digital Output No. 2 (DOUT2) each time an 
individual focal law is fired. 

The Digital Output No. 1 (DOUT1) is connected to the External Pace (Pace out) 
function, which sends an external signal before each set of focal laws is fired. This 
function is always activated, whether or not the Active checkbox is enabled. For 
example, if firing on encoders, then each time the encoder changes position, the firing 
sequence will be triggered and a signal sent to DOUT1. 
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3.10.10 Transmitter Tab 

The Transmitter tab (see Figure 3-73 on page 145) is used to specify the parameters of 
each element of a focal law in transmission.

Figure 3-73  The Transmitter tab

The Transmitter tab contains the following group boxes:

First element
Specifies the first active element of the transmitter in the considered focal law.

Current element
Selects an element of the probe as the current element. You can also select an 
element by clicking the corresponding bar on the Delay or Amplitude graphs.

On
Selecting or clearing this check box respectively turns on or off the element in 
transmission.

Holding down the SHIFT key while clearing the On check box turns off all the elements 
in transmission at once.

Link transmitter/receiver checkbox
When this check box is selected, modifying the First Element value for the 
transmitter will also set the same value for the receiver. 

Insert
Used to insert an element to be used as a transmitter in the active focal law. The 
new element is inserted before the currently selected element.
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Delete
Deletes the currently selected transmitter element from the active focal law.

Delay (ns)
The Delay box is used to specify the transmission delay applied to the current 
element in nanoseconds (ns).

The bar graph represents the transmission delay law for the different elements. 
The blue bar indicates the element being modified, that is, of which the 
parameters are displayed. The green bars indicate the delays of the other active 
elements. The inactive elements are left blank.

Amplitude (V)
The Amplitude box is used to specify the pulse amplitude applied to the element 
in volts (V).

3.10.11 Receiver Tab 

The Receiver tab (see Figure 3-74 on page 146) is used to specify the parameters of 
each element of a focal law in reception.

Figure 3-74  The Receiver tab

The Receiver tab contains the following:

First element
Specifies the first active element of the receiver in the considered focal law.

Current element
Selects an element of the probe as the current element. You can also select an 
element by clicking the corresponding bar on the Delay or Gain graphs.
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On
Selecting or clearing this check box respectively turns on or off the element in 
reception.

Holding down the SHIFT key while clearing the On check box turns off all the 
elements in reception at once.

Link transmitter/receiver checkbox
When this check box is selected, modifying the First Element value for the 
receiver will also set the same value for the transmitter. 

Insert
Used to insert an element to be used as a receiver in the active focal law. The new 
element is inserted before the currently selected element.

Delete
Deletes the currently selected receiver element from the active focal law.

Sum gain
This combo box allows you to select whether the Sum gain should be 
automatically set or be manually defined.

Current 
Indicates the current hardware Sum gain value. 

Delay (ns)
The text box is used to specify the reception delay applied to the element in 
nanoseconds (ns).

The bar graph represents the reception delay law for the different elements. The 
blue bar indicates the element being modified, that is, of which the parameters are 
displayed. The green bars indicate the delays of the other active elements. The 
inactive elements are left blank.

Gain (dB)
The text box is used to specify the gain applied to the element in decibels (dB).

The bar graph represents the amplitude law in reception for the different 
elements. The blue bar indicates the element being modified, that is, of which the 
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parameters are displayed. The green bars indicate the amplitudes of the other 
active elements. The inactive elements are left blank.

3.11 Scan and Mechanical Settings Dialog Bar

The following section describes the Scan and Mechanical Settings. 

3.11.1 Description of the Sequence tab

Clicking the Scan and Mechanical Settings button ( ) on the Main and TomoView 
Manager toolbars toggles the visibility of the Scan and Mechanical Settings dialog 
box. The Scan and Mechanical Settings dialog bar contains four tabs: Scan, Scan 
Controls, Encoders, and Options (see Figure 3-75 on page 148). When a MCDU-02 is 
detected, this dialog box also includes two additional tabs: MCDU Control and 
MCDU I/O. See section 3.12 on page 162. 

Figure 3-75  The Sequence tab for Bidirectional sequence

Type
This list box is allows you to select the sequence type to be used for the inspection 
from the following choices: One-line scan, Free running, Bidirectional, 
Unidirectional, Helicoidal, Angular, and Custom. 

These inspection types are described in sections 5.1.1 on page 295 to 5.1.6 on 
page 304.

Fire on
This list box is used to select the trigger signal used to fire the ultrasonic pulses 
from Encoder, External signal, Internal clock, and Absolute position. 
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Scan reset 
Allows you to select the Scan axis reset options between the following options: 

None 
The Scan axis is never reset.

Modulo
The Scan axis is reset when the Scan encoder reaches the Stop position. 

Rot. Synchro
The Scan axis is reset when an external signal is received on the 
corresponding instrument I/O connector (also known as top tour). 

Index preset
Allows you to select the Index axis preset options from the following options: 

None 
No preset at acquisition end.

At acquisition end 
When the acquisition is stopped, the Start value for the index axis is set to the 
current index axis encoder position.

Angle 
If an Angular sequence type is chosen, the angle between the Mechanical axis and 
the Scan axis can be defined. 

Figure 3-76  The Scan tab with Angular sequence type

Deg./Index
If a Helicoidal sequence type is chosen, this box indicates the number of degrees 
of rotation for every index position. 
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Figure 3-77  The Scan tab with Helicoidal sequence type

Encoder
These boxes indicate the name of the encoder associated with each axis. The 
encoder names can be changed in the Encoder tab.

Start
These boxes are used to set the position on the scan and index axes where the 
inspection sequence is to start. These values can be positive or negative. 

Get
These buttons set the start value to the current encoder position for the associated 
axis.

Range
If the Range radio button has been selected, these boxes are used to set the range 
on the scan and index axes.

Stop
If the Stop radio button has been selected, these boxes are used to set the stop 
position on the scan and index axes.

In the case of an encoder sequence, all acquisitions for which the position is outside 
the inspection surface defined by the Start values and Stop values are ignored.

Resolution
These boxes are used to set the acquisition resolution for the scan and index axes. 
The resolution of the scan axis determines the spacing between the acquisitions. 
The resolution of the index axis, in the case of a surface scan, determines the 
separation between the scan lines.
150    Chapter 3

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Optimize
This button is enabled when, in the UT Settings dialog bar, the Linear merged 
mode option is selected. Depending on the selected skew angle, the optimal 
resolution for the relevant axis is automatically calculated (0° and 180° = scan axis 
resolution, 90° and 270° = index axis resolution).

Speed
In slave mode, this parameter has no implication.

In master mode, these boxes are used to set the speed that the motors should 
follow during inspection.

Whenever the motor movement for the Scan axis controls the data acquisition, the 
Scan axis Speed defines the required acquisition rate:

Unit
These boxes are used to select the unit of the corresponding axis in mm, in., or 
deg (°)

Preset
This combo box allows you to select when the corresponding encoder is to be 
reset during the sequence: 

Never 
The corresponding encoder is never reset.

On start
The corresponding encoder is reset when the acquisition is started.

External
The corresponding encoder is reset when an external signal is received on the 
corresponding instrument’s I/O connector. 

Preset value
These text boxes specify the encoder positions to be used with the Preset option 
or the Set button.

Set
These buttons set the encoder positions to the Preset value positions for the 
associated axis.

Acquisition rate Scan axis speed
Scan axis resolution
------------------------------------------------
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Apply
This button applies the current tab settings to the inspection sequence that is 
selected in the Scan name list box.

3.11.2 Scan Controls Tab

The Scan Controls tab contains options and indicators related to the acquisition 
sequence (see Figure 3-78 on page 152)

Figure 3-78  The Scan Controls tab

The Scan Controls tab is subdivided into Scans Order, Special Settings, Test 
Sequence, and I/O group boxes. 

Scans order group box
This group box lists the inspection sequences and their order of execution, and 
can be modified if the Use current scan only checkbox is not activated in the 
Special Settings group box. 

You can modify the sequence order by moving the selected inspection sequence 

up and down using the  or the  buttons.

Use current scan only
When this check box is selected, only the selected inspection sequence is 
performed during the acquisition. The current sequence can be selected in the 
Scan name list box.

Prompt for scan
When this check box is selected, the Inspection Parameters for Scan dialog 
box is displayed at the acquisition start (see Figure 3-79 on page 153) which 
you can use to skip a scan as well as to check and modify the sequence 
parameters if needed. 
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Figure 3-79  The Inspection Parameters for Sequence dialog box 

The Inspection Parameters for Sequence dialog box contains the same options as the 
Sequence tab, except that the sequence type cannot be saved (see section 3.11.1 on 
page 148 for more details). 

Stop Acquisition
Click this button to stop the inspection.

Skip Scan
Click this button to skip the current sequence and present the next sequence as 
defined in the Sequences order group box of the Sequence Controls tab. If the 
current sequence is the only one in the Sequences order group box, or the last 
one, the acquisition process is stopped.

Start Scan
Click this button to start the inspection.

Show file size
When this check box is selected, a message box appears at the acquisition start 
to indicate the estimated data file size that is required according to your 
acquisition parameters. See Figure 3-80 on page 153.

Figure 3-80  The File Size dialog box 
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Enable pause acquisition
By selecting this check, the inspection sequence can be paused during the 
acquisition by an external signal.

External signal - Start/stop 
Activates the digital input number 4 (DIN4) pin, for the start/stop of...

Test sequence group box 
This box groups command buttons used when an MCDU-02 unit is controlled by 
TomoView (master mode only).

Control section 
Start 

The  button starts the inspection and can be used to resume the 
sequence if the pause button is activated. 

Pause 

The  button pauses the inspection. 

Stop

The  button stops the inspection. 

If the Use current scan only checkbox is not selected in the Special settings combo 
box, and the inspection is stopped using the Stop button inside the Test Sequence 
combo box, after the data file acquired with the first sequence has been saved, 
TomoView will automatically return to inspection mode with the second sequence in 

the Sequences order list. However, if the inspection is stopped with the  button 
on the TomoView Manager toolbar, all the unfinished sequences are discarded.

I/O section
The indicators in this section give the user the current status of Rot. synchro, 
External reset, Pause acquisition and External acquisition input/output signals.
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3.11.3 Encoders Tab

The Encoders tab contains options related to the configuration of the encoders (see 
Figure 3-81 on page 155).

Figure 3-81  The Encoders tab

The Encoders tab contains the following options:

Save
When selected, this check box enables the system to record in a C-scan the 
position of a third encoder (alternate).

Name
These boxes are used to select the encoder associated with the Scan and the Index 
axes, and the Alternate encoder.

You can edit the default encoder names but not when Internal is selected.

Type
These boxes are used to select the encoder type from Pulse + (positive pulse) 
Pulse - (negative pulse), Quadrature, and Clock Dir. (clock direction). 

Resolution
This box is used to set the encoder resolution, that is, the number of encoder steps 
needed to move 1 mm (or 1 in.) in linear units, or 1° in angular units.

Invert
When one of these check boxes is selected, the sign of the corresponding encoder 
data is automatically inverted.

Calibrate
This button displays the Calibration of Encoder dialog box, used to calibrate the 
encoder resolution for the corresponding axis (see Figure 3-82 on page 156). 
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Figure 3-82  The Calibration of Encoder dialog box

The Calibration of Encoder dialog box is subdivided into Encoder, MCDU Control, 
and Scan Axis group boxes. 

Actual resolution
This box indicates the actual encoder resolution set in the Resolution box of 
the Encoders tab of the Scan and Mechanical Settings dialog bar.

Invert
This check box, when selected, inverts the count direction of the encoder.

Set
This button is used to set the encoder position to the value indicated in the 
Preset value box.

Preset value
This box displays the value entered in the Preset value box on the Sequence 
tab.

Figure 3-83  The MCDU dialog box 
156    Chapter 3

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Movement
These buttons are disabled in slave mode. In master mode, these buttons are 
used to manually control, with the mouse, the scanner movement on each 

axis.The  button moves the scanner backward, the  button moves the 

scanner forward, the  button stops the movement along the 
corresponding axis. See Figure 3-83 on page 156.

Tuning speed
This box indicates the maximum speed the scanner can reach when you are 
using the Movement buttons. This value is set on the MCDU Control tab.

Scan axis 

Figure 3-84  The Scan axis group box 

Use rotational synchro I/O
Select this check box to use an external rotation synchronization input/output 
signal to set the beginning and end of motion used for the calibration. See 
Figure 3-84 on page 157. 

Use external reset I/O
Select this check box to use an external reset input/output signal to set the 
beginning and end of motion used for the calibration.

Set Begin
This button sets the current position as the beginning of the motion used for 
the calibration.

Set End
This button sets the current position as the end of the motion used for the 
calibration.
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Set Distance (box)
This box indicates the distance covered by the motion on the axis to perform 
the calibration. When the motion is done, enter the appropriate distance 
value.

Set Distance (button)
This button is used to calculate the encoder resolution so that the actual 
position matches the expected distance you specify in the text box.

The units for the scan and index axes are the same as the ones used on the Encoders 
tab, which are defined on the Scan tab.

Calculated resolution
This box gives the encoder resolution calculated with the calibration.

OK
This button applies the calculated resolution in the Resolution box of the 
Encoders tab of the Inspection Sequences and Mechanical Settings dialog 
bar, and closes the dialog box.

Cancel
This button closes the dialog box without applying the calculated resolution.

Clear
This button resets the parameters of the dialog box to the default values.

Start
This text box indicates the start limit that defines the color palette associated 
with the third (Alternate) encoder position. In the alternate encoder C-scan 
view, all encoder values below the start value then have the same color.

Stop
This text box indicates the stop limit that defines the color palette associated 
with the third (Alternate) encoder position. In the alternate encoder C-scan 
view, all encoder values below the stop value then have the same color.

Preset
This text box specifies the encoder position to be used with the Set button.
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Unit
This text box is used to select the unit of the corresponding alternate encoder. 
The following units are available: mm, in., or degree.

Set
This button sets the alternate encoder position to the preset value position.

Position
This box indicates the current position of the alternate encoder.

3.11.4 Options Tab

Using the Options tab (see Figure 3-85 on page 159), you can set the automatic file 
saving options that are used when performing acquisition of ultrasonic data with the 
considered inspection sequences.

Figure 3-85  The Options tab

The Options tab is subdivided into File Naming Options, MCDU Custom File and 
External File group boxes. See Figure 3-86 on page 159.

Figure 3-86  The File Naming Options group box

Directory
Using this text box, you can specify the directory, with its complete path, that 
is then used for the automatic file naming. You can enter the directory name 
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either by typing it directly into the text box, or by clicking  and selecting 
the directory in the Browse for Folder dialog box that appears.

Root name
Using this text box, you can specify the root name that is to be used for the 
automatic file naming.

• The @ character inserts a counter, which will be automatically incremented in 
the file names. For example, typing test@ will produce test0.rdt, test1.rdt, 
test2.rdt, and so on.

• The # character adds the desired number of digits for repeats. For example, 
typing test@## will produce test000.rdt, test100.rdt, test200.rdt, and so on. 

• If a file already exists (for example, test000.rdt), then the new file will be 
saved with the following name: test001.rdt (first repeat of the test000.rdt file 
name).

Counter value
This box sets the start value of the counter that is inserted in the file name 
with the @ character.

Automatic
Selecting this option button activates the automatic file naming that does not 
require your confirmation.

Prompt
Selecting this option button deactivates the automatic file naming. With this 
option, the Save As dialog box appears at the end of the inspection sequence, 
prompting you to enter the file name you want.

Confirm
Selecting this option button activates the automatic file naming that requires 
your confirmation. With this option, the Save As dialog box appears at the 
end of the inspection sequence, prompting you to confirm the file name 
defined in the Root name box.

Figure 3-87  The MCDU Custom File group box
160    Chapter 3

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
MCDU Custom File
When working in master mode, if the Custom Scan was selected in the 
Sequence tab, this button opens a dialog box to modify the selected .gal file. 
This button is disabled in slave mode. See Figure 3-87 on page 160. 

Figure 3-88  The External File group box 

External File group box
Selecting this check box specifies the automatic file naming parameters (Root 
name, Directory) by an external text file. See Figure 3-88 on page 161. The 
external .txt file must have the following syntax:

[ACQUISITION]

FILENAME=“Root name”

PATH=“Directory”

See Figure 3-89 on page 161. 

Figure 3-89  Example of an External File in a Notepad window
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3.12 Scanner Parameters (Master Mode Only)

This section describes the options required to set the scanner parameters with 
TomoView. You must set the scanner parameters at least once for each application 
performed with a given scanner, but in most cases this should require only minor 
modifications.

The MCDU Control tab of the Scan and Mechanical Settings dialog bar contains the 
options used to display and manually control the position of the motors or encoders 
required in a sequence. This tab and its options are available in the TomoView 
window when an MCDU-02 unit is detected.

3.12.1 MCDU Control Tab

The MCDU Control tab contains the options to set the scanner parameters and 
manually control the position of the motors or encoders required in a sequence.

Figure 3-90  The MCDU Control tab

The MCDU Control tab is subdivided into SCN File, Advanced, Motor Control, and 
Motor State group boxes.

The SCN File text box: 

Figure 3-91  The SCN File group box 
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Scn file: Load
This button opens the Load Scanner dialog box, used to select and load a 
scanner file (.scn). MCDU Control tab settings are updated according to the 
selected scanner file. 

Scn file: Save
This button opens the Save Scanner dialog box, used to name and save the 
current MCDU Control tab settings in a scanner file (.scn).

The Advanced text box: 

Settings button
This button opens the Advanced MCDU Control dialog box, used to set the 
parameters for each axis. See Figure 3-92 on page 163.

Figure 3-92  The Advanced group box 

The Advanced MCDU Control dialog box (see Figure 3-95 on page 166) 
provides parameters related to servomotors. You can open the Advanced 
MCDU Control dialog box by clicking Settings in the MCDU Control tab.

The MCDU-02 servo can control two servomotors. The information on the 
position of the servomotor is provided by an encoder that must be associated 
with its movement.

Motor Control group box 
This group box sets the MCDU control parameters, used when performing 
motion in setup mode. See Figure 3-93 on page 163.

Figure 3-93  The Motor Control group box
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Name
These list boxes are used to select the motor to be assigned to each axis. The 
name of the motor can be edited.

Movement
These buttons are used to manually control the scanner movement on each 

axis and are used to move the scanner in different directions. The  button 

moves the scanner backward, the  button moves the scanner forward, the 

 button stops the scanner along the corresponding axis. 

Tuning speed
These boxes are used to set the maximum speed the scanner can reach, when you 
are using the Movement buttons in setup mode.

Invert polarity
Selecting these check boxes inverts the motor polarity of the corresponding 
axis.

 
This button moves the scanner to the position specified in the Destination 
box of the corresponding axis. 

This button moves the scanner by a distance corresponding to the distance 
specified in the Destination box of the corresponding axis.

Destination
These boxes are used to enter the position where the scanner moves on the 
corresponding axis when you click Go.

Joystick
When selected, you can use these check boxes to enable an external joystick to 
control the scanner movement on each axis.

Motor state group box
The indicators of this group box give the motor status of each axis. See Figure 3-94 
on page 165. The different indicators have the following meanings:
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On: 
When this indicator is green, the motor of the corresponding axis is turned 
on.

In motion: 
When this indicator is green, the motor is in motion on the corresponding 
axis. When the indicator is red, a motion error occurred with the motor of the 
corresponding axis. 

Figure 3-94  The Motor State group box 

Servomotors must be used in a closed loop by using encoder feedback. The first 
encoder is automatically assigned to the first motor, and the second encoder to the 
second motor.
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Figure 3-95  The Advanced MCDU Control dialog box for servomotors

The Advanced MCDU Control dialog box for servomotors contains the following 
options:

Scan, Index
These option buttons are used to select the axis for which you want to set the 
parameters: scan axis or index axis.

Motor type
This box indicates the motor type used for the selected axis:

Servo: The MCDU-02 servo can support two servomotors.
Inspection setting: Speed

This box is used to set the maximum speed the motor can reach when executing 
the inspection sequence.

 

166    Chapter 3

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Inspection setting: Accel.
This box is used to set the motor acceleration when executing the inspection 
sequence. The motor accelerates at the rate indicated until it reaches the 
maximum speed specified. The motor decelerates at the same rate when stopped.

Tuning setting: Speed
This box is used to set the maximum speed the motor can reach during system 
tuning.

Tuning setting: Accel.
This box is used to set the motor acceleration during system tuning. The motor 
accelerates at the rate indicated until it reaches the maximum speed specified. The 
motor decelerates at the same rate when stopped.

Precision
This box indicates the precision, in distance units, required when position 
feedback is provided by an encoder.

Coefficient: KP
This text box is used to set the proportional gain of the system compensation PID 
filter. Proportional control is a pure gain adjustment acting on the error signal to 
provide the driving input to the process. The KP term in the PID-controller is 
used to adjust the speed of the system.

Coefficient: KI
This box is used to set the integrator of the system compensation PID filter. 
Integral control is used to provide the required accuracy for the control system.

Coefficient: KD
This box is used to set the derivative term of the system compensation PID filter. 
Derivative action is normally introduced to increase the damping in the system. 
In effect, it applies the “brakes” in an attempt to prevent overshoot (or 
undershoot).

The above parameters must be set with particular attention. You must modify these 
parameters when manually tuning PID parameters for servomotors. 

Motion error
The check box, when selected, enables a protection function that stops the 
servomotors when a too large difference occurs between the target position and 
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the actual position. Using the Value text box, you can enter a specific tolerance 
value for the motion error protection, expressed according to the currently 
specified unit.

Encoder type
This box is used to select the encoder type from the following: Quadrature, 
Reversed Quadrature, Clock Dir., and Reversed Clock Dir. 

Wizard
This option has not yet been implemented in TomoView software. 

Terminal
This button opens the MCDU-02 Terminal window, which experts can use to 
enter low-level GALIL commands in order to program the system. It should be 
used only by an MCDU-02 expert or by a user following precise instructions 
given by the Evident NDT technical support personnel. 

Close
This button confirms your changes and closes the dialog box.

3.12.2 MCDU I/O Tab

The MCDU I/O tab contains the options for setting the MCDU-02 inputs and outputs. 
See Figure 3-96 on page 168. 

Figure 3-96  The MCDU I/O tab 
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You must set the input/output parameters at least once for each different scanner. As 
you cannot modify the input/output parameters of the MCDU-02 unit, you need a PC 
and the TomoView software to modify and save the I/O settings in the MCDU-02 
permanent memory. If you do not set the I/O parameters for your scanner, then the 
MCDU-02 unit uses the last settings that were saved or the scanner factory settings.

The MCDU I/O tab is subdivided into the Reset MCDU State, Last Error, Motor 1, 
Motor 2, Relays, and EEPROM group boxes. 

External abort
This indicator, when turned on in red, indicates that the STOP emergency button is 
pressed on the MCDU-02.

Reset MCDU state group box

Figure 3-97  The MCDU State group box

The MCDU State group box has the following check boxes. See Figure 3-97 on 
page 169.

Reset
This button resets the state of the MCDU-02: motion error, voltage applied to 
the motors, relays, etc. This command, however, does not reset the PID 
parameters or the encoder type. See Figure 3-97 on page 169. 

Last error group box 

Figure 3-98  The Last Error group box 
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The Last Error group box has the following check boxes. See Figure 3-98 on page 169.

This box displays the last system error that occurred. See Figure 3-98 on 
page 169. 

Motor 1, and Motor 2 group boxes

Figure 3-99  The Motor 1 and Motor 2 group box

The check boxes of these two group boxes (see Figure 3-99 on page 170) can be 
selected or cleared to enable or disable the four options described as follows 
according to the motor chosen.

High limit switch
When selected, this check box inverts the polarity of the corresponding motor 
limit switch (if applicable). 

Invert limit
When selected, this check box inverts the position of the corresponding motor 
limit switch (if applicable).

Invert home
When selected, this check box inverts the corresponding motor home signal 
(if applicable).

Invert index
When selected, this check box inverts the corresponding motor index signal 
(if applicable).

Find Home
In the case of custom applications, this button moves the scanner in such a 
way as to find the home signal.
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Find Index
In the case of custom applications, this button moves the scanner in such a 
way as to find the index signal.

Relays group box 

Figure 3-100  The Relays group box

The Relays group box has the following check boxes. See Figure 3-100 on page 171.

Relay 0 and Relay 1 

In the case of custom applications, these check boxes are used to control relays in 
the MCDU-02 unit. See Figure 3-100 on page 171. 

EEPROM group box 

Figure 3-101  The EEPROM group box 

The EEPROM group box has the following check boxes. See Figure 3-101 on page 171.

Burn
This button is used to save the current specific I/O settings (encoder type, 
motor polarity, etc.) in the MCDU-02 EEPROM permanent memory. The 
saved configuration is then used by default at MCDU-02 startup. 

If you do not click the Burn button, some settings could be lost when you quit the 
TomoView software.
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3.13 View and Pane Properties Dialog Bar

Clicking the View and Pane Properties button  on the Main and TomoView 
Manager toolbars toggles the visibility of the View and Pane Properties dialog bar. 
The Information, Display, Echo Dynamics, Overlay, Palette, Data Source, 
Parameters, Units, View Linking, Rebounds, and Strip tabs are available in the Pane 
Properties dialog box, depending on the data type in the active view. When the tab 
parameters are not applicable to a selected pane, the tab does not appear in the View 
and Pane Properties dialog bar. See Figure 3-102 on page 172.

Figure 3-102  The View and Pane Properties dialog box 

The View and Pane Properties dialog box is not available in the TomoView Lite Aero 
and TomoView Weld versions.

3.13.1 Information Tab

The Information tab (see Figure 3-103 on page 173) contains commands that can be 
applied to the active view or layout. 
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Figure 3-103  The Information tab

The Information tab (see Figure 3-103 on page 173) contains the following group 
boxes:

Title
This box identifies the title of the active view and can be used to change titles.

Bookmark
This box can be used to define the text to be displayed inside a pane when a view 
isn’t available on the current data file.

Reset
Clicking on the Reset button resets the Title to it original value, and also removes 
any defined Bookmark. 

Apply
When the bookmark contains code for advanced layout association, clicking this 
button applies the bookmark code. This button is disabled by default for standard 
users. 

Zoom Out
Zooms out the active view in order to show all data. 

Rectify Data
Applies a software rectification to the signal data.

Envelope
Alternately activates and deactivates the envelope mode for the active A-scan 
view.
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Save Layout
Saves the modifications made to the current layout.

Save Layout As
Opens the Save Current Layout As dialog box, used to save the current layout 
under the number and name of your choice.

3.13.2 Display Tab

The Display tab contains various options to modify the active view display and will 
change depending on the active view type. See Figure 3-104 on page 174.

Figure 3-104  The Display tab for an A-scan view

The Display tab is subdivided into Cursors, Zooms and Rulers, Grid, Group Gates, 
and Configuration group boxes.

Cursors group box
This group box encloses check boxes used to select display options related to the 
cursors. See Figure 3-105 on page 174.

Figure 3-105  The Cursors group box 
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Ref., Meas, and Gate 
Selecting one of these check boxes adds the Reference, Measurement, or Gate 
cursors to the view. Depending on the active view, these cursors can include:

Scan
Cursor for the scan axis.
Index 
Cursor for the index axis.
USound 
Cursor for the ultrasonic axis.
Ampl. 
Cursor for the amplitude axis.
Autotrack 
Autotracking measurement cursor that displays the amplitude of the 
ultrasonic cursor position.

TOFD 
Hyperbolic cursor for time-of-flight diffraction.

Polar coordinates 
Polar cursors (available only when Polar view is active).

Meas.
Adds the measurement cursors to the view (see previous Ref. check box).

Gate
Adds the gate cursors to the view (see previous Ref. check box). The gate 
cursors are black cursors showing the position of the gate selector.

Zooms and Rulers group box 

Figure 3-106  Zooms and Rulers group box 

The Zooms and Rulers group box has the following check boxes. See Figure 3-106 on 
page 175. 
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USound Enabled/Amplitude Enabled 
This check box enables the zoom bar on the Ultrasound/Amplitude axis. 
Zoom bar

Adds a zoom bar to the corresponding axis in the active view.

Ruler
Adds a ruler to the index corresponding axis in the active view.

Grid group box 

Figure 3-107  The Grid group box

The Grid group box has the following check box. See Figure 3-107 on page 176.

The Show button enables the Grid on the active A-scan view, and the Coarse, 
Medium, and Fine options are used to customize the grid density. 

Polar View Image Processing group box

Figure 3-108  Polar View Image Processing group box 

Depending on the inspection sequence resolutions on the scan or index axis, there 
might be positions where no data is shown due to the limited size of the color-
coded A-scan line. You can use the Peak holding or Interpolation image 
processing algorithms to fill these gaps. See Figure 3-108 on page 176.
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Peak holding
This algorithm looks for a maximum in amplitude and spreads this value 
over the selected number of samples (must be less than or equal to 50). This 
algorithm is optimized for polar views constructed from C-scan data.

Interpolation 
This algorithm spreads a sample over the selected number of samples (must 
be less than or equal to 50) to its left and right, until recorded data of a higher 
amplitude sample is detected. This algorithm is optimized for polar views 
constructed from A-scan data.

Auto-Scroll Zoom group box

Figure 3-109  The Auto-Scroll Zoom group box

The Auto-Scroll Zoom group box has the following check boxes. See Figure 3-109 on 
page 177.

Scan/Index
This activates the Auto-Scroll Zoom function for the selected axis, which 
dynamically zooms in on the active view within the specified range.

Smooth
Adds a display smoothing function to the active view. 
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Configuration group box

Figure 3-110  The Configuration group box 

The Configuration group box has the following check boxes. See Figure 3-110 on 
page 178.

Reverse USound
Reverses the data along the ultrasonic axis (horizontal or vertical flip).

Reverse amplitude
In an A-scan view selecting this check box reverses the data along the 
amplitude axis (vertical flip).

Rotate 90 deg
Rotates the data so that the two axes interchange.

Display DGS 
Enables the distance-gain-size (DGS) 

Display TCG
Enables the time-corrected gain (TCG) display on the active A-scan view. 

Reverse Horizontal/Vertical
Reverses the horizontal/vertical axis on an active Polar view.

Show part
Enables the display of the defined part on an active Polar view. 

Gate selector
Adds the gate selector to the active view.

Keep 1:1 ratio
Displays the view in a way that keeps the sample ratio of both displayed axes.
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Reverse scan
Reverses the data along the scan axis (horizontal or vertical flip).

Reverse index
Reverses the data along the index axis (horizontal or vertical flip).

Reverse amplitude
In an A-scan view selecting this check box reverses the data along the 
amplitude axis (vertical flip).

Group Gates group box 

Figure 3-111  Group Gates group box 

The Group Gates group box has the following. See Figure 3-111 on page 179. 

I, A, B, C, D, and S
These check boxes enable the display of the corresponding gates on the active 
A-scan. 

All Gates 
Show All / Hide All

Enables or disables the display of gates on the active A-scan view. 
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The Display tab for a Polar view contains additional options that are specific to this 
view (see Figure 3-112 on page 180).

Figure 3-112  The Display tab for a Polar View

Figure 3-113  Part Definition dialog box 

The Part Definition dialog box is subdivided into the Material Velocity, Dimensions, 
and Probe Positioning group boxes. 
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Material Velocity group box 

Figure 3-114  The Material Velocity group box 

The Material Velocity group box contains the following. See Figure 3-114 on 
page 181.

Longitudinal/transversal waves
Sets the velocity of the longitudinal and transversal waves inside the part 
material. 

In Wedge 
Sets the velocity inside the wedge.

Figure 3-115  The Dimensions group box

The Dimensions group box contains the following. See Figure 3-115 on page 181.

Thickness
Defines the thickness for flat and cylindrical part types. 
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Geometry
Option buttons used to select the geometry of the inspected part from Flat, 
Cylindrical, and Bar.

Probe Positioning group box 

Figure 3-116  The Probe Positioning group box 

The Probe Positioning group box contains the following. See Figure 3-116 on 
page 182. 

Inspection from
Defines if the probe is positioned on the outside diameter (OD) or inside 
diameter (ID) for the inspection of cylindrical parts. 

Scan orientation
Defines if the orientation of the scan axis is Circumferential or Axial during 
the inspection. 

If the part type is defined as cylindrical or bar, the polar view type is added to the 
Contents dialog box when performing the analysis. See Figure 3-117 on page 183. 
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Figure 3-117  Contents dialog box with a Polar view

3.13.3 Echo Dynamics Tab

The echo dynamics is a 2-D curve resulting from the projection of the data under a 
cursor or between cursors. The Echo Dynamics tab (see Figure 3-118 on page 183) is 
used to set the echo-dynamic curve parameters.

Figure 3-118  The Echo Dynamics tab

The Echo Dynamics tab is subdivided into the Display, Grid, Curve Construction, 
and Peak Selection for Drop Sizing (-X dB) group boxes. 

Display group box 
This group box encloses the display options of the echo-dynamic curves. See 
Figure 3-119 on page 184.
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Figure 3-119  The Display group box

Horizontal/vertical curve
When this check box is selected, a horizontal echo-dynamic curve is displayed 
at the top or right side of the active view.

Dots only
When this check box is selected, echo-dynamic curves are displayed with 
dots.

Ref./Meas. cursor
Enables the display of the reference/measurement cursors on the echo-
dynamic curves.

Envelope
When this check box is selected, the echo-dynamic curves are displayed as an 
envelope of all the curves between the cursors or the complete visible image.

Grid group box 

Figure 3-120  The Grid group box 

The Grid group box contains the following. See Figure 3-120 on page 184.

The Show grid enables the Grid on the echo dynamic curves of the active view. 
The Coarse, Medium, and Fine options can be used to customize the grid density. 
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Curve Construction group box

The Curve Construction group box contains the following. See Figure 3-121 on 
page 185.

Figure 3-121  The Curve Construction group box

This group box encloses option buttons that are used to select one of the three 
curve construction types. 

Complete visible image
With this option, the echo-dynamic curve is constructed with the complete 
visible image of the inspected part.

Cut along reference cursors
With this option, the echo-dynamic curve is constructed with the cross section 
that is specified by the reference cursor.

Slice between Ref. and Meas. cursors
With this option, the echo-dynamic curve is constructed with the slice that is 
specified by the reference and measurement cursors.

Value type
Select to build the Echo Dynamics curve using the Maximum or the 
Minimum value of the current area.

Peak Selection for Drop Sizing group box (–X dB)
The Peak Selection for Drop Sizing (-X dB) group box contains the following. 
See Figure 3-122 on page 186
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Figure 3-122  The Peak Selection for Drop Sizing (-X dB) group box 

This group box allows you to select the option that will be used for the –X dB 
drop sizing measurements on echo-dynamic curves from Maximum peak in 
visible image, Maximum at reference cursor, and Maximum between ref. 
and meas. cursors. 

3.13.4 Overlay Tab

The Overlay tab (see Figure 3-123 on page 186) is used to set the display of overlay 
drawings on the active volume-corrected view. 

Figure 3-123  The Overlay tab

Show Selected Overlays group box 
The Show Selected Overlays group box contains the following. See Figure 3-124 
on page 187.
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Figure 3-124  The Show Selected Overlays group box

Enables the display of the selected overlay on the active volume corrected view.

Part/Weld/Defect Overlays
Enables the display of the selected overlay on the active volume corrected 
view. 

Filter by group and beam
Selecting this check box will only display the defects created on the current 
group for the active view.

Skip Overlays 
Enables the display of the skips on the current view for the corrected volume 
and Sector (S) views. Deselecting the Top or Bottom check boxes will remove 
the corresponding skips from the active view. 

3.13.5 Palette Tab

The Palette tab (see Figure 3-125 on page 187) is used to set the color palette of the 
active view.

Figure 3-125  The Palette tab
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The Palette tab is subdivided into Palette, Edit Palette, Save Palette, Load Palette, the 
color palette, the cursors, left and right arrow buttons, the software gain slider, RF 
symmetrical, Reverse color order, and Compression palette.

Palette
This box is used to select a predefined color palette from a list. A zone 
displays the selected color palette.

Edit Palette
Opens the Palette Editor dialog box, used to define color palettes. 

Save Palette
Opens a standard Save As dialog box, used to name and save a color palette 
(.col file). The saved color palette replaces the selected palette in the Palette 
box.

Load Palette
Opens a standard Open dialog box, used to select and load a color palette 
(.col file). The loaded color palette replaces the currently selected palette in 
the Palette box.

Color palette
Displays the current color palette for the active view. See Figure 3-126 on 
page 188.

Figure 3-126  The Color Palette dialog box

Double-clicking between the cursors divides the current palette range by two 
and double-clicking outside the cursors restores the full palette range default.

Double-clicking outside the cursors restores the default full palette range, 
which goes from –100 % to +100 %.
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Left and right arrow buttons
Clicking the left and right arrow buttons, respectively, shifts the color palette 
range by a fine increment to the left and to the right. 

Left and right double-arrow buttons
Clicking the left and right double-arrow buttons, respectively, shifts the color 
palette range on the left and on the right by a coarse increment. 

Color palette left/right cursors
Dragging the left/right cursor sets the lower limit of the color palette range as 
a percentage (linear data), or in decibels (logarithmic data).

Dragging the color palette itself sets the lower and upper limits of the color 
palette range simultaneously.

Software gain slider
Dragging the slider, or using the arrow keys, sets the software gain, which 
ranges from –100 dB to +100 dB. Clicking on the gain slider moves the slider 
by 6 dB or 6 % increments, depending on the case, simultaneously.

The software gain you set appears in a box to the right of the software gain 
slider. Clicking this box restores the default software gain, which is 0 dB or 
0 %.

The software gain slider is used to set a software-calculated amplitude gain, which 
leaves the acquisition data unchanged.

RF symmetrical palette
Selecting this check box makes the selected color palette symmetrical relative 
to the zero value.

Reverse color order
Selecting this check box reverses the color order in the color palette.

Compression palette
When enabled, the full color palette range between the left and right color 
palette. 
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3.13.6 Data Source Tab

Using the Data Source tab (see example in Figure 3-127 on page 190), you can set the 
data source used to compute the projection displayed in a view. The contents of the 
Data Source changes depending on the current type of view selected. 

Figure 3-127  The Data Source tab

The Data Source tab may contain the following group box options:

Single plane
In this mode, the view displays a single plane crossing the inspection volume. 
A single gate selector selects the cross section to display in the inspected part.

Projection, using gate selectors
In this mode, TomoView uses all data contained between two gate selectors to 
generate the displayed image. When many samples of data must use the same 
display pixel, the highest value is used.

Link to reference cursor
This check box, when selected, links the gate selector position to the 
corresponding reference and measurement cursors. Dragging these cursors 
then causes gate selectors of other views to react accordingly.

Set gate selectors range to max.
When this check box is selected, the gate selectors will be set at lower and 
higher values to display the volume of data. When this check box is selected, 
it is not possible to adjust the gate selector values at the bottom of the pane.

Scan source
Using this list box, you can select the cursor (Reference cursor, Measure 
cursor or Data cursor) that is to be used to select the A-scan along the scan 
axis.
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Index source
Using this list box, you can select the cursor (Reference cursor, Measure 
cursor or Data cursor) that is to be used to select the A-scan along the index 
axis.

3.13.7 Parameters Tab

The Parameters tab (see Figure 3-128 on page 191) is used to set the parameters that 
link the UT data volume to the actual physical volume of the specimen. These 
parameters, available only in inspection mode, are used to make adjustments to the 
ultrasonic settings and are saved in an .A01 file.

Figure 3-128  The Parameters tab

The Parameters tab is subdivided into UT Settings, Mechanical Settings, and Beam 
Orientation. 

UT Settings group box

Figure 3-129  UT Settings group box 

Sound velocity (m/s)
This box displays the sound velocity in the inspected material. The sound 
velocity is dependent of the wave type and material type used. Clicking the 
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 button opens the Sound Velocity dialog box (see Figure 3-129 on 
page 191) in which you can set the sound velocity parameters. 

Sound Velocity dialog box
Using the Sound Velocity dialog box (see Figure 3-130 on page 192), you can 
set the sound velocity parameters.

Figure 3-130  The Sound Velocity dialog box

The Sound Velocity dialog box contains the following:

Current velocity
Displays the velocity of the current wave mode, either in meters per second (m/s) 
or in inches per microsecond (in./µs).

New velocity 
Using this box, you can set the sound velocity for the active mode, either in meters 
per second (m/s) or in inches per microsecond (in./µs). The value is limited to the 
range between 500 m/s and 20,000 m/s or the corresponding values in in./µs.

Apply to Current Beam/Apply to Current Group
Applies the velocities defined in the New velocity box to either the current beam 
or current Group. 

Delay (µs)
This box displays the sum of all time delays preceding the first A-scan 
sample, in microseconds. The Delay dialog box (see Figure 3-131 on page 193) 
is used to set the probe, focal law, and channel delay parameters.
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Figure 3-131  The Delay dialog box

The Delay dialog box contains the following:

Total probe delay (µs)
Defines the total probe delay of the current Group.

Trig mode/Inspection mode 
Indicates the current Trigger and Inspection modes.

Acq./Gate/Total wedge delay (µs)
Displays the acquisition/gate/total wedge delays in microseconds. the total wedge 
delay is calculated using the following formula:

Total wedge delay = Total probe delay + channel delay + focal law delay + gate 
delay
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Mechanical Settings group box

Figure 3-132  The Mechanical Settings group box 

Scan axis offset (mm) and Index axis offset (mm)
These two boxes display the sum of the Scanner, Probe, and Beam offsets of 
the emergence point of a beam (based on the values entered in the UT 
Settings dialog bar), relative to the scan and index axes: scanner offsets, probe 
offsets, beam offsets. The Scan axis offset and Index axis offset parameters 
set the absolute position of the first data point relative to the scan and index 
axes (top view), that is, the exact place where the first data point was acquired 

from the part. Clicking on the  button will open the Mechanical Settings 
dialog box (see Figure 3-132 on page 194) which is used to set the offset 
parameters. 
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Figure 3-133  The Mechanical Settings dialog box

The Mechanical Settings dialog box contains the following:

Scanner offset
This group box encloses the boxes used to set the scanner offset for the scan 
and index axes. These offsets will be applied to all groups.

Probe offset
This group box encloses the boxes used to set the probe offset for the scan and 
index axes. These offsets will be applied only yo the active group. 

Beam offset
This group box encloses the boxes used to set the beam offset for the scan and 
index axes. These offsets will be applied only to the active beam. The Reset 
All buttons resets the corresponding value, and makes it unavailable for 
further modifications. 
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Total offset
This group box displays the total offset for the scan and index axes, which is 
calculated using the values entered in the dialog box, according to the 
following formula:

Total offset = Scanner offset + Probe offset + Beam offset

Beam Orientation group box 

Figure 3-134  The Beam Orientation group box

Refracted angle (deg)
This box displays the refracted angle in degrees, relative to the normal of the 

specimen surface, from –90° to +90°. Clicking  opens the Refracted angle 
(deg.) dialog box. (See Figure 3-134 on page 196.) 

Figure 3-135  The Refracted Angle dialog box 

Current angle
Displays the current refracted angle in degrees.
New angle
Resets the refracted angle in degrees.
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Apply the Current Beam/Apply the Current Group
Applies the refracted angle defined in the New Angle box to either the 
current beam or the current Group.

Skew angle (deg)
This box displays the skew angle in degrees, relative to the scan axis, from 0° 

to 360°. Clicking  displays the Skew angle dialog box (see Figure 3-136 on 
page 197)

Figure 3-136  The Skew angle dialog box

Probe skew/Bean skew
Sets the probe and beam skews in degrees.

Total skew 
Displays the total skew angle calculated according to the following formula:

Part Definition
This button opens the Part Definition dialog box.

 

Total skew Probe skew Beam skew+=
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Figure 3-137  The Part Definition dialog box 

The Part Definition dialog box (see Figure 3-137 on page 198) is subdivided into 
the Material Velocity, Dimensions, and Probe Positioning group boxes. 

Material velocity group box
The Material Velocity group box contains the following. See Figure 3-138 on 
page 199.
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Figure 3-138  The Material Velocity group box

Longitudinal/Transversal waves 
Sets the velocity of the longitudinal and transversal waves inside the part 
material.

In Wedge
Sets the velocity inside the wedge. 

Dimensions group box 
The Dimensions group box contains the following. See Figure 3-139 on page 199.

Figure 3-139  The Dimensions group box

Thickness
Defines the thickness for flat and cylindrical part types.

Geometry 
Option buttons used to select the geometry of the inspected part. Choose 
from Flat, Cylindrical, or Bar. 

Probe Positioning group box
The Probe Positioning group box contains the following. See Figure 3-140 on 
page 200.
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Figure 3-140  The Probe Positioning group box

Inspection from
Defines if the probe is positioned on the outside diameter (OD) or inside 
diameter (ID) for the inspection of cylindrical parts. 

Scan orientation
Defines if the orientation of the scan axis is Circumferential or Axial during 
the inspection. 

If the part type is defined as cylindrical or bar, the polar view type is added to the 
Contents dialog box when performing the analysis. See Figure 3-141 on page 200.

Figure 3-141  Contents dialog box with a Polar view
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3.13.8 Units Tab

The Units tab (see Figure 3-142 on page 201) is used to set the units for the four data 
dimensions, for all views displaying the same data group as the active view.

Figure 3-142  The Units tab

The Units tab contains the following:

Scan/Index/USound/Type
Set the scan/index/ultrasonic axis/amplitude units. 

Type
This column contains the boxes used to select the unit type for each parameter.
According to the dimension, the possible unit types are the following:

Scan: Distance, Samples, Rotation.

Index: Distance, Samples, Rotation.

USound: True Depth, Half Path, Full Path, Time, Time/2, Samples, TOFD.

Amplitude: Samples, Percentage, Decibels.

Unit
This column contains the boxes used to select the measurement unit for each
parameter. According to the unit type, the possible units are the following:

Distance: True Depth, Half Path, Full Path: m, mm, in., mils.

Samples: smpl.

Rotation: deg, rad.

Time, Time/2: s, µs.

TOFD: m, mm, in., mils.

Percentage: %.

Decibels: dB.
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Precision
This column contains the boxes used to select the measurement precision, that is:

.= 0 digits after the decimal

.#= 1 digit after the decimal

.##= 2 digits after the decimal

.###= 3 digits after the decimal

Calibrate
Clicking on the Calibrate buttons opens the Mechanical Axis, Time/Full Path and 
Time/Half Path, TOFD, True Depth or Translation/Rotation calibration dialog 
boxes. See the following for a description of these dialog boxes.

Mechanical Axis Calibration dialog box
The Mechanical Axis Calibration dialog box (see Figure 3-143 on page 202) is 
used to calibrate the distance value on the scan or index axes.

Figure 3-143  The Mechanical Axis Calibration dialog box

The Mechanical Axis Calibration dialog box contains the following:

Reference cursor/Measurement cursor 
These boxes are used to set the reference and measurement cursor positions.

Distance/Resolution 
These boxes indicate the distance between reference and measurement cursor 
positions along with the measurement resolution.
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Original file unit type
This line displays the original unit used in the data file.

Time / Full Path and Time / Half Path dialog boxes
The Time / Full Path and Time / Half Path dialog boxes (see Figure 3-144 on 
page 203) are used to calibrate the time value relative to the full path value 
and the half path value.

Figure 3-144  The Time / Half Path dialog box

The Time / Full Path and the Time / Half Path dialog boxes contain the following:

What do you want to compute?
This group box allows you to select which parameter should be calculated.

Velocity/Wedge Delay 
This box indicates the sound velocity and wedge delay inside the material.

Ref. cursor position/Meas. cursor position 
These boxes indicate the current reference and measurement cursor positions.

Difference
This box indicates the difference between the reference and measurement 
cursor positions.
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TOFD dialog box

The TOFD dialog box (see Figure 3-145 on page 204) is used to calibrate the ultrasonic
axis when you use the TOFD method.

Figure 3-145  The TOFD dialog box

The TOFD dialog box contains the following:

What do you want to compute?
This group box encloses option buttons used to select the parameter that is to be 
calculated from other parameters:

Compute reference cursor position
This option is used to adapt the TOFD ruler, setting it to its zero position at 
the reference cursor position. Position the reference cursor on the first echo 
signal and then click Ok. 

Compute velocity and wedge delay
This option is used to calculate both the material sound velocity and the 
probe wedge delay by using two reference signals, typically the lateral wave 
and the backwall echo. 
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Compute wedge delay
This option is used to calculate the probe wedge delay by using a fixed value 
of the sound velocity and one reference signal, typically the lateral wave or 
the backwall echo.

Scan axis
This group box encloses option buttons that can be used to select if the scan 
axis orientation relative to the ultrasonic beam projection should be defined 
as Parallel to beam or Perpendicular to beam.

Reference cursor position
This box defines the real (true depth) reference cursor position in millimeters 
(mm) or inches (in.).

Probe separation
This box defines the distance between the probes in millimeters (mm) or 
inches (in.).

Sound velocity
This box defines the material sound velocity in meters per second (m/s) or 
inches per microsecond (in./µs).

Wedge delay
This box defines the probe wedge delay in microseconds (µs).

For details on using the calibration function with the TOFD dialog box, see 
section “Performing TOFD Calibration in Analysis Mode” on page 355.

True Depth dialog box

The True Depth dialog box (see Figure 3-146 on page 206) is used to calibrate the 
ultrasonic axis in true depth units.
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Figure 3-146  The True Depth dialog box

The True Depth dialog box contains text boxes (on white background) for the values
that can be changed, or display boxes (appearing dimmed) for the values that are
calculated from other values. The dialog box contains the following:

Reflectors position
This group box encloses parameters used to calibrate the ultrasonic axis.

Scan 1/Scan 2
These boxes define the real scan axis position of the reference and 
measurement cursor positions in millimeters (mm) or in inches (in.).

USound 1/USound 2
These boxes defines the real (true depth) reference cursor position in 
millimeters (mm) or in inches (in.).

Diameter
This box defines the diameter of the hole used for calibration.

Angle calibration
This check box, when selected, enables the calibration of the refracted angle.
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Results 
The Sound velocity, Wedge delay, Refracted angle, and Scan offset values 
displayed in this section give the values calculated from the defined parameters. 

Translation / Rotation dialog box

The Translation / Rotation dialog box (see Figure 3-147 on page 207) is used to
calibrate the translation value relative to the rotation value.

Figure 3-147  The Translation / Rotation dialog box

The Translation / Rotation dialog box contains the following:

Radius
This box indicates the radius of the rotary motion.

Resolution
This box indicates the measurement resolution.

Ref. cursor/Meas. cursor 
These boxes indicate the reference and measurement cursor positions.

Cursor pos. difference
This box indicates the difference between reference and measurement cursor 
positions.

Original file unit type
This line displays the original unit used in the data file.
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3.13.9 View Linking Tab

The View Linking tab (see Figure 3-148 on page 208) is used to set linking cursors
types, rulers, palette ranges, and other settings for the active view. The particular
linking types set for the active view override the default links set in the Linking tab of
the Preferences dialog box.

Figure 3-148  The View Linking tab

The View Linking tab contains the following group box:

Linked Items 
This group box encloses the various objects and settings that can be linked to the 
graphical tools of the other views. Selecting a check box activates the linking of 
the corresponding object or setting.

3.13.10 Rebounds Tab

The Rebounds tab (see Figure 3-149 on page 208) is used to set the skip processing
parameters.

Figure 3-149  The Rebounds tab
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Description of the Rebounds tab

The Rebounds tab contains the following group boxes:

Processing options
This group box encloses options that are selected for the skip processing.

Skip quantity
Using these option buttons, you can select the number of skips used in the 
processing from the following: No skip, ½ skip, 1 skip, 1½ skips, 2 skips.

3.13.11 Strip Tab

The Strip tab (Figure 3-150 on page 209) is used to set options and parameters related
to the strip views. The Strip tab is only available when the active view is a strip view. 

Figure 3-150  The Strip tab 

The Strip tab is subdivided into Threshold, Amplitude/Position data, and Strip Axis
group boxes. 

Threshold group box
This group box encloses the threshold options of the strip views.

• Display threshold
When this check box is selected, the Threshold value is displayed as a 
black line in the active strip view. When the Secondary data is displayed, 
if the secondary data is below the Threshold value at a defined position, 
the associated stripe of the strip view becomes green. If the secondary 
data is above the Threshold value at a defined position, the associated 
stripe of the strip view becomes red.

• Threshold
Indicates the threshold level in amplitude or as percentage of gate length.
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Amplitude/Position data group box 
This group box encloses the amplitude/position data options for the strip 
views.

• Stripe
When this option is selected, the data is represented by a colored stripe. 
The color and the length of the stripe are indicative of the amplitude or 
the position of the indication within the associated gate.

• Curve
When this option is selected, the data is represented by a curve.

• Full stripes
When this check box is selected, the data is represented by a colored 
stripe with its length at full-view height. The color of the stripe is 
indicative of the amplitude or position of the indication within the 
associated gate.

• Secondary data
Using this list box, you can choose secondary data to be displayed in the 
active strip view. Depending on the number of gates, the data type 
recorded, and the active strip view, the Secondary data and the different 
gate’s amplitude and position data. 

Strip axis group box
This group box allows you to select whether the strip view should be constructed
along the scan or index axis. (available in analysis mode only).

3.14 Preferences Dialog Box

You can customize various TomoView parameters using the Preferences dialog box. 
You access the Preferences dialog box by selecting File > Preferences on the menu. 
See Figure 3-151 on page 211.
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Figure 3-151  The Preferences dialog box 

The Preferences dialog box is not available in the TomoView Lite and TomoViewer 
editions.

3.14.1 General Settings Tab

The General Settings tab of the Preferences dialog box (see Figure 3-152 on 
page 211), contains the following group boxes.

Figure 3-152  The General Settings tab of the Preferences dialog box
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Default Measurement System

Select Metric or US Cust. to respectively use the metric or the US customary 
measurement systems for all TomoView parameters and views. You can configure 
units in more detail for each view from the Properties dialog box, in the Units tab.

Acquisition File Properties

Use Max Size to set the maximum size of the acquisition file. The maximum size of a 
data file that can be recorded with TomoView is 2 GB.

Acquisition Mode

Select the Bypass analysis checkbox to bypass the online analysis mode so that you 
immediately go to the setup mode at the end of the acquisition. 

Interface

Select the Expert mode checkbox to activate advanced features (see section 3.16 on 
page 220 for details).

Zoom Scroll

You can scroll the vertical zoom bars on the selected view using the wheel of the 
mouse. Holding the CTRL key while moving the wheel scrolls the horizontal zoom 
bar. The axis range percentage value indicates the magnitude of the zoom bar 
displacement for one mouse wheel tick. 

Dialog Bypass

Select the check box for the dialog boxes (Startup Selection, Configuration Selection, 
or Pod Selection) that you want to bypass at startup. These options may be useful 
when you always use the same setup and want to avoid acknowledging the default 
setup, or when you remotely control TomoView and you cannot respond to the dialog 
boxes. 

Amplitude drop

Set the amplitude drop negative value for the three axes to be used for flaw sizing 
with the Zone tool.
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Peak Holding Algorithm

Set the number of samples to be used in the peak holding algorithm for the three axes 
for flaw sizing with the Zone tool. A setting of n samples means that the algorithm 
ignores an amplitude drop below –x dB along the axis if it is smaller than n samples.

Fill Acquisition Gaps

Select the check box to activate the function that fills data acquisition gaps when 
performing amplitude-drop sizing measurements for each of the two axes. 

Option

Select the Use old Indication table check box when you wish to rather use the legacy 
Indication table available in TomoView prior to version 2.9. You need to restart 
TomoView to see the effect after changing this option.

Bookmark

The Enable edition check box is disabled because its use is reserved for Evident NDT.

Firmware Compatibility

At startup, TomoView validates its compatibility with the acquisition unit firmware. 
TomoView displays a dialog box when an incompatibility is detected (see 
Figure 3-153 on page 213).

Figure 3-153  Example of dialog box for an incompatible OmniScan firmware 
program
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Select the Bypass Check check box when you wish not to display the dialog box. This 
option may be useful when you remotely control TomoView and no one is present in 
front of the TomoView computer to respond to the dialog box. 

For connection to acquisition units other than an OmniScan, when the Bypass Check 
check box is selected, choose one of the following option to determine what 
TomoView does when a firmware incompatibility is detected: 

Continue
TomoView continues to use the acquisition unit with the current firmware. 

Reset
TomoView uploads the compatible firmware to the acquisition unit through the 
Bootp server.

C-Scan 

On an amplitude C-scan, TomoView normally does not show signal amplitudes that 
are below the gate level, replacing these values by no detection codes. 

Select the Always record amplitude in analysis check box when you want to 
configure TomoView to show this signal in Analysis mode, after moving the gate. 
Select Always record amplitude in acquisition if you want the amplitude data to be 
shown whether or not the signal has crossed the gate (therefore ignoring the no 
detection codes). 

3.14.2 Linking Tab

The Linking tab of the Preferences dialog box (see Figure 3-154 on page 215), 
accessible from the File > Preferences menu selection, contains parameters to 
customize the linking features in TomoView.

When an element is linked, changing it in one context (view, group, gate) 
automatically changes it identically in the other linked contexts. For example, with the 
Scan cursors set to Fully linked, moving the reference cursor on the scan axis in one 
view, moves it to the same position in all the other views. The linking feature can save 
you a large number of tedious adjustments when you work with multiple views, 
multiple groups, and multiple gates. You can set the cursor and ruler linking behavior 
differently for uncorrected and corrected views. 
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Figure 3-154  The Linking tab of the Preferences dialog box

You can also configure the links for individual views from the View Linking tab in 
the View Properties dialog box (see section 3.13.9 on page 208 for details). 

The available linking behaviors with other views are:

Unlinked
The selected item is not linked.

Linked per gate
The selected item is linked per gate.

Linked per group
The selected item is linked per group.

Fully linked
The selected item is linked for all gates and all groups.

Linked with uncorrected
The selected item is linked as defined under Uncorrected Views.
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TomoView classifies an A-scan as an uncorrected view, even when the ultrasound axis 
is set to true depth mode.

3.14.3 Colors Tabs

The Axis Colors, View Colors, and Tool Colors tabs of the Preferences dialog box 
contain buttons that you can use to view or select the color of various TomoView 
items. You can access dialog box by selecting File > Preferences on the menu. 

The Axis Colors tab (see Figure 3-155 on page 216) displays the colors of the different 
axes for uncorrected and corrected views. These colors are shown only for reference 
purposes. You cannot change these colors.

Figure 3-155  The Axis Colors tab of the Preferences dialog box

The View Colors tab (see Figure 3-156 on page 217) is used to set the colors of the 
background, the grid, the curve, the autotracking measurement cursor, and the DGS 
curves in the views. 
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Figure 3-156  The View Colors tab of the Preferences dialog box

The Tools Colors tab (see Figure 3-157 on page 217) is used to set the color of the four
information groups and of the overlays.

Figure 3-157  The Tool Colors tab of the Preferences dialog box

Clicking any of the previously mentioned buttons opens a standard Color dialog box, 
in which you select a predefined color or define a new custom color (for details, see 
section 10.2 on page 449).

3.14.4 Folders Tab

You can customize the default folders for the various data file types. On the menu, 
select File > Preferences, and then select the Folders tab (see Figure 3-158 on 
page 218). 
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Figure 3-158  The Folders tab of the Preferences dialog box

3.15 About the Advanced Calculator 

The Advanced Calculator is proprietary Evident software installed on the TomoView. 
Start the Advanced Calculator from the TomoView Manager dialog box by clicking 

the  button. From TomoView, use the Advanced Calculator to specify the probe 
and wedge used in the inspection, the geometry and material of the inspected part, 
and the beam configuration (see Figure 3-159 on page 219). The Advanced Calculator 
calculates the beams and returns the information to TomoView.

Refer to Advanced Calculator User’s Manual (DMTA080-01EN) for more information. 
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Figure 3-159  The Advanced Calculator dialog box
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3.16 About the Expert Mode

TomoView includes an expert mode in which a larger number of readings are 
available. The categories of readings available in the Information Groups dialog box 
when the expert mode is active are shown in Figure 3-160 on page 220.

Figure 3-160  The categories of readings in the expert mode

To activate/deactivate the expert mode

1. On the menu, select File > Preferences.
2. In the Preferences dialog box, select the General Settings tab. 
3. Under Interface, select or clear the Expert mode check box, respectively, to 

activate or deactivate the expert mode. 

3.17 About the Master and Slave Modes

TomoView provides the software components necessary to control motorized or 
manual inspection sequences and is available in either Master or Slave mode. 

Master Mode
In the master operation mode, the MCDU-02 system controls the motors of the 
mechanical system. The MCDU-02 supports input from two digital-position 
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encoders (refer to the MCDU-02 User’s Manual, part number DUMG017B for 
specifications and connection methods for these encoders). In the master mode, 
TomoView supports both the single-axis and dual-axis MCDU-02 unit scan 
capabilities. With TomoView, you can use the motor control drive unit with 
Evident NDT scanners and ultrasonic acquisition systems, as well as third-party 
scanners.

Slave Mode
In the slave operation mode, the mechanical system is not controlled by 
TomoView. Instead, the mechanical system is controlled by an external control 
unit, or is moved manually.

In order for TomoView to start in master mode, an MCDU-02 (Motor Control Drive 
Unit) must be selected along with the acquisition unit at startup (see Figure 3-161 on 
page 221). TomoView will operate in master mode if a MCDU-02 (Motor Control 
Drive Unit) is selected at startup. Otherwise, it startup in slave mode. 

Figure 3-161  The Select Device Configuration dialog box

3.18 File Formats

TomoView can produce, opens, and imports various data types stored in various file 
formats listed in Table 11 on page 222 and Table 12 on page 222. 
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Table 11  File formats supported by TomoView 

File type Extension File content

Hardware setup .acq Setup of the acquisition unit

Data .rdt Data file in RDTIFF (Evident proprietary file 
format) format. Also contains display setup 
information and acquisition setup information.

.opd OmniScan phased array (PA) data file imported 
into TomoView using the OmniScan File Converter. 

.oud OmniScan UT data file imported into TomoView 
using the OmniScan File Converter.

Display setup .rst Display setup: layouts and system preferences

Scanner settings .scn Scanner setting PID parameters

Part .rsp Part definition parameters

Report .r01 Report information including indication zone data

Calculator setup .xcal Advanced Calculator extended setup file

.law Calculated beam parameters readable by the 
OmniScan

.pac Calculated beam parameters readable by 
TomoView

Attributes .A01 Attributes: data modified in analysis and associated 
with the .rdt file

Table 12  Legacy file formats supported by TomoView 

File type Extension File content

Data .dat Data file in Tomoscan format

Hardware Setup .srd Legacy TomoView setup file for the µTomoscan 
and TomoScan FOCUS acquisition units

Calculator setup .cal Advanced Calculator setup file
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The hierarchical content of the file formats generated by TomoView is illustrated in 
Figure 3-162 on page 223.

Figure 3-162  TomoView file organization

The preferences data saved in the .rst file include view linking options, axis colors, 
view colors, tool colors, and the measurement system. By default, the contents of the 
.rst file is included in the .acq file.

.rdt file

Raw UT data (amplitude, position)

.acq file

UT Settings
Scan settings
Preferences (see following note)

.xcal file

Calculator parameters
Simulation results

.scn file

Scanner settings (PID parameters)

.rst file

Layouts
Indication table customization

.rsp file

Part

.a01 file

Volumetric merge parameters
Indication table 
TOFD processing 
Software C-scan

.r01 file

Report information
Indication zone data
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You can customize the default folders for the various data file types (see Section 3.14.4 
on page 217 for details). 
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4. Setup Creation

A TomoView configuration can be saved in the .acq (acquisition, also referred to as 
the setup) file, which can be recalled at any time. This section describes the basic steps 
for creating a setup file using TomoView, starting from the default configuration. 

4.1 Working with Setup Files

The following section describes how to create the setup files. 

4.1.1 Loading an .acq Setup File

The TomoView configuration can be stored in the .acq file. An .rdt (data) file can also 
be recalled to load the .acq configuration which was used at the time when the data 
was recorded. You can reload the parameters into the ultrasonic acquisition unit to 
perform acquisition with the same parameters or to display the parameters that were 
used for acquisition.

To load a TomoView acquisition file 

1. From the document Toolbar, click  to open a setup file.
The Open dialog box appears (see Figure 4-1 on page 228).
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Figure 4-1  The Open dialog box

2. In the Open dialog box that appears (see Figure 4-1 on page 228): 
a) Select the configuration type from Data File or Setup File. 
b) From the File Content section, select the file to be loaded and choose the 

elements to be loaded.
c) Click Open. 

4.1.2 Loading an SRD Setup File

TomoView can load .srd files, along with the .acq files. The .srd files were created 
using older software versions.

To open an .srd setup file

1. From the toolbar, select File > Import SRD file. 
2. When the Open dialog box appears, select the .srd file to load and click Open. 

(See Figure 4-2 on page 229.)
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Figure 4-2  The Open SRD Document dialog box

3. When the setup is loaded: 
a) Configure the Display layout.
b) Configure the Scan and Mechanical Settings parameters.
c) Click Open. 

4. Save the setup in an .acq file using the standard save option. 

4.1.3 Saving an .acq Setup File

To save a setup

1. From the Document toolbar, click  to save a setup file. 
2. In the Save As dialog box that appears (see Figure 4-3 on page 230):

a) For the .acq file to be saved, enter the File Name. 
b) In the File Content section, select the elements to be saved.
c) To make this setup file the new default configuration, click on Save to save 

the .acq file, or click Save as default. 
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Figure 4-3  The Save As dialog box

4.1.4 Default Setup Files

TomoView comes with a number of default setup files. Each default setup file 
contains parameters appropriately configured for a particular common application. 
Loading an appropriate default setup file for your application is an easy way to 
discover TomoView advanced features.

The default setup files are available in the default setup file folder ([Installation 
Folder]\EvidentNDT\TomoView210\Setup Files). 

4.2 Working with Groups

In TomoView, a group is a defined configuration of parameters to generate one or 
more ultrasonic beams using a conventional or phased array probe. A group can 
pulse and receive on the same probe, or you can use two different probes, one to 
pulse, and the other to receive, and a probe can be used by more than one group. The 
following sections describe how to create and configure phased array and 
conventional groups (see section 3.2 on page 85 for more information on groups). 
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4.2.1 Adding and Configuring a Phased Array Group

The following procedure describes how to create a phased array group in TomoView. 
Although some of the steps may not be mandatory for all inspection types, it provides 
an overview of the power and flexibility of TomoView. 

To add and configure a phased array pulse-echo group

1. In the TomoView Manager, click  to add a group (see Figure 4-4 on page 231).

Figure 4-4  Selecting the newly created group

2. In the Group Creation Wizard dialog box that appears (see Figure 4-5 on 
page 232): 
a) Select Phased array for the type of group to create.
b) Enter a name for the new group in the Specify name text box (for example: 

Angle Beam).
c) Click Finish.

Select the group

Start the Advanced Calculator

Add a group

Open the UT Settings dialog box
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Figure 4-5  The Group Creation Wizard dialog box

3. In the TomoView Manager, in the Group area (see Figure 4-4 on page 231):
a) Select the newly created group.

b) Click  to open the Advanced Calculator. 
The Advanced Calculator is where you specify the probe and wedge used for 
the inspection, the geometry and material of the inspected part, and the beam 
configuration. See section 3.3 on page 87 for details.

4. In the Advanced Calculator, perform the following tasks:
a) For an angle beam phased array inspection, click the 1-D Linear Array tab 

(see Figure 4-6 on page 233).
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Figure 4-6  The Advanced Calculator dialog box

b) In the Probe group box, select the type of probe (Angle Beam) and the probe 
model (see Figure 4-7 on page 234).
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Figure 4-7  Selecting the probe

c) In the Part group box, select the inspected part geometry type and enter its 
thickness (see Figure 4-8 on page 234).

Figure 4-8  Specifying the inspected part geometry

d) In the Material group box, select the inspected part material and the 
Longitudinal or Transverse ultrasound wave type (see Figure 4-9 on 
page 235).

Type

Model
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Figure 4-9  Specifying the inspected part material

e) In the Wedge group box, select the type of wedge and the wedge model (see 
Figure 4-10 on page 235). 

Figure 4-10  Specifying the wedge

f) In the Scan Type group box, for an angle beam inspection, select Sectorial, 
Depth, or Static. For more information on the differences between the Scan 
Types, refer to the Advanced NDT Series books available for free on our 
website. 

g) In the Beam Angles Selection group box, select Refracted angle, and then 
specify the Start value along with the Stop, and Resolution values if available 
depending on the selected Scan Type. 

Type

Model
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h) In the Focal Points Selection group box, set the Focusing type to True Depth, 
Half Path, Projection, or Focal Lane, and if desired, select if you want to have 
Dynamic Depth Focusing (DDF) activated. Then define the Focal plane 
position, Emission focus position, and Reception focus position if available. 

i) In the Elements Selection group box, select Primary axis aperture, and then 
enter the number of elements to use for each focal law. Then define the Start, 
Stop, and Resolution values if available.

j) In the Connection group box, set the Pulser and the Receiver values. This will 
define the element to use as the first element for the transmitter and receiver 
focal laws. 

k) At the bottom of the window, click Draw. 
TomoView prepares the beam display information

l) Wait for the progress bar to complete.
m) At the top of the screen, click the Beam display info. tab.
n) Use the four views and the parameters below the views to validate the 

calculated beams (see Figure 4-11 on page 237).
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Figure 4-11  Example of the Beam Display Info. tab in the Advanced Calculator

o) Return to the 1-D Linear array tab, and then if necessary, make further 
adjustment to the parameters. 

p) At the bottom of the window, click Replace to calculate the configured focal 
laws and send the information back to TomoView.

To add and configure a phased array Pitch-and-Catch or Trough Transmission group

1. Follow steps 1 to 4.e of the procedure called “To add and configure a phased array 
pulse-echo group” on page 231.
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2. Click  to open the Advanced Calculator:
a) In the Scan Type group box, select Static. 
b) In the Beam Angles Selection group box, select Refracted angle, and then 

specify the Start value for the Pulser. 
c) In the Elements Selection group box, define the Start and Primary axis 

aperture values. 
d) At the bottom of the window, click Replace to calculate the configured focal 

laws and send the information back to TomoView.

3. Click  to open the Advanced Calculator:
a) In the Beam Angles Selection group box, select Refracted angle, and then 

specify the Start value for the Receiver. 
b) In the Elements Selection group box, define the Start and Primary axis 

aperture values. 
c) In the Probe group box, define the Probe skew angle for the receiver, if 

necessary.
d) At the bottom of the window, click Replace Rec. to calculate the configured 

reception focal laws and send the information back to TomoView.

4. Click  to open the Advanced Calculator:
a) In the Phased Array Parameters Source dialog box (see Figure 4-12 on 

page 239), select the sector to be edited, then select Emission and click Ok. 
The Advanced Calculator will open with the corresponding Pulser 
configuration.

b) In the Advanced Calculator, click on Add. 
This will add a new beam with a similar configuration to the one defined in 
step 2.
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Figure 4-12  The Phased Array Parameters Source dialog box

5. Click  to open the Advanced Calculator:
a) In the Phased Array Parameters Source dialog box (see Figure 4-12 on 

page 239), select the sector to be edited and then select Emission and click 
Ok. 

b) Edit the different available parameters, if necessary.
c) At the bottom of the window, click Replace to calculate the configured focal 

laws and send the information back to TomoView.

6. Click  to open the Advanced Calculator:
a) In the Phased Array Parameters Source dialog box (see Figure 4-12 on 

page 239), select the sector to be edited and then select Reception and click 
Ok. 

b) Edit the different available parameters, if necessary.
c) At the bottom of the window, click Replace Rec. to calculate the configured 

reception focal laws and send the information back to TomoView.
7. Repeat steps 4 to 6 until all your beams are properly configured. 

4.2.2 Adding and Configuring a Conventional UT Group

The following procedure describes how to create a conventional UT group in 
TomoView. The configuration of a conventional UT group is not performed from the 
Advanced Calculator as for the phased array groups. Therefore, the acoustic 
configuration and part definition will need to be performed separately. 
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To add and configure a conventional UT group

1. In the TomoView Manager, click  to add a group.
2. In the Group Creation Wizard dialog box that appears (see Figure 4-13 on 

page 240): 
a) Select Conventional UT for the type of group to create.
b) Enter a name for the new group in the Specify name text box (for example, 

Conventional Beam).
c) Click Finish.

Figure 4-13  The Group Creation Wizard dialog box

3. On the menu, select Part & Overlay > Part Definition.
4. In the Part Definition dialog box (see Figure 4-14 on page 241):

a) In the Material Velocity area, set the ultrasonic velocities for the 
Longitudinal waves and Transversal waves in the part.

b) In the Dimensions area, set the values describing your part.
c) For cylindrical parts, in the Probe Positioning area, select the appropriate 

Inspection from and Scan orientation values. 
d) Click OK.
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Figure 4-14  The Part Definition dialog box

5. In the TomoView Manager, in the Group area:
 Select the newly created group (see Figure 4-15 on page 241).

Figure 4-15  Selecting the UT group in the TomoView Manager

UT Settings button
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6. On the Component toolbar, click the UT Settings button ( ).
7. In the UT Settings dialog box:

a) In the Pulser/Receiver tab, set the connectors for Pulser and Receiver along 
with the Pulse width value for your UT probe. 
Divide 500 by the probe frequency expressed in MHz to get the pulse width 
value expressed in ns (ex.: 500/10 MHz = 50 ns).

b) In the Probe tab, under Selection, select Modify probe, and under Beam 
Orientation, enter the appropriate Refracted angle value.

c) In the Probe tab, select Modify probe in the Selection group box. 
d) In the Position group box, define the Scan offset and Index offset values. 
e) In the Beam Orientation group box, define the Skew angle value. 

4.2.3 Adding and Configuring a TOFD Group

The following procedure describes how to create a TOFD group in TomoView. Just as 
for a Conventional UT group, the TOFD configuration is not performed from the 
Advanced Calculator. Therefore, the acoustic configuration is performed separately. 

To add and configure a TOFD group

1. In the TomoView Manager, click  to add a group.
2. In the Group Creation Wizard dialog box that appears (see Figure 4-16 on 

page 243).
a) Select TOFD for the group type.
b) Enter a name for the new group in the Specify name text box (for example, 

TOFD group).
c) Click Finish. 
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Figure 4-16  The Group Creation Wizard dialog box

3. In the UT Settings > Pulser/Receiver dialog box:
a) Set Connector to the value corresponding to the Pulser connector number.
b) Set Receiver to the value corresponding to the Receiver connector number.
c) Set the Voltage to the highest value available. 
d) Set the Pulse width value for your UT probe. 

Divide the number 500 by the probe frequency (expressed in MHz) to obtain 
the pulse width value expressed in ns (e.g., 500/10 MHz = 50 ns). 

4.2.4 Switching Between Groups

When you have more than one group in a configuration, you often need to switch the 
focus from one group to the other.

To switch between groups

1. On the menu, select Tools > Change Group.
2. In the Change Group dialog box, select the group to which you want to switch, 

and then click OK.
OR
On the menu, select Tools > Previous Group or press the F5 key to switch to the 
previous group.
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OR
On the menu, select Tools > Next Group or press the F6 key to switch to the next 
group.

4.2.5 Renaming Groups

To rename a channel

1. Click  to open the UT Settings dialog bar.
2. In the UT Settings dialog bar, select the group you want to rename.
3. Click in the Group box, and then type the new group name.
4. Press Enter. 

4.2.6 Deleting Groups

To delete a channel

In the TomoView Manager in the Group area: 

1. Select the group you want to delete.
2. Click on the Delete button.

A message box appears (see Figure 4-17 on page 244), asking you to confirm 
deletion of the channel.

Figure 4-17  The message box for deleting a channel

3. Click OK to confirm the operation. 
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4.3 Calibrating a Phased Array Group

Before and after an inspection, you can perform an on-site calibration check to ensure 
the stability of the complete ultrasonic (UT) system. The phased array technique 
requires the calibration and verification of all the UT beams. The purpose of the 
calibration is to obtain a setup file that yields correct results regarding the position 
and amplitude of a known reflector in a calibration block. 

The following sections present the calibration procedures to calibrate the Beam 
Delays and Sensitivity for phased array groups. For the phased array TCG 
calibration procedure, see section 4.7.3 on page 258.

4.3.1 Calibrating the Beam Delays

The purpose of the phased array beam delay calibration is to adjust the delay of each 
beam so that the indication of a known reflector appears at the correct depth for all 
beams. This procedure must be performed for each group.

To calibrate the beam delays

1. On the Component toolbar, click  (Phased Array Calibration).
2. In TomoView, in a Side (B), End (D), or Sector (S) view, position the Reference 

(red) and Measurement (blue) cursors respectively above and below the reference 
reflector of the calibration block (see Figure 4-18 on page 245).

Figure 4-18  Example of cursors around an indication in a Sector (S) view

3. In the Phased Array Calibration dialog box:
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a) Select the Beam Delays tab (see Figure 4-19 on page 246).
The graph presents the ultrasonic path between the Reference and 
Measurement cursors on the vertical axis and the beams on the horizontal 
axis.

Figure 4-19  Curves for the beam delay calibration

b) Under Calibration, in the Reflector position parameter, enter the true depth 
of the known reflector used for this calibration. 

c) If the reflector echo is too weak or too strong, adjust the Group gain 
parameter. 

d) In the Tolerance parameter, enter the acceptable calibration tolerance.
e) Select the Linear interpolation check box to activate the averaging of the 

beam delays. The resulting line applies a global correction. 
4. During the scan, the distance envelope (blue line) obtained for each beam is 

drawn, and a curve representing the position of the maximum amplitude is 
constructed (red line). 

5. Place the probe on the calibration block and perform a first scan above the 
reference reflector. 

 

Distance envelope (blue line) representing the depth of the maximum amplitude for 
each beam at a given moment

Dash lines representing the tolerance limits

Red line representing the depth of the highest maximum amplitude obtained for a 
given beam during the scan.

Straight black line showing the real depth of the known reflector
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After a scan, the maximum amplitude curve (red line) should already be close to the 
tolerance limits. When the maximum amplitude curve shape is significantly different, 
in the Advanced Calculator, revise the configuration of all parameters.

6. In the Phased Array Calibration dialog box, click Clear Trace to clear the data 
from the previous scan.

7. Perform a new scan above the reference reflector on the calibration block. 
In the graph, the red line might not always appear within the tolerance lines.

8. Click Calibrate. 
The graph content is cleared and TomoView calculates the wedge delay for each 
beam so that the reflector indication appears at the requested depth.

9. Perform a new scan above the reference reflector on the calibration block to 
validate the calibration by confirming that the red line appears within the 
tolerance lines.

Figure 4-20  Red line appearing between tolerance lines after calibration

10. When the calibration is not successful, repeat steps 6 to 9.
11. If you need to reset the calibration:

a) On the TomoView Manager, click the Advanced Calculator button ( ).
b) In the Advanced Calculator, click Replace.
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4.3.2 Calibrating the Sensitivity

The purpose of the phased array sensitivity calibration is to adjust the gain of each 
beam so that the amplitude of a known reflector appears at the same level for all 
beams. 

To calibrate the sensitivity

1. On the Component toolbar, click  (Phased Array Calibration).
2. In the Phased Array Calibration dialog box, click the Sensitivity tab.
3. Couple the probe to the calibration block and perform a first scan on the 

calibration block above a reference reflector.
During the scan, TomoView draws the distance envelope (blue line) obtained for 
each beam and constructs a curve (red line) representing the position of the 
maximum amplitude (see Figure 4-21 on page 248).

Figure 4-21  Sensitivity example after a first scan

4. In TomoView, in a Side (B), End (D), or, Sector (S) view, position the reference 
(red) and measurement (blue) cursors respectively above and below the reference 
reflector of the calibration block (see Figure 4-18 on page 245).

5. In the Phased Array Calibration dialog box:
a) Set the Reflector amplitude parameter to the amplitude (%) at which you 

wish to see the reference reflector maximum amplitude appear. 
b) In the Tolerance parameter, enter the acceptable amplitude tolerance.
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c) If the reflector echo is too weak or too strong, adjust the Group gain 
parameter. 

d) Click Clear Trace to clear the data from the previous scan.
6. Perform a new scan above the reference reflector on the calibration block.
7. Click Calibrate. 

TomoView clears the graph content and calculates the gain for each beam so that 
the reflector echo amplitude appears at the requested level for all beams.

8. Perform a new scan above the reference reflector on the calibration block to 
validate the calibration by confirming that the red line appears within the 
tolerance lines (see Figure 4-22 on page 249).

Figure 4-22  Curves for the sensitivity calibration

9. When the calibration is not successful, repeat steps 6 to 8.
10. If you want to review or reset the beam gains:

a) On the Component toolbar, click  (UT Settings). 
b) In the Beam list above the tabs, select the desired beam. 
c) In the General tab, under Gain, review or edit the Beam gain. 
d) Click Reset Beam when you want to reset the sensitivity calibration. 

4.4 Calibrating a Conventional UT Group

You can calibrate the ultrasonic velocity and the wedge delay of a conventional UT 
group using the parameters available from the General tab of the UT Settings dialog 
box (see Figure 4-23 on page 250). 
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Figure 4-23  The General tab of the UT Settings dialog box for a UT group

 You need a calibration block with one known reflector to perform the delay 
calibration and a calibration block with two known reflectors to perform the 
velocity calibration. 

To calibrate a conventional UT group

1. On the Component toolbar, click  (UT Settings).
2. In the TomoView Manager, in the Group area, select the Conventional UT group 

that you want to calibrate.
3. In the UT Settings dialog box, select the probe category and model in the 

Selection area. 

Figure 4-24  Selecting the probe in the UT Settings dialog box

4. Place the probe on the calibration block and position the probe over the two 
reflectors with known positions. 

5. On an A-scan view:
a) Select and configure the view to see the echoes of the two reflectors.
b) Move the Reference cursor (red line) on the echo of the first reflector. 
c) Move the Measurement cursor on the echo of the second reflector.

6. In the UT Settings dialog box, in the General tab:

Probe category
Probe model
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a) Under Time Base, set Mode to Half path.
b) Under Auto Values, click Calibrate.

7. In the Time / Half Path dialog box that appears (see Figure 4-25 on page 251):
a) Under What Do You want to Compute, select Compute Velocity and delay.
b) Set Ref. cursor position to the known position of the first reflector.
c) Set Meas. cursor position to the known position of the second reflector.
d) Click OK.

TomoView calculates the ultrasonic velocity and wedge delay and sets the 
corresponding values in the UT Settings dialog box, in the Probe tab, under 
Material and Interface.

Figure 4-25  Calibrating with the Time / Half Path dialog box

4.5 Calibrating a TOFD Group in Setup Mode

Although TOFD groups are generally calibrated in Analysis mode, the following 
procedure explains how to calibrate in Setup mode. For more information on how to 
calibrate a TOFD group in Analysis mode, see section 7.6.2 on page 355. 
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To calibrate a TOFD group in setup mode

1. In the menu, select View > Contents and display the TOFD group A-scan and 
Side (B) views.

2. In the UT Settings > General dialog box, set Mode to TOFD in the Time Base 
group box.

3. In the Component toolbar, click  to open the TOFD Manager dialog box.
4. In the TOFD Manager dialog box, click Calibration.
5. In the TOFD dialog box:

a) In the What do you want compute? group box, define what parameters you 
want to compute.

b) In the Scan axis group box, define the scan axis as either parallel, or 
perpendicular to beam. 

c) In the TOFD primary value and TOFD secondary value group boxes, define 
the requested parameters. 

d) Click Ok. 

If you select the Compute velocity and wedge delay option button in the What do 
you want compute? group box of the TOFD dialog box, the measurement cursor has 
to be positioned on a second reference signal (for example, lateral wave).

The ultrasonic axis is now calibrated in setup mode.

4.6 Working with Overlay Drawings

An overlay is a graphical representation of weld geometry or of a part, which is
superimposed over an ultrasonic data view. The overlay helps to visualize where
defects are physically located relative to the weld or to the part geometry. TomoView
provides predefined customizable overlays but you can also create weld and part
overlays from drawing files (DXF). 

For weld inspection applications, you can add a weld drawing as an overlay in the 
view:
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To create a weld overlay

1. On the menu, select Part & Overlay > Weld definition.
a) In the Predefined Weld dialog box, click the appropriate weld type (see 

Figure 4-26 on page 253).

Figure 4-26  The Predefined Weld and Weld Parameters (for Type 1) dialog boxes

b) In the Weld Parameters dialog box, type appropriate values to define your 
weld, and then click OK.

c) Back in the Predefined Weld dialog box, select the Automatic flip check box, 
and then click OK.
The weld overlay appears in the view (see Figure 4-27 on page 254). 
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Figure 4-27  Example of a weld overlay with three flips

4.7 Working with the TCG Curve

The time-corrected gain (TCG) function operates by modifying the receiver gain 
during data acquisition to compensate for the attenuation of the ultrasonic wave in 
the material. The TCG curve defines gain values that are added to the group gain. 

TomoView offers two methods to construct a TCG curve. For a UT conventional 
group (mono-element probe) or for a linear 0-degree phased array group, you can use 
the controls in the TCG tab of the UT Settings dialog box (see section 4.7.1 on 
page 254). For phased array group, use the Phased Array Calibration component (see 
section 4.7.3 on page 258).

In order to build a TCG curve, a calibration block is required with the same size 
reflectors at different depths. You can then display the TCG curve as a red line at the 
top of the corresponding A-scan view (see section 4.7.2 on page 257).

4.7.1 Constructing a TCG Curve for a Conventional UT Group

Use the controls in the TCG tab of the UT Settings dialog box to construct a TCG 
curve for a UT conventional group or for a 0-degree linear phased array group to 
which the same TCG curve is applied to all laws. 

Original overlay

First flip

Second flip

Third flip
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The TCG function is not available for a group using a logarithmic amplifier on legacy 
acquisition units.

To define a TCG curve

1. Choose a layout that includes an A-scan view.
2. Enable the TCG function proceeding as follows: 

a) On the Component toolbar, click  (UT Settings).
b) In the UT Settings dialog bar, click the TCG tab and then select the Enable 

check box.

Figure 4-28  The TCG tab of the UT-Settings dialog box

3. Place the probe on a calibration block having same size reflectors at different 
known depths.

4. Position the probe to get well-defined echoes on the A-scan (see Figure 4-29 on 
page 256).
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Figure 4-29  The A-scan before adding the first TCG point.

5. In the UT Settings dialog box, set the Reference level parameter to the amplitude 
level for the echo, expressed in percent of the full screen height. The 80 % default 
setting is suitable as a basic setting in most cases.

6. On the A-scan view, position the Reference and the Measurement cursors to the 
left and the right of the echo by double-clicking with the left and right mouse 
buttons.

7. Maximize the signal amplitude by moving the probe over the indication. Use the 
envelope tool to help you find the maximum signal.

8. In the UT Settings dialog box, click Add Point to add the chosen point to the TCG 
curve. When needed, click New Line to add an empty line.
TomoView adjusts the gain to bring the peak of the selected echo to 80 % of the 
full screen height.
256    Chapter 4

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Figure 4-30  The A-scan after adding the first TCG point

9. Repeat steps 6 to 8 for each point you want to add to the TCG curve. A minimum 
of two points is required to define a functional TCG curve.

A Point gain with a negative value is not applied. Ensure to construct your TCG curve 
without negative point gains. Point 0 corresponding with the interface is not always 
the one with the highest amplitude.

4.7.2 Displaying or Hiding the TCG Curve

The TCG curve can be displayed or hidden using the following steps:

To display or hide the TCG curve

1. Select the A-scan view in which you want to display or hide the TCG curve.

2. On the Component toolbar, click  (UT Settings).
3. In the UT Settings dialog box, select the TCG tab.
4. Select or clear the Display check box to respectively display or hide the TCG 

curve.
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The TCG curve appears as a red line at the top of the corresponding A-scan view.

Figure 4-31  Example of an A-scan view showing the TCG curve

4.7.3 Constructing a TCG Curve for a Phased Array Group

Use the controls in the TCG tab of the Phased Array Calibration dialog box to 
construct a TCG curve for a phased array group. For angle beam inspections such as 
in weld applications, you need to use the following procedure to calculate the TCG 
gain independently for each beam.

To construct the phased array TCG curve

1. Enable the TCG function by proceeding as follows:

a) On the Component toolbar, click  (UT Settings).
b) In the UT Settings dialog bar, click the TCG tab, and then select the Enable 

check box.

2. On the Component toolbar, click Phased Array Calibration ( ).
3. In the Phased Array Calibration dialog box, click the TCG tab.
4. In TomoView, in a Side (B), End (D), or, Sector (S) view (depends on probe skew), 

position the reference (red) and measurement (blue) cursors respectively above 
and below the reflector indication (see Figure 4-18 on page 245).

5. Place the probe on the calibration block and perform a first scan on the calibration 
block above one reference reflector.
During the scan, TomoView draws the amplitude envelope (blue line) obtained 

TCG curve TCG curve area
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for each beam and constructs a curve (red line) representing the maximum 
amplitude of the envelope (see Figure 4-32 on page 259). 

Figure 4-32  TCG curve construction example after a first scan

6. In the Phased Array Calibration dialog box:
a) Set the Reflector amplitude parameter to the amplitude (%) at which you 

wish to see the reference reflector maximum amplitude appear. 
b) In the Tolerance parameter, enter the acceptable amplitude tolerance.
c) Click Clear Trace to clear the data from the previous scan.

7. Perform a new scan on the calibration block. 
8. To use this reflector to create a TCG curve point, click Add TCG Point.

TomoView adjusts the gain for each beam to obtain the required reference 
amplitude for the depth corresponding to the inspected reflector.

9. Repeat steps 4 to 8 for each reference reflector used to construct the complete TCG 
curve.

You can review the TCG gain for each beam from TCG tab in the UT Settings dialog 
box. 
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4.7.4 Importing/Exporting a TCG Curve

The TCG curve points can be easily imported and exported directly from the 
TomoView interface using simple .csv (Comma Delimited) files using the following 
procedure. 

To Import a TCG file into TomoView

1. Create the .csv file containing the different TCG points for a particular group. 
a) A line must be generated for every beam using the following structure where 

the Positions are defined in mm and the Gains are in dB. Every number is 
entered with a three digits decimal precision. 
Position 1, Gain 1; Position 2, Gain 2;....

b) Comments can be added at the end of every line as long as the as preceded by 
a “#” symbol. 

c) The file must be saved or renamed as a .csv file to be interpreted correctly. 

Figure 4-33  The TCG points import text

2. In the TomoView Manager, select the group on which you want to apply the TCG 
points. 

3. In the TCG tab of the UT Settings dialog bar:
a) Click Import. 
b) Select the .csv file containing the TCG points. 
c) Click Open. 

The TCG points position can be different from the ones defined in the .csv file if the 
position defined in the .csv file don’t match the available TCG points position slots. 
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4.8 Working with Layouts

In TomoView, a layout is an organization of two or more views appearing in the 
document window. TomoView offers a set of ten layouts available from the 
TomoView Manager dialog box as a quick selection. (See Figure 3-15 on page 96.)

Figure 4-34  The set of ten layouts

4.8.1 Applying a Template Layout File 

TomoView comes with a certain number of template layout files each containing up to 
ten layouts that can be selected to modify the current display. Additional layout files 
can also be created and defined as template layout files (see section 4.8.3 on page 263 
for more information). 

To apply a template layout

1. In the TomoView Manager dialog box, click  to select a Template layout file 
(see Figure 4-35 on page 262).
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Figure 4-35  The Template Layout menu on the Control bar

2. From the list of available layouts, select the most appropriate. See Figure 4-36 on 
page 262.

Figure 4-36  The list of available layouts 
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4.8.2 Displaying or Changing the View in a Pane

Once a layout has been selected, the views can be modified in order to customize the
display. 

To change the view in a pane

1. Activate the pane you want by clicking anywhere in it.

2. In the menu, click View > Contents, or click  on the View toolbar to open the 
Contents floating dialog box (see Figure 4-37 on page 263).

Figure 4-37  Example of the Contents dialog box 

3. Double-click on the view to have in the active pane. 
4. If required, activate another pane by clicking on it and select the data and the 

view to be displayed in this pane.
The right section is updated to list the view types that are possible with the 
selected data type. 

4.8.3 Saving Layout Files and Defining New Template Layouts 

The list of template layouts described in section 4.8.1 on page 261 matches the content 
of the layout folder. The default layout folder is [Installation 
Folder]\TomoView210\Layouts Files (see Figure 4-38 on page 264). You can therefore 
customize the list of predefined layouts by adding, removing, or modifying the layout 
files and their subfolders.
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Do not modify or delete the following layout files:
[Installation Folder]\TomoView210\Layout Files\Viewer.rst
[Installation Folder]\TomoView210\Layout Files\Lite Aero\Lite Aero.rst
[Installation Folder]\TomoView210\Layout Files\Lite Weld\Lite Weld.rst
Changing or deleting these files prevents the corresponding TomoView edition from 
starting (TomoViewer, Lite Aero, or Lite Weld). If this occurs, re-install TomoView to 
fix the problem.

Figure 4-38  Default layout folder

To save a set of ten customized layouts:

1. In the menu, select File > Save Layout as (*.rst).
2. In the Save As dialog box (see Figure 4-39 on page 265).

a) Enter the File Name for the .rst file. 
b) Click Save. 
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Figure 4-39  The Save As dialog box 

You can also save up to five custom layout files available directly under the Custom 
section of the template layouts. 

To save a set of ten customized layouts directly in the template layouts

1. In the menu, select File > Save Custom Layout.
2. In the Save Custom Layout dialog box (see Figure 4-40 on page 266):

a) Select one of the five available custom layout slots. 
b) Define the name for the selected custom layout.
c) Click OK. 
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Figure 4-40  The Save Custom Layout dialog box

3. The new custom layout will be available in the same location as the other 
template layouts (see Figure 4-41 on page 266)

Figure 4-41  The Custom Layout saved templates

With the Lite Aero and Lite Weld editions, you can only load Lite ready predefined 
layout files, respectively saved in the folders: 

[Installation Folder]\TomoView210\Layout Files\LITE AERO
[Installation Folder]\TomoView210\Layout Files\LITE WELD
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4.9 Working with the DGS Curve

The distance gain size (DGS) is a method for sizing indications based upon a 
calculated DGS curve for a given transducer, material, and a known reflector size. The 
main DGS curve represents the signal amplitude of an equivalent flat-bottom hole 
(FBH) reflector of a specified size. 

The DGS configuration only requires one reflector and the knowledge of the 
ultrasound propagation speed in the inspected material and in the wedge material.

The DGS function is more commonly used with conventional UT groups (see 
section 4.9.1 on page 267). You can however use the DGS function with a phased array 
group using special DGS qualified PA probes and specific group configuration (see 
section 4.9.3 on page 272).

4.9.1 Configuring the DGS for a Conventional UT Group

To configure the DGS for a conventional UT group

1. Create a conventional UT group (see section 4.2.2 on page 239).
2. In the TomoView Manager, ensure the newly created conventional UT group is 

selected.

3. On the Component toolbar, click  (UT Settings).
4. In the UT Settings dialog box, to ensure that the DGS function operates properly, 

perform the following tasks:
a) In the Pulser/Receiver tab, under Receiver:

(1) Ensure that Rectification is not set to RF. 
The DGS does not operate when Rectification = RF.

(2) When working with µTomoscan and MultiScan MS5800 acquisition
units, set Scale type to Lin. The DGS is not available for other scale types
with these acquisition units.

b) In the Pulser/Receiver tab, under Pulser and Receiver, set Connector to the 
appropriate value.
In pulse-echo mode, they are the same. 

c) In the TCG tab, clear the Enable check box. 
The TCG must not be active when performing the DGS calibration.

5. Perform the calibration of the ultrasonic velocity and wedge delay (see 
“Calibrate” on page 122). 
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6. In the UT Settings dialog box, in the Probe tab: 
a) Under Selection, select Modify probe to make the other probe parameters 

editable. 
b) Under Position, adjust the Scan offset and the Index offset parameters to 

appropriate values. 
c) Under Beam Orientation, adjust the Refracted angle and the Skew angle 

parameters to appropriate values.
d) Select the appropriate probe from the probe database.

4.9.2 Calibrating the DGS for a Conventional UT Group

To calibrate the DGS for a Conventional UT Group

1. On the Component toolbar, click  (UT Settings). 
2. In the UT Settings dialog box, select the DGS tab (see Figure 4-42 on page 268) 

and then perform the following tasks: 

Figure 4-42  The DGS tab of the UT Settings dialog box

a) Under Reflector, select the Type of reflector that you are using for the DGS 
calibration.
The available choices are:
• Back Wall (for linear 0-degree groups only)
• FBH: flat bottom hole
• K1-IIW (see IIW calibration block in Figure 4-43 on page 270)
• K2-DSC (see DSC test block in Figure 4-43 on page 270)
• SDH: side-drilled hole
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The list of available reflector types changes depending on the type of probe that you 
are using (contact or angle beam). 

b) For FBH and SDH reflector types, under Reflector, set Size value to the 
diameter of the known reflector.

c) For K1-IIW and K2-DSC reflector types, on the DGS chart supplied with your 
probe, find the ∆VK value, and then enter it in the Delta vk parameter.

d) If you know the energy transfer loss difference between the calibration block 
and the inspected part, enter the value in the Delta vt parameter. 
Unlike changing the global gain, Delta vt only affects the signal gain, not the 
curve.

e) Enter the ultrasound velocity for the wedge material.
f) Under Parameters, enter the desired Registration level value. 

The registration level is the reference reflector size. The maximum amplitude 
echo of a reflector of this size falls on the DGS curve, independently of the 
depth of the reflector.

You can change the registration level, the gain, and the range without having to 
recalibrate the DGS.

g) Enter the desired Warning level value.
h) If you know the attenuation value for the calibration block, enter the value in 

the Calibration block attenuation parameter.
i) If you know the attenuation value for the part material, enter the value in the 

Part attenuation parameter.
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Figure 4-43  The IIW and DSC calibration blocks

3. Move the probe on the calibration block to the position of the maximum 
amplitude echo (see Figure 4-44 on page 270). 

Use the envelope tool ( ) from the View toolbar to guide you to find the maximum 
amplitude echo.

Figure 4-44  Finding the maximum amplitude using the Envelope tool

IIW calibration block DSC test block
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4. Move the Reference (red line) and Measurement (blue line) cursors on either side 
of the reflector echo used for the calibration.

5. Once the signal is maximized, in the UT Settings dialog box, in the DGS tab:
a) Click Set.

The amplitude of the reflector echo is modified to match the value of the 
Reflector amplitude parameter.

b) Click Calibrate. 
c) Select the Display DGS check box to view the DGS curve on the A-scan (see 

Figure 4-45 on page 271).
d) You can export the DGS curve to a TCG by clicking Create TCG. 

TomoView transfers the DGS parameters to the TCG and the DGS curve 
disappears.

Once you enable the TCG, you cannot change DGS parameters.

Figure 4-45  Example of the DGS registration and warning level curves

Warning level (white)
Registration level (red)

Reflector amplitude (dash)
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4.9.3 Configuring the DGS for a Phased Array Group

You can use the DGS function with a PA group as long as the group contains only one 
beam.

You cannot configure a phased array group using a non-phased array MultiScan 
MS5800 acquisition unit.

To configure a phased array group for DGS

1. Create a phased array group as described in section 4.2.1 on page 231.

2. In the TomoView Manager, click the Advanced Calculator button ( ) to return 
in the Advanced Calculator and perform the following adjustments (see 
Figure 4-46 on page 273):
a) Select the 1-D Linear array tab. 
b) Under Scan Type, select Static to limit the number of beams to one.
c) Under Beam Angles Selection, for the Refracted Angle parameter, set the 

Start value to the desired angle.
d) Under Focal Points Selection, since the DGS does not support beams, set 

Emission focus position to a large value such as 1000.
e) Under Probe, select the Integrated Wedge probe category, and then select one 

of the DGS probes (4L16-DGS1 or 2L8-DGS1).
f) At the bottom of the Advanced Calculator window, click Replace to return 

the calculated focal law parameters to TomoView.
3. Perform the necessary calibrations (see section 4.3 on page 245).
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Figure 4-46  An example of the Advanced Calculator 1-D Linear array tab 
configured for the DGS
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4.9.4 Displaying DGS Readings

TomoView features special DGS readings that can be displayed only when the Expert 
mode is enabled. See section 3.8 on page 114 for more information on readings and 
information groups. 

To display DGS readings

1. To make the DGS readings available, activate the Expert mode:
a) On the menu select File > Preferences.
b) In the Preferences dialog box, select the General Settings tab. 
c) Under Interface, select the Expert mode check box. 

2. On the menu select View > Readings > Edit Groups.
3. In the Information Groups dialog box (see Figure 4-47 on page 275):

a) Expand the Group[n] in which you want to add DGS readings.
b) Expand the DGS section.
c) Select the check box in front of the desired DGS readings.
d) Click OK.
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Figure 4-47  The DGS readings in the Information Groups dialog box

4. To display the readings on the desired view:
a) Right-click on the title bar of the view.
b) In the contextual menu, select or clear Show Info Group.

4.9.5 Changing the DGS Curve Colors

You can also change the color of the DGS curves from the Preferences dialog box.

To change the DGS curve colors

1. On the menu, select File > Preferences.
2. In the Preferences dialog box, select the View Colors tab.
3. Under DGS Curves, click Standard or Warning to open the Color dialog box 

respectively for the registration level and the warning level DGS curves. 
4. In the Color dialog box, select the desired color for the curve, and then click OK.
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5. Back in the Preferences dialog box, click OK.

4.10 Working with the Readings 

TomoView computes reading values for various parameters for analyzing ultrasonic 
data. Readings are calculated using cursor, zone, acquisition, or segment (3-D Cursor) 
parameters and can be displayed at the top of a view (see Figure 4-50 on page 279).

4.10.1 Reading Management

You can define four groups of readings using the readings Information Groups 
dialog box (see Figure 4-48 on page 277). You access the Information Groups dialog 
box by double-clicking in the reading zone that appears at the top of a view or by 
selecting View > Readings > Edit Groups on the menu.

The most frequently used readings are organized by categories under Favorite 
Readings in the Information Groups dialog box. Each category has a limited number 
of readings with short names similar in concept to those of the OmniScan software. 
The categories and lists of available readings are the same for each of the four groups 
and for all view types.

More readings are available from the Information Groups dialog box when the 
export mode is activated (see section 3.16 on page 220 for details).
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Figure 4-48  The Favorite Readings categories in the Information Groups dialog box

The readings configuration is saved in an .rst file that is included by default in the .acq 
file (see section 3.18 on page 221 for details).

4.10.2 Reading Examples

The following readings, illustrated in Figure 4-49 on page 278, provide useful 
numerical values for the indication amplitude and position within the inspected part:

A(r)
Is the amplitude in a percentage at the reference cursor position.
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D(r)
Is the true indication depth (always between zero and the part thickness) at the 
reference cursor position. 

T(r)
Is the thickness at the reference cursor position.

U(r)
Is the position of the reference cursor on the ultrasound axis (expressed in time of 
flight [µs], half path [mm] or true depth [mm]).

Figure 4-49  Illustration of the A, D, T, and U readings

The following readings provide useful information for corrosion applications:

ML(r)
Material loss (%) at the reference cursor position

T(Zmin)
Minimum thickness inside the zone

S(ZMin)
Position of the minimum thickness inside the zone on the scan axis

I(Zmin)
Position of the minimum thickness inside the zone on the index axis

U

D

TA
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Figure 4-50  Corrosion readings example

When you position the pointer over a reading, a tooltip appears, providing a useful 
definition of the reading (see Figure 4-51 on page 279).

Figure 4-51  Example of a reading tooltip

You can display all readings on all views. However, a value appears only when the 
measurement can be computed in the view. For example, with an A-scan view, the 
amplitude value can be computed and displayed but not a zone value (see Figure 4-52 
on page 279).

Figure 4-52  Example of an empty reading

Zone

Empty reading
Setup Creation    279

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
4.10.3 Hiding or Showing Readings at the Top of a View

You can quickly hide or show readings configured to appear at the top of a view. 

To hide or show a specific readings group at the top of a view 

1. Select the view you want to modify.

2. In the View toolbar, select  to hide or show a specific readings 
group. 

To hide or show all the readings at the top of a view

1. Right-click on the title bar of the view. 
2. In the contextual menu, select or clear Show Info Group.

4.10.4 Customizing the Reading Color and Font

You can customize the background color and the font of readings.

To customize reading colors and the font

1. On the menu, select File > Preferences to customize reading background colors.
2. In the Preferences dialog box, select the Tool Colors tab (see Figure 4-53 on 

page 280).

Figure 4-53  The Tool Colors tab of the Preferences dialog box
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3. Under the Information Groups area, click the button corresponding to the 
element (Background or Text) and the reading group (#1, #2, #3, or #4) that you 
want to modify. 

4. In the Color dialog box, click the desired color, and then click OK (see Figure 4-54 
on page 281). 

Figure 4-54  The Color dialog box

5. Repeat step 3 for each element for which you want to change the color.
6. In the Preferences dialog box, click OK.
7. On the menu, select View > Readings > Properties to customize the reading font.
8. In the View Information Properties dialog box (see Figure 4-55 on page 282), 

select the desired Font and Size for the readings, and then click OK.
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Figure 4-55  The View Information Properties dialog box

4.11 Working with Gates

The following steps describe how to configure the gates. This procedure must be 
independently performed for every group. For reference information on the Gate tab, 
see section 3.10.2 on page 123. 

To define gates

1. On the Component toolbar, click  (UT Settings).
2. If not already done, display an A-scan view on the active pane.
3. On the UT Settings dialog bar, click the Gate tab and perform the following: 

a) Place the reference and measurement cursors on the ultrasonic axis so as to 
determine the starting position and length of the gate.

b) Place the reference cursor on the amplitude axis by double-clicking with the 
left and right mouse buttons so as to determine the detection threshold level 
of gate 1.

c) Click Set Gate button.
d) Select the POS & AMP check boxes to enable the creation of a data group 

thereby enabling recording of the position and amplitude of the C-scan data.
e) For Gate I, select the POS B - POS A check box to enable the creation of a dat 

group monitoring the position difference between Gates A and B.
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4.11.1 Gate Adjustments

You can adjust the position and the width of a gate. In the A-scan, this is done by 
dragging-and-dropping a part of the gate line. The mouse pointer changes depending 
on where you click on the gate line, and indicates the task that you can perform (see 
Table 13 on page 283 for details).

You can adjust basic gate parameters using the controls in the TomoView Manager 
dialog box under Group (see Figure 4-56 on page 284).

Table 13  Moving and resizing a gate using the mouse 

Task Pointer Action

To resize a gate Drag-and-drop the end of the gate line

To move a gate Drag-and-drop the middle part of the gate 
line

To move a gate only 
vertically

Press and hold the SHIFT key, and then 
drag-and-drop the middle part of the gate 
line

To move a gate only 
horizontally

Press and hold the CTRL key, and then 
drag-and-drop the middle part of the gate 
line
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Figure 4-56  The gate parameters in the TomoView Manager dialog box

You can precisely configure the gates by pressing  on the TomoView Manager, 
and then use the parameters in the Gates tab of the UT Settings dialog box (see 
Figure 4-57 on page 284).

Figure 4-57  The Gates tab of the UT Settings dialog box

C-scan gate parameters

p
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4.11.2 About Gate Synchronization

Synchronizing gates means that the start position of a gate depends on the start 
position of another gate. For example, when gate B has a start position of 10 mm and 
is synchronized with gate A, gate B starts 10 mm on the right of the start of gate A.

Synchronizing gates is useful for example in an immersed inspection where the 
distance between the probe and the inspected part fluctuates in time. Using gate I to 
detect the interface echo, and then synchronizing gate A on gate I ensures that gate A 
always captures echoes from the same position range in the immersed inspected part. 

You can synchronize the position of a gate only with the position of the previous gate. 
For example, gate A can only be synchronized with gate I, gate B can only be 
synchronized with gate A and so forth. 

To synchronize a gate on another gate

1. To synchronize gate A on gate I, set Synchro. to Echo in the Digitizer section of 
the UT Settings dialog bar.

2. To synchronize other gates, set Link to the desired value in the Gates section of 
the UT Settings dialog bar. 

When TomoView acquires data with a FOCUS LT, you can also specify a negative 
start position for gate B that is synchronized on gate A. This allows you to create an 
anti-causal or pre-synchronization detection. This feature is useful when you need to 
detect a week echo appearing just before a strong echo. Pre-synchronization is 
possible because the FOCUS LT can generate up to 10 µs of signal prior to a gate. Note 
that while more than one pair of gate can use pre-synchronization, you cannot 
synchronize a gate to a synchronized gate that has a negative start position.

4.11.3 Gates in the Analysis Mode

You can also adjust the gate position and size in Analysis mode. The modified data is 
saved in a companion file (.A01). You can easily come back to the original gate 
parameter values by right-clicking on the title bar of the view, and then selecting 
Restore Initial Gates on the contextual menu.
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In Analysis mode, when you move a gate on an A-scan or S-scan view while the 
Ultrasound axis is in true depth, the new gate position is calculated in true depth. 
However, when you move the a gate on an A-scan view while the Ultrasound axis is 
not in true depth, the new gate position is calculated in sound path.

In Analysis mode, when programmed in half-path mode, the gated zone on the S-scan 
is true for the current beam. The position of the gate limits are automatically adjusted 
on the S-scan when you change the current beam (see Figure 4-58 on page 286).

Figure 4-58  S-scan gate positions automatically adjusted when the current beam 
changes when programmed in half-path mode

4.11.4 Gates and Amplitude C-Scans

On an amplitude C-scan, TomoView normally does not show signal amplitudes that 
are below the gate level as the OmniScan software does. However, you can configure 
TomoView to always record the amplitude in acquisition even when the signal is 
below the gate level using the following procedure.

To configure TomoView to show data below the gate level in acquisition

1. Select File > Preferences. 
2. In the Preferences dialog box, select the General Settings tab.

Current beam Current beam
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3. Under C-Scan in Analysis, select the Always record amplitude in acquisition 
check box. 

In Analysis mode, after moving the gate, you can however configure TomoView to 
show this signal (see Figure 4-59 on page 287).

Figure 4-59  Example of a C-scan showing and not showing the data below the gate

To configure TomoView to show data below the gate level in analysis 

1. On the menu, select File > Preferences.
2. In the Preferences dialog box, select the General Settings tab. 
3. Under C-Scan in Analysis, select the Always record amplitude in analysis check 

box.

4.11.5 Gate Usage Example

A water immersion inspection is a good example to illustrate the usage of multiple 
gates (see Figure 4-60 on page 288). Position and size gate I over the area where you 
expect to find the echo from the part interface. Position gate A to cover the path inside 
the inspected part without detecting the entry and back wall echoes. Finally, position 
and size gate B over the area where you expect to find the back-wall echo. In an 
immersed inspection, the distance between the probe and the part often fluctuates. To 
compensate for this fluctuation, the start position of gate A and gate B can be set to 
automatically change according to the position of the echo detected in gate I. This 
ensures that both gates constantly cover appropriate areas.

Showing data below gate Not showing data below gate
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Figure 4-60  Example of gate usage in a water immersed inspection

4.12 Working with the Alarms

The following procedure describes how to define the alarms. For reference 
information on the Alarms tab of the UT Settings dialog box, see section 3.10.8 on 
page 141. 

To define the alarms

1. On the Component toolbar, click  (UT Settings).
2. In the Alarms tab of the UT Settings dialog bar:

a) In the Output line box, select the alarm output line. 
b) Define the alarm condition by selecting the appropriate options under the 

Conditions group box.
c) Repeat these steps for each alarm condition. 
A set of indicators appears in the status bar representing the state of each alarm: 

.

4.13 Working with the Inputs/Outputs

The following procedure describes how to set the Analog Inputs, while the General

Immersed probe

Gate I tracks the echo of the part
interface

Gate A tracks echoes of defects in the
part

Gate B tracks the echo of the back wall
of the part

Immersed part
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Outputs and Digital out can be set by simply selecting the corresponding check box.
For reference information on the I/O tab of the UT Settings dialog box, see section
3.10.9 on page 142. 

To set the Analog Inputs

1. On the Component toolbar, click  (UT Settings).
2. In the I/O tab of the UT Settings dialog bar:

a) Select the Analog 1 check box to enable the first analog input line.
b) Define the associated Multiplier and Offset values by double-clicking on the 

current value.
c) Edit, if necessary, the Measure type and Unit parameters.

4.14 Working with the Firing Sequencer

The Firing Sequencer module is used to modify the order in which the ultrasonic
beams are fired. For some applications, the modification of the firing sequence can
help reduce the effects of ghost echoes due to high recurrence. 

For a phased array setup with multiple focal laws and channels, the firing repetition 
(recurrence) is very important to maximize the scanning speed without the presence 
of interference echoes. This can be critical for immersion techniques with the presence 
of signals coming from the water surface.

To activate the Firing Sequencer

1. On the Component toolbar, click  (UT Settings).
2. In the UT Settings dialog bar, select Interleaved. 

3. On the Component toolbar, click the Fire Sequencing button ( ).

When clicking on , the Firing Sequencer dialog bar will appear, which contains 
the list of all beams included in the different groups. 
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Figure 4-61  The Firing Sequencer (Interleave) dialog bar

The following describes the buttons of the Firing Sequencer which can be used to
modify the firing order of the different beams. 

Default
Brings the firing sequence order back to the default sequence (Group 1 - Beam 1,
Group 1 -Beam 2, …, Group 2 - Beam 1, Group 2 - Beam 2, and so on), This means
that the first generated beam is the first generated beam to be fired.

Figure 4-62  The Default dialog button

2 Zones
Creates a firing sequence with interlacing pairs of beams within each group (see
example in Figure 4-63 on page 291).
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Figure 4-63  Example of firing sequence with 2 Zones interlacing pairs

2 Z. All
Creates a firing sequence with interlacing pairs of beams within all groups (see
example in Figure 4-64 on page 291).

Figure 4-64  Example of firing sequence with 2 Z. All interlacing pairs

Up
Moves the selected beam or group of beams up in the Firing sequences list.

Down
Moves the selected beam or group of beams down in the Firing sequences list.

Import
Allows you to import a .cfs file containing a firing sequence from a previously 
exported configuration. 
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Export
Allows you to save the current firing sequence to a .cfs file. 

4.15 Working with the Conditional A-scan

The Conditional A-scan allows the A-scans to be recorded only when an alarm was 
triggered. This allows the A-scans to be kept only in the areas where this information 
is important and therefore allows the user to inspect much larger areas in a single 
inspection. 

To Set the Conditional A-scan 

1. Go to the Digitizer section of the UT Settings panel and check the Conditional 
checkbox. See Figure 4-65 on page 292.

Figure 4-65  The Digitizer tab

2. In the Alarms section of the UT Settings dialog bar, configure the alarms that will 
trigger the A-scan to be recorded. Three different alarms can be configured, all of 
which will have the same effect. See Figure 4-66 on page 292.

Figure 4-66  The Alarms tab
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3. Click  to start an acquisition. 
The A-scans will only be recorded in the areas where an alarm was triggered as 
can be seen on the following figures. See Figure 4-67 on page 293 and Figure 4-68 
on page 293.

Figure 4-67  Acquisition with full A-scan recording

Figure 4-68  Acquisition with conditional A-scan recording
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5. Performing Acquisitions

To simplify sequence programming, TomoView offers predefined sequence types 
with typical values. You have only to enter the inspected area’s dimensions and set the 
parameters of your mechanical system. You can also modify the predefined sequences 
as needed, or define custom sequences. 

5.1 Working with the Different Scan Types

TomoView has several types of available scans. They are listed and described in the 
following sections. 

The different scan types available in TomoView are: One-line scan, Free running,
Bidirectional, Unidirectional, Helicoidal, Angular, and Custom.

These different scan types are explained in the following sections.

5.1.1 One-Line Scan Sequence

The One-line scan sequence type identifies a linear-scan sequence. One position 
encoder is used to determine the position during the acquisition.

The linear scan (see Figure 5-1 on page 296) is unidimensional and proceeds along a 
linear path. The only settings that must be provided are the limits along the scan axis 
and the spacing between acquisitions.
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Figure 5-1  Linear scan

Operation mode

The One-line scan inspection sequence operates as follows:

1. The scanner proceeds to the position set in the Scan: Start box of the Sequence 
tab.

2. The scanner then moves on the scan axis to the position set in the Scan: Stop box, 
while performing data acquisition.

3. Data acquisition is performed at every interval set in the Scan: Resolution box.
4. The sequence is finished when the scanner has reached the position set in the 

Scan: Stop box.

Description of the Sequence tab

When you select One-line scan for the sequence inspection type, the Sequence tab 
contains the set of options shown in Figure 5-2 on page 296.

Figure 5-2  The Sequence tab for the One-line scan sequence

The Sequence tab for a One-line scan sequence contains the same options as for a 
Bidirectional sequence, except that it does not include the settings for the index axis. 
For a description of these options, please refer to section 5.1.1 on page 295.

X
Probe Probe Movement Axis

 

296    Chapter 5

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
5.1.2 Free Running Sequence

The Free Running sequence identifies an inspection sequence where data acquisition 
is performed at the rate specified in the Acquisition rate box of the Digitizer tab (UT 
Settings dialog bar). For TomoView, the data is recorded at only one position, at the 
origin of the scan and index axes.

Description of the Sequence tab

When you select Free Running for the sequence inspection type, the Sequence tab 
contains no options or parameters (see Figure 5-3 on page 297).

Figure 5-3  The Sequence tab for Free Running sequence

5.1.3 Bidirectional Scan

A Bidirectional scan type is a bidimensional surface scan (also known as a raster 
scan) sequence in which two encoders are used to determine the position on the scan 
and index axes during the acquisition. 

A surface scan uses two axes: (1) the scan axis, which is the mechanical axis of the 
scanning lines (2) the index axis, which is the mechanical axis of movement between 
the scanning lines. At the end of each scan along the scan axis, an increment is added 
to the position along the index axis. Data acquisition for bidirectional sequences is 
carried out in both the forward and backward directions along the scan axis, as shown 
in Figure 5-4 on page 298.
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Figure 5-4  Bidirectional surface scan

The user must supply the limits of the inspection surface as well as the spacing 
between acquisitions. Figure 5-5 on page 299 shows the scan-axis and index-axis 
parameters in the reference system of the scanning mechanism.
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Figure 5-5  Reference system of the scanning mechanism

Operation mode

The Bidirectional inspection sequence operates as follows:

1. The scanner proceeds to the Scan: Start position set on the Sequence tab.
2. The scanner proceeds to the Index: Start position set on the Sequence tab.
3. The scanner then moves on the scan axis to the position set in the Scan: Stop box, 

while performing data acquisition.
4. Data acquisition is performed at every interval of the Scan: Resolution value set 

on the Sequence tab.
5. The scanner moves on the index axis for the distance set in the Index: Resolution 

box.
6. The scanner moves to the Scan: Start position, while performing data acquisition.
7. The scanner moves on the index axis for the distance set in the Index: Resolution 

box.
8. The scanner then moves on the scan axis to the position set in the Scan: Stop box, 

while performing data acquisition.
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9. Steps 4 to 7 are repeated until the scanner has reached the position set in the 
Index: Stop box. Then, the sequence is finished when the scanner has reached the 
position set in the Scan: Stop box (if the index axis has an odd number of steps), 
or when it has reached the Scan: Start position (if the index axis has an even 
number of steps).

5.1.4 Unidirectional Scan

The Unidirectional scan type is a bidimensional surface-scan (also known as a raster 
scan) sequence in which two encoders are used to determine the position during the 
acquisition.

A surface scan uses two axes: (1) the scan axis, which is the mechanical axis of the 
scanning lines and (2) the index axis, which is the mechanical axis of movement 
between the scanning lines. At the end of each scan along the scan axis, an increment 
is added to the position along the index axis. Data acquisition for unidirectional 
sequences is carried out in one direction only along the scan axis, as shown in 
Figure 5-6 on page 301. This type of scanning sequence is typically used with 
scanning mechanisms revealing a rather large backlash phenomenon in scan 
direction.
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Figure 5-6  Unidirectional surface scan

The user must supply the limits of the inspection surface as well as the spacing 
between acquisitions (see Figure 5-5 on page 299). 

Operation mode

The Unidirectional inspection sequence operates as follows:

1. The scanner proceeds to the Scan: Start position set on the Sequence tab.
2. The scanner proceeds to the Index: Start position set on the Sequence tab.
3. The scanner then moves on the scan axis to the position set in the Scan: Stop box, 

while performing data acquisition.
4. Data acquisition performed at every interval of the Scan: Resolution value set on 

the Sequence tab.
5. The scanner returns to the Scan: Start position. No data acquisition is performed 

during this step.
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6. The scanner moves on the index axis for the distance set in the Index: Resolution 
box.

7. The scanner then moves on the scan axis to the position set in the Scan: Stop box, 
while performing data acquisition.

8. Steps 4 to 6 are repeated until the scanner has reached the position set in the 
Index: Stop box. Then, the sequence is finished when the scanner has reached the 
position set in the Scan: Stop box.

Description of the Sequence tab

When you select Unidirectional for the sequence inspection type, the Sequence tab 
contains the set of options shown in Figure 5-7 on page 302.

Figure 5-7  The Sequence tab for Unidirectional sequence

The Sequence tab for a Unidirectional sequence contains the same options as for a 
Bidirectional sequence. For a description of these options, please refer to section 5.1.1 
on page 295.

5.1.5 Helicoidal Scan

The Helicoidal scan type is similar to the Bidirectional scan. With this type of scan, 
the inspection mechanism performs a helicoidal movement around a cylinder. 

A helicoidal scan uses two axes: (1) the scan axis, which is the mechanical axis of the 
scanning lines (rotation), and (2) the index axis, which is the mechanical axis 
movement between the scanning lines (axial). The Helicoidal sequence operates as 
follows:

1. The scanner proceeds to the Start position specified in the Sequence tab for both 
axes.

2. The scanner then moves on the scan axis and index axis to the Stop position 
specified by the Range or Stop value of the Sequence tab.
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3. There is motion on both axes at the same time.
4. Data acquisition is performed at every interval of the Scan: Resolution value set 

in the Sequence tab.

Operation mode

The Helicoidal inspection scan is similar to the Bidirectional scan, but instead of 
executing a raster scan, the scanner executes an helicoidal movement. In this 
helicoidal-scan sequence, the two mechanical axes are driven by two motors 
controlled by an external control unit or axes of a manually driven scanner (slave 
mode), or by the MCDU-02 (master mode).

The Helicoidal inspection sequence operates as follows:

1. The scanner proceeds to the position set in the Scan: Start and Index: Start boxes 
of the Sequence tab.

2. The scanner then moves on the scan axis and index axis to the position set in the 
Scan: Stop and Index: Stop boxes, while performing data acquisition.

3. Data acquisition is performed at every interval of the Scan: Resolution value set 
on the Sequence tab.

4. In a helicoidal sequence, the scan axis is projected along the circumference of the 
cylinder. The Scan: Start and Scan: Stop values refer to the circumference origin 
point (0), in distance units or angular units.

5. A signal or a modulo can be used to reset the scan-axis encoder to the Scan: Start 
value after each complete rotation.

6. The sequence is finished when the scanner has reached the position set in the 
Index: Stop box.

Description of the Sequence tab

When you select Helicoidal for the sequence inspection type, the Sequence tab 
contains the set of options shown in Figure 5-8 on page 303.

Figure 5-8  The Sequence tab for Helicoidal sequence
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The Sequence tab for a Helicoidal sequence contains the same options as for a 
Bidirectional sequence. For a description of these options, please refer to section 5.1.1 
on page 295. This tab also contains three additional option buttons and one additional 
parameter:

deg/Index
In master mode, this text box defines the distance along the scan axis (in degrees) 
that is completed for each index increment. The Index axis inspection speed 
value is then deduced from this value, the Scan axis inspection speed, and the 
Index resolution.

The chosen Deg/Index value is usually slightly larger than 360 degrees, to obtain 
sufficient overlap between adjacent helicoidal scan lines.

This parameter has no implication in slave mode. 

Scan axis reset
Click one of these option buttons to select one of the options used to reset the 
scan-axis encoder to position zero:

None: scan-axis encoder is never reset.

Modulo: scan-axis encoder is reset to position zero when a maximum value 
(modulo) corresponding to the Scan: Stop value is reached.

Rot. Synchro.: a synchronization signal is used to reset the scan-axis encoder to 
the Scan: Start value.

5.1.6 Angular Sequence

The Angular sequence type identifies a two-dimensional surface-scan sequence, 
where the scan and index axes do not correspond to the orientation of the mechanical 
axes, such as in the Bidirectional and Unidirectional sequences. Instead, the scan and 
index lines form a certain angle with the orientation of the mechanical axes (see 
Figure 5-9 on page 305). Two position encoders are used to determine the position 
during the acquisition.

A surface scan uses two axes: (1) the scan axis, which is the mechanical axis of the 
scanning lines, and (2) the index axis, which is the mechanical axis displacement 
between the scanning lines. At the end of each scan along the scan axis, an increment 
is added to the position along the index axis. In this sequence, the mechanical axes 
work together in such a way as to produce the desired scanning pattern. Data 
acquisition for angular sequences is carried out in both the forward and backward 
directions along the scan axis.
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Figure 5-9  Angular surface scan

Operation mode

The Angular inspection sequence operates as follows:

1. The scanner proceeds to the position set in the Scan: Start and Index: Start boxes 
of the Sequence tab.

2. The scanner then moves on the scan axis, according to the specified angle, to the 
position set in the Scan: Stop box, while performing data acquisition.

3. Data acquisition is performed at every interval of the Scan: Resolution value set 
on the Sequence tab.

4. The scanner moves on the index axis, according to the specified angle, for the 
distance set in the Index: Resolution box.
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5. The scanner moves on the scan axis, according to the specified angle, to the Scan: 
Start position, while performing data acquisition.

6. The scanner moves on the index axis, according to the specified angle, for the 
distance set in the Index: Resolution box.

7. The scanner then moves on the scan axis, still according to the specified angle, to 
the position set in the Scan: Stop box, while performing data acquisition.

8. Steps 4 to 7 are repeated until the scanner has reached the position set in the 
Index: Stop box. Then, the sequence is finished when the scanner has reached the 
position set in the Scan: Stop box (if the index axis has an odd number of steps), 
or when it has reached the Scan: Start position (if the index axis has an even 
number of steps).

Description of the Sequence tab

When you select Angular for the sequence inspection type, the Sequence tab contains 
the set of options shown in Figure 5-10 on page 306.

Figure 5-10  The Sequence tab for Angular sequence

The Sequence tab for an Angular sequence contains the same options as for a 
Bidirectional sequence. For a description of these options, please refer to section 5.1.1 
on page 295. This tab also contains an additional parameter, which is required for this 
sequence type:

Angle
This box is used to set the angle that the scan line forms with the orientation of the 
mechanical axis.

5.1.7 Custom Sequence

Selecting the Custom sequence type automatically opens the Load Custom Program 
File dialog box (see Figure 5-11 on page 307). This dialog box is used to select and 
load a special type of sequence predefined in a .gal file.
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Figure 5-11  The Load custom program file dialog box

5.2 Working with Encoders

You can use one or more encoders in your setup to measure the position of the probe 
on the scanned area. 

Tomoview supports different types of encoders (see section 5.2.1 on page 307). 

You need to calibrate each encoder (see section 5.2.2 on page 309).

5.2.1 About Encoder Types

TomoView supports various types of encoders. You can select the encoder type on the 
Encoders tab of the Scan and Mechanical Settings dialog box (see Figure 5-12 on 
page 307).

Figure 5-12  Selecting the encoder type on the Encoders tab
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Each encoder input on your acquisition unit has two channels, A and B, enabling a 
dual-channel encoder for quadrature reading of the resolution. 

The available encoder types are:

Clock Dir
Select this option when you use a stepper controller and its documentation 
specifies that the position output signal is a clock/direction type (5 V pulse for the 
position/speed and 5 V signal for the direction).

Quadrature
Select this option when the attached encoder (5V TTL output) is a dual-channel 
output encoder. The channels are generally named A and B. When the encoder is 
rotating clockwise (from left to right in Figure 5-13 on page 308), channel B 
follows channel A with a 90-degree delay. When the encoder is rotating 
counterclockwise, channel A follows channel B with a 90-degree delay. In this 
way you can determine if the rotation is clockwise or counterclockwise. The 
decoder counts one step each time it detects a rising or a falling edge on 
channel A or channel B. This means that if the real encoder resolution is 
1,000 steps/revolution, the final resolution with the quadrature reading is 
4,000 steps/revolution. 

Figure 5-13  Quadrature and normal reading of the resolution

Up
The decoder only reads channel A and increments the counter even if the encoder 
is turning counterclockwise. The final resolution is the real encoder resolution.

Down
The decoder only reads channel A and decrements the counter even if the encoder 
is turning clockwise. The final resolution is the real encoder resolution.

Channel A

Channel B

Quadrature reading

Normal reading
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Clock/Dir Up
The decoder only reads channel A and increments the counter. When the signal of 
channel_B (direction) is high, the acquisition stops to prevent overwriting the 
data while you move the probe back and the counter is decremented.

Clock/Dir Down
The decoder only reads channel A and decrements the counter. When the signal 
of channel_B (Dir) is high, the acquisition stops to prevent overwriting the data 
while you move the probe back and the counter is incremented.

Quad Up
The decoder reads channel A and channel B in quadrature mode (4 times the 
encoder resolution) and increments the counter when the encoder rotates 
clockwise. When the encoder rotates counterclockwise, the acquisition stops to 
prevent overwriting the data and the counter decrements. 

Quad Down
The decoder reads channel A and channel B in quadrature mode (4 times the 
encoder resolution) and decrements the counter when the encoder rotates 
counterclockwise. When the encoder rotates clockwise, the acquisition stops to 
prevent overwriting the data and the counter increments. 

5.2.2 Calibrating an Encoder

You need to calibrate an encoder to validate, fine tune, or determine its resolution. The 
resolution of an encoder is the number of steps corresponding to a travelled distance 
of 1 mm or 1 in., or 1 degree. 

Perform the following procedure for each encoder that you are using.

To calibrate the encoder of an axis

1. On the Component toolbar, click the Scan and Mechanical Settings button ( ).
2. In the Inspection Sequences and Mechanical Settings dialog box, click the Scan 

tab, and then perform the following tasks:
a) In the Type box, select the appropriate scan type for your application. Do not 

select Free running as this type does not support encoders.
b) In the Unit box, select the appropriate linear or angular units.

3. In the Encoders tab (see Figure 5-14 on page 310): 
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a) In the Type box, select the type of your encoder (see section 5.2.1 on 
page 307).

b) Click Calibrate.

Figure 5-14  The Encoders tab of the Scan and Mechanical Settings dialog box for 
an Encoded - 2 axis scan type

4. While in the Calibration of Encoder dialog box (see the example shown in 
Figure 5-15 on page 311): 
a) Optionally, move the required encoder, or the mechanics attached to the 

encoder, to a known position on the axis, and then click Set. 
This operation sets the current position to the value of the Preset value box 
that has been specified on the Sequence tab.

b) Click Set Begin.
c) Move the encoder over a defined distance on the axis in the direction that is 

considered positive. In the case of master mode, use the Movement buttons to 
move the scanner. 

d) Click Set End.
e) In the Set Distance text box, enter the travelled distance, and then click Set 

Distance.
The resulting encoder resolution appears in the Calculated resolution box. 

f) When needed, click Clear to reset the parameter values, and then return to 
step 4.a.

g) Click OK to apply the calculated encoder resolution. 
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Figure 5-15  The Calibration of Encoder dialog box for encoder 1 on the scan axis

5.3 Working with the Position-Dependent Setup

The Position-Dependent module was developed for the inspection of samples having 
changing geometries requiring different setup files in a single acquisition. 

5.3.1 About the Position-Dependent Setup Module

Using the Position-Dependent Setup module, you can synchronize the different setup 
and data files. The module loads the appropriate setup and initiates the data storage 
on a disk, based upon the current manipulator position on the index axis.

For example, a first setup is loaded and a scan is performed from y1 to y2: The data is 
stored when the position value (x1,y2) is reached. Then, setup file 2 is loaded and data 
acquisition starts from index line y3 to y4. On completion of the scan (x2,y4), the data is 
stored in a new file and setup file 3 is loaded. Data acquisition starts at point (x2,y5) 
and ends at (x1,y6). On completion, the data is stored and a new file is created 
containing all data. Figure 5-16 on page 312 illustrates this mechanism.
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Figure 5-16  Synchronization of setup and data files

5.3.2 Position Dependent Setup Dialog Bar

The position-dependent setup is set with the Position Dependent Setup dialog bar 

(see Figure 5-17 on page 312). You open this dialog box by clicking  on the Main 
toolbar.

Figure 5-17  The Position Dependent Setup dialog bar

The Position Dependent Setup dialog bar contains the following options:

 Setup 1 Setup 2 Setup 3

Data 1 Data 2 Data 3

X1,Y1 X1,Y3

X2,Y5

X1,Y2

X2,Y4

X1,Y6

X

Y

Change of 
geometry
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Control list
The columns in this list box display the following information:

Setup File (full path): list of setup files used for the inspection
Acquisition File Name: associated data acquisition file
Index Start and Index End: index positions where the setups are valid

Add
This button adds a line for a new setup to be used during the inspection.

Remove
This button removes a line (a setup) from the list.

Select Setup File
This button selects the setup to be used for a particular line.

Import, Export
These buttons load or save a particular setup sequence.

Automatic merge
This check box, when selected, specifies that the data acquisition files are to be 
merged into one at the end of the inspection.

File name
This box specifies the name of the final merged file.

Save files in
This box specifies the name of the folder where the data acquisition files are to be 
saved.

Start Inspection
This button starts the inspection, with the setup files and the acquisition file 
names defined in the control list.

5.3.3 Use of the Position-Dependent Setup Module

Once the different setup files to be used throughout the acquisition have been created, 
follow these steps to configure the Position-Dependent module:
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Before using the position-dependent setup module, you must properly define the 
setups, particularly the mechanical sequence of each setup.

To use the position-dependent setup module

1. Set the scan and index positions to the start of the first setup to be used.

2. On the Main toolbar, click  to open the Position Dependent Setup dialog bar.
3. Click Add. 

A new line appears in the control list, with an asterisk (*) in the left column.

a) Click Select Setup File and choose a setup file to be associated to the first 
section of the sample to inspect. 

b) In the Index Start and Index End columns, enter the index positions to be 
associated to the this setup file.

c) In the Acquisition File Name column, enter the dat file name that will be 
generated at the end of the section. 

4. Repeat step 3 for all setups to be used for the inspection.
5. Select the Automatic merge check box if you want the individual data acquisition 

files to be merged into one.
a) Select the C-Scan Only if only the C-Scan data is to be merged.
b) In the File Name box, enter the name of the merged file.

6. In the Save files in section, click  and select the folder where files are to be 
saved in the dialog box. 

7. Click Start Inspection to start the acquisition according to the specified setup 
files.

5.3.4 Limitations

The position-dependent setup module has the following limitations:

• The change in setup can only be defined along the index axis.
• During setup change, the manipulator must be stopped for TomoView to load the 

setup.
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• At inspection start, the first setup loaded is the one closest (at higher values) to the 
current index position.

• The Index Start and Index End positions must be exactly the same as the ones 
defined in the setup files.

• The total size of the merged file cannot be higher than the size allowed by 
TomoView available in the Acquisition File Properties section on the General 
Settings tab of the Preferences dialog box.

5.4 Defining the Automatic Savings Options

In the Options tab of the Scan and Mechanical Settings dialog bar (see Figure 3-85 on 
page 159) you can use the File Naming Options section to configure the way the data 
files will be saved at the end of the inspection sequences. See Figure 5-18 on page 315

Figure 5-18  The File Naming Options dialog box

To configure the automatic saving options

1. Set Directory to the folder where the files are to be saved.
2. Set Root Name to the name of the data files to be saved.

• The @ character inserts a counter, which will be automatically increase the file 
name by one. For example, entering test@ will generate test0.rdt, test1.rdt, 
test2.rdt, and so on. 

• The # character adds the desired number of digits for repeats. For example, 
typing test@## will generate test000.rdt, test100.rdt, test200.rdt, and so on.

• If a file exists (for example, test000.rdt) then the new file will be saved under 
the following name: test001.rdt (first repeat of the test000.rdt file name). 

3. Set Counter value to configure the counter start value of the counter that is 
inserted in the file name with the @ character. 

4. Select the saving mode from Automatic, Prompt, or Confirm. 
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• The Automatic mode will save the data files without asking for a 
confirmation.

• The Prompt mode will deactivate the automatic file naming and ask you to 
enter the data file name at the end of every acquisition. 

• The Confirm mode will ask you to confirm the file name defined in the Root 
name before saving the data file.
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6. Basic Analysis Using TomoView

Once acquisitions have been completed, TomoView can be used to analyze the 
resulting data files. This section describes the basic analysis in TomoView, 
demonstrating how you can manage data files to create simple and convenient reports 
making the inspection results easy to understand. 

6.1 Working with Data Files in TomoView

This section describes how to open TomoView and OmniScan data files and merge
data files in order to combine multiple inspection data to a single file that can then be
analyzed and described in a simple report. 

6.1.1 Opening a TomoView Data File

The Open dialog box (see Figure 6-1 on page 318) is used to select and load an 
ultrasonic data file as well as the other data types that can be linked to this file.

To open a TomoView data file

1. In the Document toolbar, click . 
2. Make sure that Data is selected in the upper left section of the Open dialog box.
3. Select File Content and Processing options (see below for more information on 

these options).
4. Click Open.
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Figure 6-1  The Open dialog box

The File Content and Processing group boxes contain the following options:

File Content
This group box encloses check boxes, with which you can select the associated 
files (for a description of the file types, see section 3.18 on page 221).

For example, an .rdt data file can be saved with an .A01 data file resulting from 
analysis processing. You can then either open the original data alone (.rdt file), or 
open the original data along with the data modified in analysis (.rdt and .A01 
files). The principle of associated files allows the original data to remain intact 
after the data file is saved.

Only the file types that are associated with the .rdt file when saving the data can 
be selected. The dimmed file types are not available.

Processing
You can use the check boxes enclosed in this group box to select optional 
calculations to be performed on the file to be opened. After opening the file, 
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TomoView calculates the selected processing options and adds the associated 
data groups to the file. 

• The Merge all check box performs the same calculations as the menu 
command Processing > Automatic Volumetric Merge. 

• The Merge by group check box performs the same calculations as the menu 
command Processing > Automatic Volumetric Merge by Group. 

• The Thickness soft C-scan check box is only available when converting 
OmniScan data files (see section 6.1.3 on page 322 for more information). 

6.1.2 Importing OmniScan Data Files

This section explains how to import OmniScan data files and convert them into 
TomoView files using the OmniScan File Converter. By converting OmniScan data 
files, you can use the powerful analysis tools offered by TomoView to analyze 
OmniScan data.

To import an OmniScan file into TomoView

1. On the Component toolbar, click  to open the OmniScan File Convertor (see 
Figure 6-2 on page 320).
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Figure 6-2  The Open dialog box

2. To apply one of the template layouts on the converted data files, select the Use 

layout check box and the  to select a layout. When the converted files are 
opened in TomoView, all views, readings, and preferences will be properly set 
(see Figure 6-3 on page 320).

Figure 6-3  The Use Layout list
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3. In the Processing group box:
• Select the Merge all check box to launch the volumetric merge processing 

after the conversion (the same calculations as the menu command 
Processing > Automatic Volumetric Merge). 

• Select the Merge by Group check box to launch the volumetric merge by 
group processing after the conversion (the same calculations as the menu 
command Processing > Automatic Volumetric Merge by Group).

• Select the Thickness Soft C-Scan check box to create a thickness C-Scan using 
the original OmniScan thickness information.

If you do not select any layout file, you view blank panes on the TomoView screen. 
However, it is possible to select a template layout when TomoView is opened.

4. Select an OmniScan .oud (Conventional UT) or an.opd (Phased Array) data file 
and click Open.
You have a choice between an .oud file for data acquired with conventional 
ultrasonic technology and an .opd file for phased array ultrasonic technology.
A Save As dialog box appears (see Figure 6-4 on page 322). You can use this 
dialog box to select where the template file is to be saved.

If the file that you are trying to convert is not supported, you might need to use the 
latest Stand Alone OmniScan Converter or upgrade to a more recent TomoView 
version that supports new formats.
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Figure 6-4  The Save As dialog box

5. In the File name text box, type a name for the .rdt file that will be created.
6. Click Save.

6.1.3 Merging Data Files

With the data file merger component, you can merge multiple data files into one to 
create a new data (.rdt) file that contains all the data (groups) of the original files. You 
can perform the file merge process on both conventional and phased array data files.

As the resulting data file is a common .rdt file, you can apply most of the generic 
TomoView processing algorithms to this file (for example: volumetric merge of data, 
hysteresis correction of data).

The data file merger component in combination with the volumetric merge function 
can be extremely useful for applications where you perform the part or weld 
inspection in various sections, each contained in a different data file. You can use the 
consecutive application of the Data File Merger function and the Volumetric Merge 
function to create data groups covering the complete inspected volume. In addition, 
you can correct mechanical offsets from the View > Properties dialog box, in the 
Parameters tab.
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The total size of the merged file cannot exceed 1 GB.

To merge data files

1. On the menu, click File > Merge Files. 
2. In the Data File Merger dialog box (see Figure 6-5 on page 323):

a) Click the browse button ( ) on the right of the Destination file text box to 
select a folder and a file name for the final merged file. 

b) Click the add button ( ) to select the first data file (.rdt) to be merged. 
c) Repeat step 2.b to add the other data files to be merged.
d) If files that you want to merge are currently open in TomoView, close them.
e) Select the Merge companion file (A01) check box to also include the 

companion file data in the merge.
f) Select the C-scan only check box to only merge C-scan data. Since A-scans are 

not saved, this option allows to create files with significantly larger patch area 
before reaching the data file size limit.

g) Click Merge. 

Figure 6-5  The Data File Merger dialog box
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6.2 Working with the Indication Table and Report Component

The indication table is a key feature of TomoView (see Figure 6-6 on page 324). Use 
the Indication Table to gather flaw indication information and to create an HTML 
report. The basic steps are:

• Use the cursors and the Zone tool to highlight an indication
• Open the indication table and add an indication
• Add comments and extra readings to the table
• Customize the report
• Preview and produce the HTML report

Figure 6-6  The indication table

TomoView automatically saves the Indication Table in the display setup file (.RST) 
and automatically saves the numerical reading indication information contained in 
the Indication Table in an attribute file (.R01). 

6.2.1 Adding an Indication to the Indication Table

Use the Zone tool and the indication table to quickly select the area corresponding to 
an indication and create a record for the indication.
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You can customize the sizing settings in the Preferences dialog box, in the General 
Settings tab under Flaw-Sizing Settings.

To add an indication to the indication table

1. Select a layout with views that best illustrate the indications in the part (see the 
example shown in Figure 6-7 on page 325).

Figure 6-7  Example of the indication table, the cursors, and the Zone tool used to 
document an indication

2. On the Component toolbar, click the Indication Table button ( ) to display the 
Indication Table dialog box. 
The first line of the table indicates the current value of the selected readings.
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3. Position the reference and measurement cursors to mark the indication.
4. Using the Zone tool, draw a zone around a flaw indication.
5. In the Indication Table dialog box, select a predefined reading category (see 

Figure 6-8 on page 326) to select the readings that appear in the table.

Figure 6-8  Selecting a predefined reading category in the indication table

You can select a different reading category for each indication table entry. 
The indication image is a snap shot of the data display views taken when you click 

. When you want to put the emphasis on the defects characteristics, 

configure the views accordingly before clicking .

6. In the Indication Table dialog box, click .
The selected flaw indication is added to the Indication Table list and a red 
marking rectangle labeled with the indication number appears on the view.

7. As needed, repeat steps 3 to 6, to mark other indications. 
8. You can add a comment to an indication:

a) In the Indication Table dialog box, select the indication to which you want to 
add a comment by clicking on the corresponding line in the table. 

b) Click Additional Info.
c) In the Custom Readings dialog box that appears (see Figure 6-9 on page 327), 

type your comment for that indication in the Comment text box.
The comment then appears in the Comments section of the report for the 
selected indication.
326    Chapter 6

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Figure 6-9  Adding a comment and an additional reading to an indication

9. You can also include additional readings to the indication table (see Figure 6-9 on 
page 327):
a) In the Indication Table dialog box, select the line for the Entry# = Auto 

indication.

b) In the Custom Readings dialog box, click .
c) In the Readings Selection dialog box that appears, select the check box of one 

or more readings that you want to add to the selected indication, and then 
click OK.
The selected readings appear in the Custom Readings dialog box, under 
Additional readings.

Additional readings appear only for new indications, not for those already entered in 
the indication table.
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6.2.2 Producing an Ultrasonic Inspection Report

Once you have completed the indication analysis using the indication table, you can 
produce an HTML ultrasonic inspection report from the Indication Table dialog box. 
This report includes the following elements for each defined group of the 
configuration:

• Setup information
• Inspected part information
• Scanned area information
• Content of the indication table
• Views for each entry of the indication table
• Customized information

To produce an ultrasonic inspection report

1. Gather indication information in the indication table (see section 6.2.1 on 
page 324).

2. From the Indication Table dialog box click General info to open the General 
Information dialog box and customize the HTML report (see Figure 6-10 on 
page 329) 
a) In the Report Header text box, type your report header information.

The text appears at the beginning of the report (see Figure 6-11 on page 329).
b) In the Footnote text box, type your report footnote information.

The text appears in the Notes section at the end of the report (see Figure 6-12 
on page 330).

c) Click .
d) Type the custom information label in the Field text box and the 

corresponding value in the Value text box.
The added user fields appear in the second section from the top of the report 
(see Figure 6-11 on page 329).

e) Click OK.
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Figure 6-10  Example of the General Information dialog box

Figure 6-11  Example of a report header and user fields

Report header text

User field text
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Figure 6-12  Example of a report footer

3. Back in the Indication Table dialog box, click Preview. 
The HTML report appears in your Internet browser.

4. Review the report.
5. In the Indication Table dialog box, click Print. 
6. In the Print dialog box, select the printer, and then click Print to print the report.

6.2.3 Changing the Logo in the Inspection Report

The Evident logo appears by default at the top of the inspection report. You can 
change the logo. 

Ensure to change the logo before creating the report. Otherwise, the old image will 
appear in the report. You then need to delete the report file (.r01) and add the 
indications again.

To change the logo appearing at the top of the inspection report

1. Create a small image of the logo that you want to see at the top of the inspection 
report.

Report footer text
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Use a logo image that is about the same size as the Evident logo image (200 pixels 
wide by 38 pixels high). 

2. In the [Installation Folder]\TomoView210 folder:
a) If you do not want to loose the Evident logo file, rename the logo.jpg file to 

Evident_logo.jpg. 
b) Save the image of your logo in the JPEG format using the logo.jpg file name.
Your logo appears at the top of the next inspection report that you generate.
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7. Advanced Analysis Using TomoView

This chapter describes how to use the multiple advanced analysis features available in 
TomoView. 

7.1 Working with the Thickness C-Scan Process

A thickness C-Scan is a part thickness color illustration used to highlight thickness 
variations. This view is useful for the monitoring of part wear or corrosion.

To create a thickness C-Scan

1. From the menu, select Processing > Create Thickness C-Scan.
2. In the Create Thickness C-Scan dialog box, (see Figure 7-1 on page 334

a) In the Groups list, select the group to create a thickness C-Scan.
b) In the Thickness types list, for example, select A ^ - I/. 
c) To customize the color palette limits, from the Thickness gate area, select 

Override with user values, and then set Min. and Max. parameters to the 
desired values.

d) Click Create.
e) Click Done. 

3. Choose a view in a layout to be configured as a thickness C-Scan.
4. On the menu, choose View > Contents.
5. In the Contents dialog box, select a thickness C-Scan view (see Figure 7-2 on 

page 334). 
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Figure 7-1  The Create Thickness C-Scan dialog box 

Figure 7-2  Selecting a thickness C-Scan view

The thickness C-Scan illustration appears in the view (see example in Figure 7-3 on 
page 335). 
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Figure 7-3  Example of a thickness C-Scan

7.2 Working with the Volumetric Merge Process

A TomoView view can only display the data of one data group. The volumetric merge 
function condenses the information of several groups into one group, so that you can 
view more information in a single view. 

In data analysis mode, you can use the Volumetric Merge function to perform a 
merge of the ultrasonic data acquired with various groups. The merging process 
compares the amplitude obtained at each point of the inspected volume by the 
considered groups, and creates a new data group with the maximum amplitude 
observed at each position in the inspected volume.
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The volumetric merge function is a wizard taking you step by step through the 
merging configuration process. You can save the configuration defined with the 
wizard in a volumetric merge configuration file (.vmc), and recall the file to quickly 
perform a similar volumetric merge. Refer to section 7.2.1 on page 336 for details on 
the volumetric merge configuration file format.

TomoView saves the created merged data in the attributes file (.A01) that is saved as 
part of the data file (.rdt).

You can also use the Automatic Volumetric Merge that uses the default volumetric 
merge parameters, thus bypassing the steps of the volumetric merge wizard. All 
groups (except TOFD groups) are merged together but the original data is always 
preserved (see section 7.2.2 on page 342). You can also perform an Automatic 
Volumetric Merge when converting OmniScan data files. 

7.2.1 Performing a Volumetric Merge

The volumetric merge function is a wizard taking you step by step through the 
merging configuration process.

To perform a volumetric merge

1. Open a data file containing more than one beam or more than one data group.
2. On the menu, choose Processing > Volumetric Merge. 

The Volumetric Merge wizard starts.
3. Under Groups Selection (see Figure 7-4 on page 337), select which beams or 

groups to merge:
a) Under Merge Data, select the beam or group type to be displayed in the 

Available Groups list. 
b) In the Available Groups list, select the beams and groups you wish to merge, 

and then click Add. 
The selected beams or groups appear in the Selected Groups list.

c) If you want to use a previously defined volumetric merge configuration 
(VMC), click Load Configuration from VMC File, and then select the desired 
file (.vmc).

d) Click Next.
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Figure 7-4  The Groups Selection group box

The volumetric merge function does not work when a cylindrical specimen is defined. 
Also, it is impossible to merge different data types together (for example, A-scan with 
C-scan).

4. Under Parameters Settings, select which beams or groups to merge:
a) Under Processing Options, select which skips to use. 
b) Click Next.

5. Referring to (see Figure 7-5 on page 339), perform the following tasks:
a) Under New Group Information, type a name for the beam or group to be 

created. 
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b) Under Merge Type:
 Select Full to perform a merge of all probe positions for the considered 

beams or groups, and then set Thickness to the thickness of the inspected 
part. It is taken into account for the calculation of the rebounds.
OR
Select Probe position selective to perform a merge for particular probe 
positions, which you specify in the From and To boxes for the Scan, 
Index, and USound axes.

c) Under Generated Data:
(1) Select Include group information to keep the information related to the

origin of each point of the merged data group and save it in the attributes
file (.A01) with the merged data.

(2) Select Generate peak A-scan instead of A-scan to generate a peak A-scan
for the merged group. 

(3) Set Limit to the amplitude threshold level for the generation of the peak
A-scan. 

(4) Set Peak number to the number of peaks (maximum value is 127) for the
generation of the peak A-scan.

d) Click Next.
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Figure 7-5  The New Group Information, Merge Type, and Generated Data group 
boxes

6. Referring to (see Figure 7-6 on page 340), perform the following tasks:
a) Under Merge Dimension, set the merge dimensions for the three axes. 

The Memory required parameter displays the corresponding required 
memory to process and store the data. 

b) If needed, click Reset to Defaults to reset the limits of the inspected volume 
for the merged data group to the Overall Dimensions, and the resolution to 
the nominal value.

c) Click Next.
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Figure 7-6  The Merge dimensions and Overall dimensions group boxes

7. Referring to (see Figure 7-7 on page 341), perform the following tasks:
a) Consult the values in the Data Information and Volume Information 

sections to validate the volumetric merge parameters. 
b) Click Back if you need to adjust parameters in the previous steps. 
c) If you want to save your volumetric merge configuration to a file (.vmc), click 

Save to File, and then specify the folder and file name for the file. 
d) Click Finish to perform the volumetric merge. 

The merged group is added to the contents (see Figure 7-7 on page 341 and 
Figure 7-8 on page 341). 
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Figure 7-7  The Data information and Volume information group boxes

Figure 7-8  Example of the volumetric merge group created
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7.2.2 Performing an Automatic Volumetric Merge

The Automatic Volumetric Merge function performs the volumetric merge of all 
beams in the currently selected file using the default values of the Volumetric Merge 
dialog box (see section 7.2.1 on page 336). The merge process transforms the sectorial 
group data into bitmap images of end-view slices.

To perform the volumetric merge

1. Open the file on which you wish to perform a volumetric merge.
2. On the Processing menu, select Automatic Volumetric Merge. 

TomoView processes the data and displays the new data on the screen.

7.2.3 Performing an Automatic Volumetric Merge by Group

The Automatic Volumetric Merge by Group function performs the volumetric merge 
of all beams for each group using the default values of the Volumetric Merge dialog 
box (see section 7.2.1 on page 336) and creates one merged data group per group.

To perform the volumetric merge by group

1. Open the file on which you wish to perform a volumetric merge.
2. On the Processing menu, select Automatic Volumetric Merge by Group.

The merged data groups are added to the view Contents list.

7.3 Customizing Readings

Readings can be customized in Analysis mode in the same way as in the Setup mode.
For details on how to customize readings, see section 4.10 on page 276.

7.4 Working with the Amplitude Drop Sizing Utility

You can use TomoView to display the various readings related to the active data file 
and the data views (see section 7.3 on page 342). With user-defined flaw sizing 
settings, you can use some of these parameters to get information on the position and 
the size of a flaw indication.
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7.4.1 Defining or Modifying Flaw Sizing Settings

The View Information parameters, related to indication sizing, allow for –X dB 
amplitude drop sizing of a flaw indication in its three dimensions simultaneously 
(scan, index, and ultrasonic axes). The value of X can be defined independently for 
each axis.

To define or modify the flaw sizing settings

1. On the menu, select File > Preferences.
2. In the Flaw sizing settings group box of the Preferences dialog box, click General 

Settings tab (see section 4.10 on page 276).
a) In the Amplitude drop (-X dB) group box, enter the -X value for each axis 

independently (only negative values are accepted).
b) In the Peak holding algorithm group box, enter the number of samples to be 

used for the peak holding algorithm for each axis independently.
The default value is 0, but if for a given axis a value n larger than 0 is entered, 
the sizing algorithm, along this axis, “ignores” an amplitude drop below -X 
dB that is smaller than n samples. This tool can be used to group several 
flaws, or to avoid the problems related to the use of nonsmoothed A-scan 
signals. 

c) If the check boxes are selected in the Fill acquisition gaps group box, the 
sizing algorithm ignores the missing acquisition points or lines along the 
considered axis by interpolating between the adjacent valid acquisition points 
or lines. 

Figure 7-9  General Settings tab
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Applying the peak holding algorithm, for a given axis, can oversize the indication by 
2×n samples for this axis.

7.4.2 Determining the Location and Dimensions of Flaw Indications

The View Information parameters can be used not only to determine the dimensions 
of a flaw indication using –X dB amplitude drop sizing, but also to determine the 
location of the flaw indication in the inspected volume. The following procedure uses 
the Zone tool of the TomoView software.

To determine the location and dimensions of a flaw indication in 3-D

1. Create a suitable display layout, showing at least the Top (C), Side (B), or the End 
(D) views.

2. In one of the displayed views display the parameters (as shown in Table 14 on 
page 344).

Table 14  Parameters for flaw indication 

Parameter Description

Z. Max. Ampl. Zone maximum amplitude

Z. Max. Scan Pos. Zone maximum amplitude position on the scan 
axis

Z. Max. Index Pos. Zone maximum amplitude position on the index 
axis

Z. Max. UT Path Pos. Zone maximum amplitude position on the 
ultrasonic axis

Z. Scan1 –X dB Position 1 along the scan axis of “maximum 
amplitude –X dB” position

Z. Scan2 –X dB Position 2 along the scan axis of “maximum 
amplitude –X dB” position
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These readings can be found in the Statistics > Zone category of the Information 
Groups dialog box (see Figure 7-10 on page 346). Note that the Expert mode must 
be activated for these readings to be available (see section 3.16 on page 220). 

Z. Index1 –X dB Position 1 along the index axis of “maximum 
amplitude –X dB” position

Z. Index2 –X dB Position 2 along the index axis of “maximum 
amplitude –X dB” position

Z. USound1 –X dB Position 1 along the ultrasonic axis of “maximum 
amplitude –X dB” position

Z. USound2 –X dB Position 2 along the ultrasonic axis of “maximum 
amplitude –X dB” position

Z. Scan2 – Scan1 –X dB Length of the flaw indication at –X dB along the 
scan axis

Z. Index2 – Index1 –X dB Length of the flaw indication at –X dB along the 
index axis

Z. USound2 – USound1 
–X dB

Length of the flaw indication at –X dB along the 
ultrasonic axis

Table 14  Parameters for flaw indication (continued)

Parameter Description
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Figure 7-10  Statistics parameter category of the Information Groups dialog box

3. Visualize the region of interest in the considered recorded data (see Figure 7-11 on 
page 347).
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Figure 7-11  Data display examples

4. Position the gate selectors for the ultrasonic axis so that the flaw indication to be 
sized is located between the gate selectors.

5. Create a zone in the Side (B) view [End (D) view] containing the considered flaw 
indication.

6. Create a zone in the Top (C) view containing the considered flaw indication.
7. The zone in the Side (B) or End (D) view is automatically adjusted to the gate 

selector limits. In fact, you have now created a volumetric zone defined by the 
contour in the Top (C) view and the gate selectors in the ultrasonic axis (see 
Figure 7-12 on page 348). The parameters in the Information Groups dialog box 
give the maximum amplitude of the flaw indication, its position along each axis, 
and its size along each axis, with the user-defined amplitude drop value.
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Figure 7-12  Examples of flaw indication sizing with the zone tool
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7.5 Working with the Gain Information Component

The Gain Information dialog bar (see Figure 7-13 on page 349) is used to monitor the
different gain settings, and to adjust the software gain applied to the signal and/or the
color palette settings in either setup or analysis mode. 

Figure 7-13  The Gain dialog bar

The Gain dialog bar displays the current color palette. Double-clicking between the
top and bottom cursors reduces the current palette range by a factor of two. Double-
clicking outside the cursors restores the default full-palette range.

Dragging the top or bottom color palette cursors, respectively, sets the upper and
lower limits of the color palette range in percentage (linear data), or in decibels
(logarithmic data). Dragging the color palette itself sets the lower and upper limits of
the color palette range. 

Dragging the slider, or using the arrow keys, sets the software gain, which ranges
from –100 dB to +100 dB. The software gain slider sets a software-calculated
amplitude gain that is applied to both the displayed images and the amplitude values
in the readings, but leaves the raw acquisition data unchanged.

When applying negative software gain to ultrasonic data, pixels over 100 % FSH keep
applicable color code for saturation and the corresponding information view keeps
returning 100 % for the signal amplitude. 

Software gain slider

Top color palette cursor

Bottom color palette cursor
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To add or remove software gain

1. Select the view for which you want to modify the gain information.

2. On the Main toolbar, click the Gain Information button ( ).
The Gain dialog bar appears (see 7.14 on page 400).

The Hard Gain information box indicates the applied hardware gain. This 
information can be modified in the is defined in the UT Settings > General dialog bar.

3. To modify the software gain:
• Move the software gain slider cursor up or down using the mouse.
• Click in the Gain information dialog box and use the up and down keyboard 

arrow keys to increase or decrease the software gain in 0.1 dB increments.
• Click above or below the slider cursor ( ) to increase or decrease the 

software gain in 6 dB increments.
• Click on the Soft Gain (dB) button to sete the software gain.
• On the color palette, double-click between the cursors to divide the current 

palette range by two, or outside the cursors to restore the default full palette 
range.

7.6 Working with the TOFD Manager Component

The TOFD Manager is a complete tool for time-of-flight diffraction (TOFD) 
inspections that performs both basic and advanced analysis of TOFD examination 
data. Using the TOFD Manager, you can perform online and offline TOFD 
calibrations with either conventional or phased array probes.

You can also use the TOFD Manager to perform advanced analysis using typical 
TOFD cursors, algorithms for both lateral wave synchronization (straightening) and 
lateral wave removal, and a synthetic aperture focusing technique (SAFT) algorithm. 
All processing algorithms are developed to leave the raw inspection data unaffected. 
However, all processed data can be saved in separate data groups in the attributes file 
(.A01).
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You can open the TOFD Manager from the Component toolbar by clicking the TOFD 

Manager button ( ) or from the menu by selecting Components > TOFD Manager 
Window. The TOFD Manager dialog box is shown in Figure 7-14 on page 351.

Figure 7-14  The TOFD Manager dialog box

In the Information Groups dialog box, when the expert mode is active, a TOFD 
group of reading is available (see Figure 7-15 on page 351) for fast and easy length 
and through-wall sizing of indications in combination with the Indication Table (see 
section 6.2.1 on page 324).

Figure 7-15  The TOFD readings in the Information Groups dialog box
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The TOFD Manager is not available in the Lite Aero and Lite Weld editions.

7.6.1 Description of the TOFD Manager Dialog Box

This section describes the TOFD Manager dialog box (see Figure 7-16 on page 352).

 

Figure 7-16  The TOFD Manager dialog box

The TOFD Manager dialog box (see Figure 7-16 on page 352) contains the following 
group boxes:

Analysis Tools
Specifies parameters for the calibration of the ultrasonic axis (depth) for TOFD 
data.

Focalization Process
Allows the operator to use the SAFT algorithm on TOFD data.

Lateral Wave Processing
Specifies parameters for lateral wave processing (synchronization and 
removal).

7.6.1.1 Analysis Tools Group Box

The Analysis tools group box contains the following buttons:
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Calibration
Opens the TOFD dialog box in order to perform TOFD calibration (see 
Figure 7-17 on page 353).

TOFD dialog box

Figure 7-17  TOFD dialog box

The TOFD dialog box contains text boxes (on a white background) for the values that 
can be changed, or display boxes (appearing dimmed) for the values that are 
calculated from the other values. The dialog box contains the following elements:

What Do You Want To Compute?
This group box encloses option buttons used to select the parameter that is to be 
calculated from the other parameters.

Compute reference cursor position
This option is used to adapt the TOFD ruler to set its zero position at the 
reference cursor position. Position the reference cursor on the first echo 
signal, and then click OK.
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Compute velocity and wedge delay
This option is used to calculate both the material sound velocity and the 
probe wedge delay, by using two reference signals, typically the lateral wave 
and the back-wall echo.

Compute wedge delay
This option is used to calculate the probe wedge delay, by using a fixed value 
of the sound velocity and one reference signal, typically the lateral wave or 
the back-wall echo.

Scan Axis
This group box encloses option buttons used to select the scan axis orientation 
relative to the ultrasonic beam projection: Parallel to beam or Perpendicular to 
beam.

Reference cursor position
This box defines the real (true depth) reference cursor position in millimeters 
(mm) or inches (in.).

Probe separation
This box defines the distance between the probe exit points in millimeters 
(mm) or inches (in.). This distance is always measured along the component 
surface.

Sound velocity
This box defines the material sound velocity in meters per second (m/s) or 
inches per microsecond (in./µs).

Wedge delay
This box defines the probe wedge delay in microseconds (µs).

7.6.1.2 Lateral Wave Processing Group Box

The Lateral wave processing group box (see Figure 7-16 on page 352) contains the 
following options:

Reference position
This box indicates the position, on the scan axis, of the selected reference A-scan.

Set Reference
This button sets the reference A-scan defined by the reference cursor position.

Complete visible image
When this option is selected, the processing is done on the complete image.
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Slice between ref. and meas. cursors
When this option is selected, the lateral wave synchronization, or lateral wave 
removal, is performed on the A-scans enclosed between the reference and the 
measurement cursors on the displayed Side (B) view.

LW Removal
This button performs the lateral wave (LW) removal process on the data group in 
the active view, and creates a new data group containing the processed data.

LW Synchronization
This button performs the lateral wave synchronization process on the data group 
in the active view, and creates a new data group containing the processed data.

7.6.1.3 Focalization Process Group Box

The Focalization process group box contains the following elements:

Aperture size
This box indicates the aperture of the SAFT algorithm, which is the total number 
of A-scans used to calculate the processed A-scan. The value is always odd, and is 
determined by the position of the cursors on the active Side (B) view.

SAFT
This button performs the SAFT (synthetic aperture focusing technique) algorithm.

7.6.2 Performing TOFD Calibration in Analysis Mode

This section provides a description on how to use the TOFD calibration of the TOFD 
Manager component in Analysis mode. For information on how to perform TOFD 
calibration in setup mode, see section 4.5 on page 251. 

To use the TOFD calibration function in Analysis mode

1. Open a data file (.rdt).
2. Visualize a Side (B) view.
3. Position the reference cursor at the start of the lateral wave signal.
4. Position the measurement cursor at the start of the back-wall signal.
5. On the View Properties > Units dialog bar, in the Type list box of the USound 

axis, select TOFD. 

6. On the Component toolbar, click the TOFD Manager button ( ).
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The TOFD Manager dialog box appears (see Figure 7-16 on page 352).
7. In the TOFD Manager dialog box, select the appropriate options, and then enter 

the appropriate values (see section 7.6.1 on page 352).

If you select the Compute velocity and wedge delay option button in the What do 
you want to compute? group box of the TOFD dialog box, the measurement cursor 
has to be positioned on a second reference signal (for example, lateral wave).

8. Click OK.
The ultrasonic axis is now calibrated in Analysis mode.

7.6.3 Performing Data Processing of TOFD Files

Although the functionality and mathematical correctness of all processing algorithms 
have been thoroughly checked and validated, no guarantees in terms of flaw 
detection and sizing performances can be given. The performance enhancement 
provided by a processing algorithm is definitely related to the specificity of each 
application, and is therefore the responsibility of the user.

7.6.3.1 Lateral Wave Synchronization

This section describes how to synchronize the lateral wave of a TOFD group.

Calibrate the TOFD group prior to applying the lateral wave synchronization 
algorithm.

To synchronize the lateral wave of a TOFD group

1. Open a data file (.rdt).
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2. Select the Side (B) view on which you want the lateral wave synchronization to be 
applied. 

3. In the Side (B) view, position the reference (red) cursor to select a reference 
A-scan in an unflawed zone (see Figure 7-18 on page 357).

4. In the Side (B) view, position the ultrasonic reference cursor and the ultrasonic 
measurement (blue) cursor on either side of the lateral wave signal (see 
Figure 7-18 on page 357). Appropriate setting of the cursors determines the result 
of the operation.

Figure 7-18  Selection of a reference A-scan

5. In the TOFD Manager dialog box, in the Lateral Wave Processing group box, 
click Set Reference.

Scan reference cursor

Representative A-scan

Ultrasonic reference and measurement cursors
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By default, the lateral wave synchronization is applied to the Complete visible 
image, but alternatively, the Slice between Ref. and Meas. cursors option can be 
selected if appropriate for the considered TOFD data.

6. Click LW Synchronization.
7. In the menu, select View > Contents and display the newly created LWS. The 

lateral wave is now synchronized (see Figure 7-19 on page 358).

Figure 7-19  TOFD data after lateral wave synchronization

7.6.3.2 Lateral Wave Removal

This section describes how to remove the lateral wave of a TOFD group.
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In order to obtain usable results from the lateral wave removal algorithm, it is 
mandatory to apply the algorithm to previously synchronized data.

To remove the lateral wave of a TOFD group

1. In the menu, select View > Content and display the lateral wave synchronized 
data.

2. In the Side (B) view, position the scan reference (red) cursor to select a reference 
A-scan in an unflawed zone (see Figure 7-20 on page 360). If the selection of the 
reference A-scan is correctly performed prior to the lateral wave synchronization, 
this operation does not need to be repeated.

3. In the Side (B) view, position the ultrasonic reference cursor (red) and the 
ultrasonic measurement cursor (blue) on either side of the lateral wave (see 
Figure 7-20 on page 360). If the lateral wave signal shows a lot of variation, it is 
important to position the cursors at least around the first oscillation of the lateral 
signal.
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Figure 7-20  Selection of reference A-scan

4. In the TOFD Manager dialog box, in the Lateral wave processing group box, 
click Set Reference.
By default, the lateral wave removal is applied to the Complete visible image, 
but alternatively the Slice between Ref. and Meas. cursors option can be selected 
if appropriate for the considered TOFD data.

5. Click LW Removal.
6. In the menu, select View > Contents and display the newly created LWR. The 

lateral wave is now removed (see Figure 7-21 on page 361). 

Scan reference cursor

Representative A-scan

Ultrasonic reference and measurement cursors
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Figure 7-21  TOFD data after lateral wave removal

7.6.3.3 SAFT Processing

The synthetic aperture focusing technique (SAFT) is a computer enhanced imaging 
technique for the detection and characterization of discontinuities. The technique 
takes advantage of the nonlinear phase shift of a reflection as a discontinuity is 
linearly scanned. Improved lateral resolution and a higher signal-to-noise ratio are 
achieved by using this phase shift, mathematically simulating the focusing of an 
ultrasonic lens that is focused on every point in an inspected part.

The SAFT algorithm can be applied either to raw TOFD data or to processed TOFD 
data. It is the responsibility of the data analyst to select the best combination for a 
given application.
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To apply the SAFT algorithm

1. Select the Side (B) view on which you want to apply the SAFT algorithm. 
2. In this Side (B) view, perform the following procedure in order to select the 

adequate aperture to be used for the SAFT algorithm:
a) Zoom in on a zone of interest containing a punctual TOFD indication (see 

Figure 7-22 on page 362), showing the typical parabolic shape.
b) Position the reference and measurement cursors on either side of the flight-

time minimum of the indication, so that the indication remains clearly visible 
at the selected scan axis positions; the SAFT algorithm tends to smoothen out 
and eventually erase indications if too large an aperture is used.

Figure 7-22  Definition of the aperture

3. The SAFT aperture as defined by the positions of the cursors is displayed in the 
TOFD Manager dialog box, in the Focalization process group box.

Scan reference and measurement cursors
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4. In the TOFD Manager dialog box, in the Focalization process group box, click 
SAFT.

5. In the menu, select View > Contents and display the newly created SAFT. The 
SAFT algorithm has been applied (see Figure 7-23 on page 363).

Figure 7-23  Overview of a SAFT ultrasonic image

As the SAFT algorithm involves averaging, which might tend to smoothen out 
high amplitudes, the use of a higher Software Gain value could be helpful to 
optimize the visualization of the processed data.

7.7 Working with the C-Scan Merge Process

In the Analysis mode, you can use the C-scan merge component to merge C-scan data 
acquired with various groups and/or beams. 
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The merge process compares the minimum amplitude, the maximum amplitude, or 
the minimum position obtained at each point of the inspected part acquired by the 
considered groups and/or beams. It then creates a new data group with the above 
mentioned criterion. TomoView also saves the created merged data in the Attributes 
file (.A01). 

With the C-scan merge component, you can: 

• Merge multiple C-scan images from different data files (see Figure 7-24 on 
page 364).

• Merge C-scan images from different gates (even if you modified the gate position 
and length). Can be used for multi-layers part with bonding (see Figure 7-25 on 
page 365). 

• Merge Amplitude C-scan and preserve maximum amplitude (for indication 
detection) or minimum amplitude (for back-wall attenuation monitoring).

• Merge minimum position C-scan.

Figure 7-24  Two files merge example
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Figure 7-25  Gate A and Gate B C-scan merging example

To merge C-scan data

1. Open the file containing the data that you want to merge.
2. On the menu, select Processing > C-Scan Merge.
3. In the C-Scan Merge dialog box (see Figure 7-26 on page 366):

a) In the Data Selection area, select the data that you want to preserve in the 
merge.

b) In the Additional Options area, select Merge associated data to 
simultaneously create the associated amplitude or position data.

c) In the Group Selection area, in the Available groups list, hold down the 
SHIFT key and click to select the groups that you want to merge, and then 
click Add.
The selected groups appear in the Selected groups list.

d) Click Next. 

Gate A C-scan Gate B C-scan

Merged Gate A and Gate B C-scans
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Figure 7-26  Example of the C-Scan Merge dialog box (first step)

4. In the second step of the C-Scan Merge dialog box (see Figure 7-27 on page 367), 
under Merge Dimensions:
a) Use the parameters in the Scan Axis and Index Axis areas to set the merge 

dimensions. 
b) In the Destination area, type the desired Group name for the merged data.
c) Click Finish.

The merged group is added to the contents (see Figure 7-27 on page 367).
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Figure 7-27  Example of the C-Scan Merge dialog box (second step)

5. To display the merged group (see Figure 7-28 on page 367):
a) Select the view where you want to display the merged C-scan. 
b) On the menu, click View > Contents.
c) In the Contents dialog box, in the list on the left, select the created C-scan 

merged group. 
d) In the list on the right, double-click the corresponding view to display.

The selected data appears in the view. 
e) Close the Contents dialog box.

Figure 7-28  Example of the C-scan merge group created
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7.8 Working with the SNR Analysis Component

TomoView includes a signal-to-noise ratio (SNR) function. You can use the SNR 
Analysis Utility to evaluate the noise level in a reference area on a C-scan view and 
then to calculate the indication surface area above the noise.

The SNR function is available in Analysis mode and with the Lite Aero edition. The 
SNR function is used for 0-degree inspections, often for aerospace industry parts. You 
can use the function on Top (C), amplitude, and position C-scan views. 

7.8.1 Calculating the Area of an Indication Using SNR Analysis Utility

To calculate the area of an indication using the SNR Analysis Utility

1. Start the SNR analysis utility using one of the following methods:

 On the Component toolbar, click the SNR Analysis Utility button ( ).
OR
On the menu, select Processing > SNR Analysis Window.

2. On the Component toolbar, select the Zone tool ( ), and then draw a rectangle 
over a zone representing a noise reference area (see the example shown in 
Figure 7-29 on page 368).

Figure 7-29  Selecting the noise reference area with the Zone tool

Drawing a rectangle 
around a reference 
noise area
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3. In the SNR Analysis Utility dialog box, click Retrieve.
TomoView calculates the mean and the standard deviation value for the reference 
area, and displays a distribution chart of the number of pixels as a function of the 
signal amplitude (see Figure 7-30 on page 369).

Figure 7-30  Example of reference area analysis results

4. Set the color palette to the gray scale to enhance highlighting of the defect area:
a) Right-click on the title bar of a Top (C), amplitude, or position C-scan view.
b) In the contextual menu select Set Color Palette > Gray levels.
c) In the contextual menu select Edit Color Palette and in the Limits group box, 

select the < = 0 % color to orange and the > = 0 % color to red. 
5. On the C-scan view, move the reference cursor and the measurement cursors 

around the indication as in the example shown in Figure 7-31 on page 370.

Calculated mean and 
standard deviation for the 
reference area selected 
with the Zone tool

Number of pixels versus
signal amplitude chart
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Figure 7-31  Positioning the cursors around the defect area

6. In the SNR Analysis Utility dialog box (see Figure 7-32 on page 371), the SNR 
value is directly related to the K parameter slider value: 
a) Move the K parameter slider to set the desired K or SNR value.

The K value is often a final user requirement. 
Decreasing the value of K, increases the number of low contrasted indications 
in red color.

b) Click  to update the C-scan view to the new K parameter value. 
The defect area value represents the set of pixels being above the reference 
noise area level.

Defect area
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Figure 7-32  Adjusting the K value

In the example shown in Figure 7-33 on page 372:
• K = 3.04 corresponds to an SNR value equal to 9.78 dB.
• The defect area is equal to 198 mm2 which represents 31.03 % of the total 

area defined between the reference and measurement cursors.

Click to update the view

Move the K parameter
slider to the desired value

The SNR value 
corresponding to the 
current K value
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Figure 7-33  Example of the SNR analysis with K equal to 3.04

In the example shown in Figure 7-34 on page 373:
• K = 8.76 corresponds to an SNR value equal to 18.85 dB.
• The defect area is equal to 97.5 mm2 which represents 15.28 % of the total 

area defined between the reference and measurement cursors.
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Figure 7-34  Example of the SNR analysis with K equal to 8.76

7.8.2 SNR Analysis Conventions

The parameters involved in the SNR calculations are presented in Table 15 on 
page 373 and are illustrated in Figure 7-35 on page 374. 

Table 15  SNR parameters 

Parameter  Symbol

Mean value inside reference area m

Standard deviation inside reference area σ

Lower Threshold S–

Upper Threshold S+

Lower Area (area of amplitude below S–) A–= A1

Upper Area (area of amplitude above S+) A+ = A2

Adjustable factor K
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Figure 7-35  The SNR distribution

The mathematical expression for the SNR is:

where: 

The defect area value represents the set of pixels with values above the SNR ratio. The 
mathematical expression for the defect area is:

When the K slider is at the maximum left position:

• K = 0
• The defect SNR is not applicable.
• The defect area is equal to the total area between the reference and 

measurement cursor positions.

When the K slider is at the maximum right position:

Signal amplitude
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A1 A2

SNR 20 K log=

S+ m K +=

S- m K –=

Defect Area A+ A-+=
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where:
• Amax = 100 % (for an amplitude C-scan)

• Amax = End of gate position (for a TOF C-scan)

• Defect Area = 0

7.9 Working with the Soft C-Scan Process

When working in analysis mode, you can use the Soft C-Scan module to create new 
C-scan data from previously recorded A-scan data. This process creates both position 
and amplitude C-scan data groups. 

The TomoView software saves the created C-scan data with the Attributes files (.A01). 
Thus, if deemed necessary, the previously created C-scan data is immediately 
available upon reopening the data file (.rdt).

To create a soft C-scan from previously recorded A-scan data

1. Open a data file.
2. Position the reference and measurement cursors on a view to define the gate 

location and level.
3. On the menu, select Processing > Create Soft C-Scan to open the Create Soft C-

Scan dialog box. 

K max
Amax m–


--------------------------- 
 log m


------- 
 log=

Defect SNR 20 max
Amax m–


--------------------------- 
 log m


------- 
 log=
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Figure 7-36  The Create Soft C-Scan dialog box

4. In the Available group box, select the groups for the soft C-Scan operation. 
5. In the Settings group box, select the type of position information to be taken into 

account when creating the soft C-scan data group (Peak, Crossing, or Both). 
6. In the Gate location command group, if necessary:
7. In the Settings group box, if necessary, define the Start, Length, and Level 

(threshold) gates to generate the soft C-Scan data group. 

Variable Back Wall Soft C-Scan

It is possible to edit the A-scan range on which the soft C-Scan processing is 
performed to using the Create soft C-scan dialog box. This is particularly useful when 
performing analysis on complex geometries like nozzles or other parts with changing 
thicknesses. 

To create a variable back wall soft C-scan 

1. Repeat steps 1 to 7 described in the To create a soft C-scan from previously 
recorded A-scan data section. 

2. In the Create Soft C-scan dialog box: 
a) In the Variable Back Wall group box, select the Activate group box. 
b) Select if you want to create the soft C-Scan from the Side (B) or End (D) scan. 
c) Create the points to be used for the software C-scan creation:
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 Position the Reference and Measurement cursors on the view and click Add.
OR
Click Add and define the Scan/Index and End values.

Figure 7-37  The Create Soft C-Scan with the Variable back wall activated

d) Click Create. 
The points which were created will then appear on the Side (B) or End (D) 
scan. 

Figure 7-38  The B-Scan with a displayed variable back wall
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3. Click Done. 
4. In the menu, select View > Contents and add the software C-scan data to the 

display. 

Figure 7-39  The Contents dialog box

You can turn On/Off the display of the points used for the software C-scan creation 
with the Soft C-scan check box in the Overlay tab of the View Properties dialog bar. 

7.10 Working with the Binarizer Component

The Binarizer can be used to perform simple pass or fail analysis on data files by 
converting acquisition data to a color driven Good/No good display. The Binarizer is 
particularly useful when inspecting composite parts and can be used on uncorrected 
VC amplitude and position C-scan data. 

To binarize a C-Scan using the Binarizer Component

1. In the Components toolbar, click  (Binarizer) to open the Binarizer. See 
Figure 7-40 on page 379.
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Figure 7-40  The Binarizer dialog box

2. In the Threshold Type section (see Figure 7-41 on page 379), select the criteria for 
the Binarization:
a) Select Threshold based on ref. area to use a reference area for the noise level 

and continue to step 3. 
b) Select User threshold to manually define the binarization thresholds and 

continue to step 5. 

Figure 7-41  The Threshold Type group box
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3. Place the red and blue cursors (by double-clicking with the left and right mouse 
buttons) in order to draw a rectangle over a zone which will be used as the 
reference area. See Figure 7-42 on page 380.

Figure 7-42  The Binarizer cursors

4. In the Binarizer dialog box, click on the Retrieve button to automatically calculate 
the mean and standard deviation of the noise for the reference area. The User 
Threshold will also be adjusted using either one of the two following options 
where the sign (+ or –) depends on whether the Plus or Minus polarity was 
selected. 
a) If Deviation from mean was selected then the following calculation will be 

performed:

User threshold = Mean value ± Deviation from mean 

b) If Standard Deviation was selected then the following calculation will be 
performed:

User threshold = Mean value ± Standard Deviation x SNR ratio
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Figure 7-43  The Reference Area dialog box

5. Select how the binarization will be performed using the following parameters:
a) If the Dual checkbox is unchecked and the Polarity is set to Plus, the Binarizer 

will sort the data based on the following threshold (see Figure 7-43 on 
page 381):

User threshold = Mean value + [Selected deviation]

b) If the Dual checkbox is unchecked and the Polarity (see Figure 7-44 on 
page 381) is set to Minus the Binarizer will sort the data based on the 
following threshold: 

User threshold = Mean value -[Selected deviation]

Figure 7-44  The Binarizer polarity
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c) If the Dual checkbox is checked, two different threshold values can be 
defined and the Binarizer will sort the data based on the values which are 
between or outside the two Thresholds. See Figure 7-45 on page 382. 

Figure 7-45  The Binarizer thresholds

6. In the Selection group box, select Full to process the full C-Scan or Local to only 
binarized the area defined by the Reference and Measurement cursors. Different 
areas can be processed and added to the final C-Scan individually. 

7. Click Process. 
8. In the menu, select View > Contents and add the Binarized data to the display. 

See Figure 7-46 on page 382 and Figure 7-47 on page 383.

Figure 7-46  The Binarizer Contents dialog box
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Figure 7-47  The Binarized data display

9. To remove parts of the binarized C-Scan select the area using the Reference and 
Measurement cursors and click Remove. 

7.11 Working with Color Palettes

Depending on the application, it can be very helpful to modify the color palette
associated with the specific view types in order to make certain types of indications
easier to see. This section shows how the TomoView color palette can be edited. 

7.11.1 Modifying Color Palettes

To modify a color palette

1. To open the Palette Editor dialog box (see Figure 7-48 on page 384):
• In the View Properties > Palette dialog bar, click.

OR

Right-click on the active view color palette and select Edit Color Palette. 
2. If the Pane Properties dialog box is not presently open, click Properties on the 

Pane menu. 
3. Click the Palette tab. 
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4. Click Edit Palette. 

Figure 7-48  The Palette Editor dialog box

5. In the Palette Editor: 
a) Click Load Palette if you want to open an existing palette.
b) Click Equidistant if you want to distribute the thresholds evenly between the 

colors. 
c) Enter the desired number of colors in the palette in the Number of colors box. 

The number of active boxes will increase or decrease accordingly.
d) In the Interpolation group box, select the desired interpolation type from the 

colors. 
e) Select the Use special colors check box and select colors to be associated with 

the No data, No synchro, and No detection boxes if you want to have these 
colors highlighted on the display. 
• No data corresponds to locations where no data was acquired because of 

missed encoder steps, or because the location was outside the inspected 
volume. 

• No synchro. corresponds to locations where no signal crossed gate I 
(synchronization gate). This color is effective only for synchronization 
setup on echo.
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• Click the No detection box to define the color assigned to locations where 
no signal crossed the considered gate.

f) To change a color, click on it and select an alternative color using the Color 
dialog box (see Figure 7-49 on page 385).

g) Click Save Palette if you want to save the current palette to a .col file. 

Figure 7-49  The Color dialog box 

In setup mode, Special colors functions are not applied to the Scrolling B-scan view, 
Scrolling Strip View (Amp), and Scrolling Strip View (Pos).

6. Click Apply, then Close. 

7.11.2 Optimizing a Color Palette for Corrosion Visualization

Corrosion inspection is a good example of an application where an appropriate color
palette configuration can be very useful. This section describes the steps to optimize a
color palette for corrosion. 
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To optimize a color palette for corrosion visualization

1. Select the C-scan view for which you want to visualize the corrosion. 
2. In the Palette Editor:

a) Set Number of colors to 3. 
b) In the Interpolation group box, select Threshold. 
c) Deselect the Use special colors check box. 
d) In the Limits group box, set the < = 0 % color to grey and the > = 0 % color to 

red. 
e) Set color 1 to green, color 2 to yellow, color 3 to orange, and color 4 to red. 
f) Click Save Palette and save the current color palette to a .col file. 

Figure 7-50  Color palette optimized for corrosion visualization

3. In the View properties > Palette dialog bar, select the Reverse color order check 
box. 

4. Click  to open the Gain Information dialog bar. 
a) Adjust the top and bottom color palette cursors to match, respectively, the 

maximum and minimum corrosion thicknesses of your specimen (see the 
example in Figure 7-52 on page 387)
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Figure 7-51  Example of palette limits adjusted to specimen corrosion limits

The C-scan pane view should now highlight the corrosion of the specimen, such 
as in the example in Figure 7-52 on page 387. 

Figure 7-52  Example of corrosion visualization on a demonstration specimen

Adjust the top color palette cursor to match the
maximum corrosion thickness of your specimen

Adjust the bottom color palette cursor to match
the minimum corrosion thickness of your

specimen
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7.12 Working with the Image Analysis Tools

This section provides information on the cursor and zone tools as well as on the 
display of rebound and overlays.

TomoView offers powerful tools to facilitate advanced data analysis. Table 16 on 
page 388 provides a list of these image analysis tools along with their associated 
buttons (toggled to change the visibility of the tools) and their descriptions.

Table 16  Summary of image analysis tools 

Icon Name Function

Zoom tool To select and zoom in a specific region on a view.

Segment tool To make 3-D measurements on a C-scan view by 
clicking and dragging. Also works on Top/Side/End 
views.

Zone tool To select a region on a top, side, end, or C-scan view by 
clicking and dragging.
Tip: When the Zone tool is not selected, press and hold 
the CTRL key, and then click and drag on a view to 
perform the same task.

Move tool To move the graphical data relative to the view frame.

Split view 
horizontally in two 

To divide the active view into two views with the same 
horizontal dimension.

Split view vertically 
in two

To divide the active view into two views with the same 
vertical dimension.

Split view in four To divide the active view into four views with the same 
horizontal and vertical dimensions.

Delete view To delete the active view.

Empty view To remove the contents of the active view.
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Maximize view To maximize the size of the active view by hiding the 
other views. Clicking this button when the view is 
already maximized restores the view to its original size 
and displays the other views.

Edit view properties To open the View Properties dialog box, used to 
configure the parameters of the active view.

Edit view contents To open the Contents dialog box, used to select the 
data type and the view type to be displayed in the 
active view.

Toggle echo 
dynamics curves 

To toggle the display of the echo dynamics curve on 
the active view. This button is available only for top, 
side, end, and C-scan views.

Toggle view 
information group 1 

To toggle the display of information group 1 in the 
active view (reference cursor parameters by default).

Toggle view 
information group 2 

To toggle the display of information group 2 in the 
active view (measurement cursor parameters by 
default).

Toggle view 
information group 3 

To toggle the display of information group 3 in the 
active view (by default, parameters related to the 
combination of the reference and measurement 
cursors).

Toggle view 
information group 4 

To toggle the display of information group 4 in the 
active view (3-D cursor, Zone tool, and acquisition 
parameters by default).

Hide view 
information groups 

To hide all information groups displayed in the active 
view.

Edit view 
information groups 
contents

To open the Information Groups dialog box, used to 
edit information group contents, that is, the parameter 
sets displayed in the information groups. You can also 
double-click a reading to open this dialog box.

Table 16  Summary of image analysis tools (continued)

Icon Name Function
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As shown in the example in Figure 7-53 on page 391, the reference and measurement 
cursors appear on the various views as horizontal and vertical colored lines on each of 
the three axes (index, scan, and ultrasonic) to mark a specific data point. The Zone 
tool appears as a pink rectangle and the 3-D Cursor appears as a pink line. 

Envelope Toggles the activation of the envelope mode for the 
online and off-line A-scan view.

Rectify data To apply a software rectification to unrectified signal 
data. 

Fit image to view To display the complete data contents of the active 
view.

Fit inspection 
domain to view 

To display the complete inspection domain in the 
active view.

Toggle reference 
cursor

To toggle the display of the active view reference 
cursors.

Toggle measurement 
cursor

To toggle the display of the active view measurement 
cursors.

Add a note To add a callout on top of a view to point out and 
comment on a given element. You can freely move and 
resize the callout. The callout notes are included in 
screen captures but cannot be saved.

US Customary units In TomoView Lite and TomoViewer editions only, 
changes length measurement units to US Customary 
when pressed. 

Table 16  Summary of image analysis tools (continued)

Icon Name Function
390    Chapter 7

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Figure 7-53  Example of cursor and zone tools

7.12.1 Measurement Cursors and Measures

With TomoView, you can use the reference and measurement cursors on a view to 
measure the distance along the various axes. Each cursor has a label indicating the 
current coordinate on the view. You can display cursor parameters values at the top of 
the view (see section 7.12.1.6 on page 393). 

7.12.1.1 Relationship Between Cursors

Two types of relationship can exist between cursors: a fixed gap or a link.

A fixed gap is a relationship created between the reference and the measurement 
cursors for a given view. You can use it to simultaneously move both cursors with a 
fixed gap between them.

A link is a relationship created between cursors of same type in different views. You 
can use it to simultaneously move either the reference or the measurement cursors to 
the same coordinate in two different views.

Reference cursor

Data cursor

Measurement
cursor

Contour rectangle
3-D Cursor
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7.12.1.2 Moving a Cursor with the Mouse

To move a cursor with the mouse

1. Place the mouse pointer over the reference or measurement cursor you want to 
move.

The pointer shape will change to  or .
2. Click, drag, and release the cursor onto the new position.

OR

 Double-click using the left or right mouse button on the desired position to move 
the reference or measurement cursor directly to the new position.

7.12.1.3 Moving a Cursor with the Keyboard

To move a cursor with the keyboard

Select the view on which you want to move the reference or measurement cursors. 

 Use the arrow keys to move the reference cursor.
OR
Use the arrow keys while holding down the SHIFT key to move the measurement 
cursor.

The cursors only move on the active view, unless they are linked to other views.

7.12.1.4 Moving Cursors with a Fixed Gap

To move the reference and measurement cursors with a fixed gap

1. Place the reference cursor on a given position.
2. Place the measurement cursor at a distance from the reference cursor 

corresponding to the gap you want to create.
3. Place the mouse pointer over one of the cursors you want to move with a fixed 

gap (the pointer shape will change to  or ). 
4. Press the mouse button while holding down the CTRL key and drag the cursors 

to the new position.
392    Chapter 7

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Both reference and measurement cursors will follow each other with the specified 
gap. The cursors will only move on the active view, unless they are linked to other 
views.

7.12.1.5 Creating a Link Between Cursors

To create a link between cursors

1. Click on the view where you want to create a cursor link.
2. Open the View Properties > View Linking dialog bar. 
3. In the Linked items group box, select the Scan/Index cursors check box.

The scan and index cursors will automatically move to the same position as will do 
any linked cursor in another view.

7.12.1.6 Displaying Cursor Parameters

As the reference and measurement cursors are often used to take measurements 
inside the different views, it is very convenient to display the various readings related 
to these cursors.

To display the cursor parameters

1. Click on the view where you want to display the cursor parameters.

2. On the View toolbar, click .
3. In the Information Groups dialog box:

a) Select the Group n > Favorite Readings category.
b) Select the Reference Cursor (r), Measurement Cursor (m), and Cursors 

readings that you want to display. 
c) Click Ok. 
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Figure 7-54  The cursor parameters

4. In the View toolbar, click  to activate the readings that you have 
defined for the current view. 

7.12.2 Zone Tool

You can use the Zone tool to select a part of an image. A zone is a rectangular shape 
that can be used on volume-corrected volumetric views (only one zone can be active 
at a time). 

Because contours are 3-D measurement tools, they are always linked from one 
volumetric view to another.
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7.12.2.1 Creating a Zone

To create a zone

1. Click on the view where you want to create a zone.

2. On the View toolbar, click .
3. Drag and release the mouse button on a view to create the zone, which appears as 

a magenta-colored rectangle. 

7.12.2.2 Resizing a Zone

To resize a zone

1. Click on the view where you want to resize a zone.
2. Place the mouse pointer over a zone corner to be resized until the pointer changes 

to an oblique arrow (  or ).
3. Drag and release the zone corner using the mouse button until it has reached its 

arrival point.
4. If necessary, move another zone corner by repeating these steps.

7.12.2.3 Moving a Zone

To move a complete zone

1. Click on the view where you want to move the zone.
2. Place the mouse pointer over one of the zone lines until the pointer changes to a 

cross ( ).
3. Drag and release the mouse button to move the zone to its new position.

7.12.2.4 Hiding a Zone

To hide a zone

 In the menu, select Tools > Hide Zone.
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7.12.2.5 Displaying Zone Parameters

No information group displays the coordinates related to the zone. To display zone 
parameters, you must first edit an information group.

To display the zone parameters

1. Click on the view where you want to display the zone parameters.

2. On the View toolbar, click .
3. In the Information Groups dialog box: 

a) Select the Group n > Favorite Readings category.
b) Select the Zone readings that you want to display (see Figure 7-55 on 

page 396).
c) Click Ok. 

Figure 7-55  The Statistics zone parameters

4. On the View toolbar, click  to activate the readings that you have 
defined in the current view. 
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7.12.3 3-D Cursor

You can use the 3-D Cursor tool to select a 3-D segment and make measurements in 
the inspected part. A 3-D Cursor is a line-shaped tool that can be used on volumetric 
views (only one 3-D cursor can be active at a time).

Because 3-D Cursors are 3-D measurement tools, they are always linked from one 
volumetric view to another.

7.12.3.1 Creating a 3-D Cursor

To create a 3-D Cursor

1. Click on the view where you want to create the 3-D Cursor.

2. On the View toolbar, click .
3. Drag and release the mouse button on a view to create the 3_D cursor, which will 

appear as a magenta-colored line.

7.12.3.2 Moving a 3-D Cursor

To move a 3-D Cursor

1. Click on the view where you want to move the 3-D Cursor.
2. Place the mouse pointer over a control point of the cursor to be moved until the 

pointer changes to a reticle shape ( ).
3. Drag and release the 3-D Cursor point using the mouse button until it has reached 

its arrival point.
4. If necessary, move the other cursor control point by repeating these steps.

7.12.3.3 Hiding a 3-D Cursor

To hide a 3-D Cursor

 In the menu, select Tools > Hide 3-D Cursor.
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7.12.3.4 Displaying 3-D Cursor Parameters

To display 3-D Cursor parameters

1. Click on the view where you want to display the zone parameters.

2. On the View toolbar, click .
3. In the Information Groups dialog box:

a) Select the Group n > Favorite Readings category.
b) Select the Segment (seg.) readings that you want to display (see Figure 7-56 

on page 398). 
c) Click Ok. 

Figure 7-56  The 3-D Cursor (segment) parameters

7.13 Working with the A-scan Resynchronization Process

When performing acquisitions using two-dimensional encoded data, the data can be 
easily offset between the different scan lines for various reasons. The A-scan 
Resynchronization helps to correct this error, making the data more coherent for 
further analysis. 

To resynchronize the A-scan

1. On the A-scan view, position the reference and measurement cursors around the 
interface entry echo.
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2. On the menu, select Processing > Set A-scan Resynchronization gate to define a 
new purple gate between the reference and measurement cursors which will be 
used as the reference for resynchronization (see Figure 7-57 on page 399).

Figure 7-57  Example before resynchronization

3. On the menu, select Processing > Resynchronize A-scans to resynchronize the 
A-scans. 
Figure 7-58 on page 399 shows the resulting A-scan and C-scan.

Figure 7-58  Example after resynchronization
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7.14 Working with the Matrix Filters Process

The Matrix Filters can be used to reduce the noise on C-Scan data by processing every 
data point using the surrounding points. The Matrix Filters are particularly useful 
when analyzing noisy composite parts, therefore allowing clearer data representation 
for analysis of data files with high noise levels. 

To filter a C-Scan using the Matrix Filters Component

1. In the menu, select Processing > Matrix Filters Parameters. 
a) Set Algorithm to Average, Minimum, or Maximum. See Figure 7-59 on 

page 400.
b) Define the patch size which will be used as the reference pixel surrounding.
c) Click Create. 

Figure 7-59  The Matrix Filters Parameters dialog box

2. In the menu, select View > Contents and add the matrix filtered data to the 
display. See Figure 7-60 on page 401.
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Figure 7-60  The Contents dialog box

7.15 Working with the Cylindrical Correction

This section describes the cylindrical correction tool provided in TomoView. In this
section, we refer often to Volume Corrected views (called the VC-X View). To set a
volumetric view as a Volume Corrected view, right click in the View bar, and select
Set Volume Corrected Display Mode (see Figure 7-61 on page 401). 

Figure 7-61  The drop down menu for Set Volume Corrected Display Mode

7.15.1 Description of the Cylindrical Correction Tool

TomoView software can display various types of information concerning the active 
data file and the data views. View information consists of the various view-related 
parameters, which can be displayed in the upper part of the pane. The information to 
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be displayed is defined in the Information Groups dialog box. (For a complete 
description of the various information groups, consult section 7.3 on page 342.) In 
TomoView, all information concerning the position of indications in a user-defined 
cylindrical geometry has been organized in the Cylindrical correction group (see 
Figure 7-62 on page 402).

Figure 7-62  The Cylindrical correction information group

This information group contains the parameters shown in Figure 7-63 on page 403. 
These parameters provide the position, in the user-defined cylindrical geometry, of a 
point indicated by the reference cursor and/or the measurement cursor, or by the zone 
tool.
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Figure 7-63  The Cylindrical correction parameters

Cylindrical correction parameters are available for an inspection conducted from the 
outside diameter (OD) or from the inside diameter (ID). The feature is applicable for 
data files acquired with scan or index axes that are calibrated in distance units 
(millimeters or inches) or rotation units (degrees). In addition, you can convert the 
units in analysis mode.

In addition to the position of the points determined by the two cursors, the distance 
between the cursors in the user-defined cylindrical geometry can be calculated along 
the considered axes.

The position of the maximum amplitude within a user-defined zone can be calculated 
in the user-defined cylindrical geometry.
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The feature is not relevant for merged views resulting from various focal laws, as the 
data might be deduced from different refracted angles.

7.15.2 Case of a Skew Angle of 0° or 180°

The cylindrical correction for probe skew angles of 0° or 180° is applicable for all
inspection configurations where both the scanning axis and the probe beam are
oriented circumferentially, for instance:

• Raster scanning sequence for the inspection of a longitudinal pipe weld used to 
find defects parallel to the weld axis

• Raster scanning sequence for the inspection of a circumferential pipe weld used to 
find defects perpendicular to the weld axis

To obtain the cylindrical correction for the points determined by the reference and 
measurement cursors

1. Make sure that at least the reference (red) cursor is present in the Volume 
Corrected Side (B) view before activating the cylindrical correction.

2. In the VC-Side (B) view, select the applicable information fields (either OD- or ID-
related) as follows:
a) Click to activate the VC-Side (B) view.

b) On the View toolbar, click  to display information group 3 in the upper 
part of the pane.

c) On the View toolbar, click  to open the Information Groups dialog box.
d) Double-click Group 3, and then Cylindrical correction.
e) From the Cylindrical correction group, double-click to select the applicable 

information check boxes (see example in Figure 7-64 on page 405 showing a 
selection of OD-related parameters).

f) Click OK.
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Figure 7-64  Selection of OD-related parameters

3. On the Parameters tab of the Pane Properties dialog box, click Specimen 
Definition.

4. In the Part Definition dialog box that appears (see Figure 7-65 on page 406), 
define the specimen as follows:
a) Click Cylindrical.
b) In the Thickness box, type the thickness of the considered cylindrical 

geometry.
c) In the Outside diameter box, type the appropriate value for the outside 

diameter.
d) Under Cylindrical geometry, click the OD or ID option button to specify 

whether the inspection is performed from the outside diameter or from the 
inside diameter.

e) Click OK.
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Figure 7-65  The Part Definition dialog box

When the specimen has been defined for one channel or one focal law, it is also 
applied for all channels or focal laws contained in the considered data file, and it can 
be saved in the .A01 file upon closing the data file.

• The OD Cyl. Ref. Scan and OD Cyl. Ref. Depth information fields provide the 
position (scan and depth axes), in the user-defined cylindrical geometry, of the 
point determined by the intersection of the horizontal reference (red) cursor and 
the angled reference (pink) cursor, in the VC-Side (B) view, or by the horizontal 
and the vertical reference (red) cursors in the Side (B) view.

• The information fields OD Cyl. Meas. Scan and OD Cyl. Meas. Depth provide 
the position (scan and depth axes) in the user-defined cylindrical geometry, of the 
point determined by the intersection of the horizontal measurement (blue) cursor 
and the angled measurement (cyan) cursor, in the VC-Side (B) view, or by the 
horizontal and the vertical measurement (blue) cursors in the Side (B) view.

• The information fields OD Delta Cyl. Scan and OD Delta Cyl. Depth provide 
the distance (scan and depth axes), in the user-defined cylindrical geometry, 
between the points determined by the reference and measurement cursors.
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• The provided position information in the cylindrical geometry takes into account 
multiple rebounds of the ultrasonic beam from both OD and ID, considering the 
wall thickness entered by the operator in the Part Definition dialog box (see 
Figure 7-66 on page 407).

Figure 7-66  Cylindrical correction: example 1

• The provided position information in the cylindrical geometry is displayed in 
millimeters (or inches) if the scan axis is in distance units, and in degrees (or 
radians) if the scan axis is in rotation units.

To obtain the cylindrical correction for the position of the maximum amplitude within a user-
defined zone

1. Make sure that at least the reference (red) cursor is present in the VC-Side (B) 
view before activating the cylindrical correction.

2. In the VC-Side (B) view, select the applicable information fields (either OD- or ID-
related) as follows:
a) Click in the VC-Side (B) view to make the active view.
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b) On the View toolbar, click  to display information group 3 in the upper 
part of the pane.

c) On the View toolbar, click  to open the Information Groups dialog box.
d) Double-click Group 3 and then Cylindrical correction. See Figure 7-67 on 

page 408. 
e) From the Cylindrical correction group, double-click to select the applicable 

information check boxes (see example in Figure 7-64 on page 405 showing a 
selection of OD-related parameters).

f) Click OK to close the dialog box.

Figure 7-67  Selection of OD-related parameters

3. Position the gate selectors for the ultrasonic axis so that the flaw indication to be 
sized is located in the gate. (It might also be useful to display the gate cursors in 
the volume-corrected views.)

4. In the VC-Side (B) view, create a zone containing the considered flaw indication.
5. In the VC-Top (C) view, create a zone containing the considered flaw indication.

You have now, in fact, created a volumetric zone defined by the zone created in 
the top view and the gate selectors on the ultrasonic axis (see Figure 7-68 on 
page 409). Additionally, the selected parameters in the information group give the 
position of the maximum amplitude in the zone along the scan and depth axes. 
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The position of the maximum along the index axis (flat geometry) can be obtained 
by using the standard parameter C. Max. Index Pos. from the Statistics 
information group.

Figure 7-68  Cylindrical correction: example 2

7.15.3 Case of a Skew Angle of 90° or 270°

The cylindrical correction for probe skew angles of 90° or 270° is applicable for all 
inspection configurations where both the index axis and the probe beam are oriented 
circumferentially, for instance:

• Raster scanning sequence or line scanning sequence for the inspection of a 
longitudinal pipe weld used to find defects parallel to the weld axis

• Raster scanning sequence or line scanning sequence for the inspection of a 
circumferential pipe weld used to find defects perpendicular to the weld axis
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To obtain the cylindrical correction for the points determined by the reference and 
measurement cursors

1. Make sure that at least the reference (red) cursor is present in the VC-End (D) 
view before activating the cylindrical correction.

2. In the VC-End (D) view, select the applicable information fields (either OD- or ID-
related) as follows:
a) Click in the VC-End (D) view to make it the active view.

b) On the View toolbar, click  to display information group 3 in the upper 
part of the pane.

c) On the View toolbar, click  to open the Information Groups dialog box.
d) Double-click Group 3 and then Cylindrical correction.
e) From the Cylindrical correction group, double-click to select the applicable 

information check boxes (see example in Figure 7-69 on page 410 showing a 
selection of ID-related parameters).

f) Click OK.

Figure 7-69  Selection of ID-related parameters

3. On the Parameters tab of the Pane Properties dialog box, click Specimen 
Definition.
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4. In the Part Definition dialog box that appears (see Figure 7-70 on page 411), 
define the specimen as follows:
a) Click Cylindrical.
b) In the Thickness box, type the thickness of the considered cylindrical 

geometry.
c) In the Outside diameter box, type the appropriate value for the outside 

diameter.
d) Under Cylindrical geometry, click the OD or ID option button to specify 

whether the inspection is performed from the outside diameter or from the 
inside diameter.

e) Click OK.

Figure 7-70  The Part Definition dialog box

When the specimen has been defined for one channel or one focal law, it is also 
applied for all channels or focal laws contained in the considered data file, and it can 
be saved in the .A01 file upon closing the data file.
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• The ID Cyl. Ref. Index and ID Cyl. Ref. Depth information fields provide the 
position (index and depth axes), in the user-defined cylindrical geometry, of the 
point determined by the intersection of the horizontal reference (red) cursor and 
the angled reference (pink) cursor, in the VC-End (D) view, or by the horizontal 
and the vertical reference (red) cursors in the End (D) view.

• The information fields ID Cyl. Meas. Index and ID Cyl. Meas. Depth provide 
the position (index and depth axes) in the user-defined cylindrical geometry, of 
the point determined by the intersection of the horizontal measurement (blue) 
cursor and the angled measurement (cyan) cursor, in the VC-End (D) view, or by 
the horizontal and the vertical measurement (blue) cursors in the End (D) view.

• The information fields OD Delta Cyl. Scan and OD Delta Cyl. Depth provide 
the distance (index and depth axes), in the user-defined cylindrical geometry, 
between the points determined by the reference and measurement cursors.

• The provided position information in the cylindrical geometry takes into account 
multiple rebounds of the ultrasonic beam from both OD and ID, considering the 
wall thickness entered by the operator in the Part Definition dialog box (see 
Figure 7-71 on page 412).

Figure 7-71  Cylindrical correction: example 3
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• The provided position information in the cylindrical geometry is displayed in 
millimeters (or inches) if the index axis is in distance units, and in degrees (or 
radians) if the index axis is in rotation units.

To obtain the cylindrical correction for the position of the maximum amplitude within a user-
defined zone

1. Make sure that at least the reference (red) cursor is present in the VC-End (D) 
view before activating the cylindrical correction.

2. In the VC-End (D) view, select the applicable information fields (either OD- or ID-
related) as follows:
a) Click to activate the VC-End (D) view.

b) On the View toolbar, click  to display information group 3 in the upper 
part of the pane.

c) On the View toolbar, click  to open the Information Groups dialog box.
d) Double-click Group 3 and then Cylindrical correction.
e) From the Cylindrical correction group, double-click to select the applicable 

information check boxes (see example in Figure 7-72 on page 413 showing a 
selection of ID-related parameters).

f) Click OK.

Figure 7-72  Selection of ID-related parameters
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3. Position the gate selectors for the ultrasonic axis so that the flaw indication to be 
sized is located in the gate. (It might also be useful to display the gate cursors in 
the volume-corrected views.)

4. In the VC-End (D) view, create a contour containing the considered flaw 
indication.

5. In the VC-Top (C) view, create a contour containing the considered flaw 
indication.
You have now, in fact, created a volumetric contour defined by the contour 
created in the top view and the gate selectors in the ultrasonic axis (see 
Figure 7-73 on page 414); the selected parameters in the information group give 
the position of the maximum amplitude in the contour along the index and depth 
axes. The position of the maximum along the scan axis (flat geometry) can be 
obtained by using the standard parameter C. Max. Scan Pos. from the Statistics 
information group.

Figure 7-73  Cylindrical correction: example 4
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7.15.4 Using Cylindrical Corrections

For the inspection of cylindrical parts, the Advanced Calculator takes into account the 
cylindrical corrections of the beams so that the readings of depth and index values are 
valid. The reading of depth (ODCylRefDepth) is taken perpendicularly to the tangent 
external surface of the part, and the reading of the index (ODCyRefIndex) is taken 
along the circumference of the external surface of the part (see Figure 7-74 on 
page 415).

Figure 7-74  Reading of depth and index for a cylindrical part

7.15.5 Calibrating the Wedge

Before performing the inspection of a cylindrical part, you need to configure the 
Advanced Calculator with the appropriate part and wedge dimensions. To achieve 
this, you need to calibrate both the height of the first element of the probe and the 
wedge angle. This calibration compensates for inaccurate nominal wedge dimensions 
or wedge wear. Calibrate the wedge using a linear scan at 0 degree, oriented towards 
the center of the cylinder. The interface echo of a correctly calibrated wedge appears at 
0 mm depth anywhere along the probe. 

ODCylRefDepth

ODCylRefIndex
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To calibrate the wedge

1. In the 1-D Linear array tab of the Advanced Calculator (see Figure 7-75 on 
page 417), perform the following configuration steps:
a) In the Scan group box, select Linear in the Type drop-down combo box. 
b) In the Beam angles selection group box, select Refracted angle (deg), and set 

the Start value to 0.0. 
c) In the Wedge group box, set the nominal values specified for your wedge.
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Figure 7-75  Parameters for wedge calibration

d) In the Probe group box, set the Probe index offset.
Measure the Probe index offset along the circumference of the outside 
diameter of the part, as shown in Figure 7-76 on page 418, not along a straight 
line. The Probe index offset value is negative when the Probe skew angle is 
90°, and is positive when the Probe skew angle is 270°. 

1.a)

1.b)

1.c)

1.d)
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Figure 7-76  Measurement of the Probe index offset

2. Click Save As to save the focal laws. 
3. In TomoView, load the focal law that you just saved, and examine the interface 

echo.
A interface echo of correctly calibrated wedge will appear exactly at 0 mm depth 
anywhere along the probe, as shown in the example of Figure 7-77 on page 419. If 
this is the case for your application, you do not need to continue this procedure. 
If the wedge needs calibration, the interface echo will not appear exactly at 0 mm 
depth anywhere along the probe (as shown in the example of Figure 7-78 on 
page 419), and the echo line around 0 mm in the sectorial scan is not horizontal.

Probe index offset
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Figure 7-77  Example of the interface echo for a correctly calibrated wedge

Figure 7-78  Example of the interface echo for a wedge needing calibration
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4. If your wedge needs calibration, select the 1-D Linear array tab in the Advanced 
Calculator.

5. In the Wedge group box, adjust the values for both the Wedge angle and the 
Height at the middle of the first element to better represent the real dimensions 
of the wedge. 

6. Repeat steps 2 to 5 until the interface echo line is exactly at 0 mm depth anywhere 
along the probe as shown in the example of Figure 7-77 on page 419.

7.15.6 Analyzing Cylindrical Readings in TomoView

In TomoView, you can analyze the cylindrical readings for sectorial and linear scans. 

In TomoView, the cylindrical readings are only available in the Analysis mode, not in 
the Setup and Inspection modes.

To analyze cylindrical readings for sectorial scans

1. Open the data file to be analyzed. 
2. Refer to Figure 7-79 on page 421 and perform the following actions:

a) In the VC sectorial scan view, select the desired focal law to display and place 
the reference cursor. 

b) In the Linked VC-END (D) view, read the cylindrical correction values. 
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Figure 7-79  Analyzing cylindrical readings for a sectorial scan

Do not use merged or polar views to measure cylindrical values.

To analyze cylindrical readings for linear scans

1. Open the data file to be analyzed.
2. Refer to Figure 7-80 on page 422 and perform the following actions:

a) Set the reference cursor at the probe index position to correctly display the 
A-scan. 

b) In the VC-END (D) view, read the cylindrical correction values. 

)
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Figure 7-80  Analyzing cylindrical readings for a linear scan

Do not use merged or polar views to measure cylindrical value.

7.16 Working with the Export Data Utility

This section describes how to use the Export Datagroup features to export A-scan and 
C-scan data to a simple text file format, which can be read with Microsoft Excel.

To export a data group

1. Open a data file.
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2. Position the reference and measurement cursors on views to determine the 
volume of the recorded data to be exported.

3. In the menu, select File > Export Datagroup to file. See Figure 7-81 on page 423

Figure 7-81  The Export Datagroup dialog box

4. In the Export Datagroup dialog box, select from A-scan or C-Scan data, 
depending on what you want to export (this will modify the Available data 
group list according to contents of the data file). 

5. Select the data that you want to export in the Available data group list.
6. Adjust the Start and End values of the Scan, Index, and USound parameters to 

determine the data volume to export. 
7. Set the Data group header to determine the header format that will be added to 

the exported data.
8. Select if you want to have the Amplitude data exported as Percent or as Raw 

data. 
9. If exporting C-Scan data, select the format of the Position data. 
10. Click Export. 
11. Select a name and location for the exported file and click Save. 

The data will exported in the following formats:
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For A-scan
— 1st line

A-scan amplitude data at Scan Start, Index Start position.

— 2nd line
A-scan amplitude data at Scan Start + 1, Index Start position.

— 3rd line
A-scan amplitude data a Scan Start + 2, Index Start position. 

IndexQTY + 1st line

A-scan amplitude data at Scan Start, Index Start + 1 position.

IndexQTY + 2nd line

A-scan amplitude data at Scan Start + 1, Index Start + 1 position.

For C-scan
— 1st line

C-scan data of line along the scan axis, at index position Index Start.

— 2nd line
C-scan data of line along the scan axis, at index position Index Start + 1.

— 3rd line
C-scan data of line along the scan axis, at index position Index Start + 2.

The values are delimited by the TAB key (ASCII character code: 9).

7.17 Using the Hysteresis Correction Module

This section provides a detailed description on how to use the Hysteresis Correction 
module. Using this module, you can improve visualization of the previously recorded 
ultrasonic data from bidirectional scanning sequences by drastically reducing the 
effect from the mechanical backlash of the manipulator on the scan axis. The 
Hysteresis Correction module leaves the raw inspection data unaffected, whereas the 
processed data can be saved in separate data groups in the Attributes file .A01.
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The Hysteresis Correction module is not available in the Lite edition.

To perform a hysteresis correction

1. Open a data file (.rdt).
2. Display a C-scan, a Top (C), or a Volume Corrected Top (C) view.
3. Position the reference and measurement cursors on the mechanical grid to 

perform the wanted correction for the scan and index axis (see the example in 
Figure 7-82 on page 425).

Figure 7-82  Position of the cursors

4. In the menu, select Processing > Hysteresis correction to display the Hysteresis 
Correction dialog box (see Figure 7-83 on page 426).

 

Scan Axis

Index Axis
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Figure 7-83  The Hysteresis Correction dialog box

5. Select the channel to be corrected. 
6. In the Correction of box, to indicate the position shift between two successive 

scan lines, specify the number of samples to be used for the hysteresis correction.
7. Click OK.

The correction has now been applied to the selected data group (see Figure 7-84 
on page 427).
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Figure 7-84  Example of a hysteresis correction

7.18 Working with the Log-to-Linear Data Conversion Process

This section describes the TomoView Convert Log to Linear function. In data analysis 
mode, you can use this function to convert recorded logarithmic data to linear data. 
This process creates a new data group containing the converted data.

The TomoView software saves the new linear data with the Attributes files (.A01). 
Thus, if deemed necessary, the previously created linear data is immediately available 
upon reopening the data file (.rdt).

To convert logarithmic data to linear data

1. Open a data file containing logarithmic data.
2. In the menu, select Processing > Convert Log to Linear (see Figure 7-85 on 

page 428).
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Figure 7-85  The Convert Log to Linear dialog box

3. In the Convert Log to Linear dialog box, select the group to be converted.
4. Click OK.

The newly converted data is available in the Contents dialog box as a new group 
(see Figure 7-86 on page 428).

Figure 7-86  The Contents dialog box with the Log-To-Linear data group
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8. Shortcut Keys

Table 17 on page 430 provides a list of the keyboard shortcuts that you can use with 
TomoView. You can use the shortcut keys to activate certain commands without going 
through all the menus or clicking a toolbar button. 

Shortcut keys available for menu commands appear on the menu to the right of the 
command that they activate (see Figure 8-1 on page 429).

Figure 8-1  Example of shortcut keys available for menu commands
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Table 17  Shortcut keys 

Shortcut key Toolbar button – Menu command
Function description

CTRL+[n] Layout > Layout[n]
With [n] equal to 1, 2, 3,...,9, or 0, activates the nth layout as when 
you select one of the ten layouts from the TomoView Manager 
under Layout. CTRL+0 activates the tenth layout. 

CTRL+SHIFT+[n] Layout > Save Current Layout > Save as layout[n]
With [n] equal to 1, 2, 3,..., 9, or 0, opens the Save Current 
Layout as dialog box, allowing you to name and to save the nth 
layout.

CTRL+A Processing > Set A-Scan Resynchronization Gate
In Analysis mode, after positioning the reference and 
measurement cursors around the interface entry echo, creates a 
resynchronization gate (black) between the cursors. 

CTRL+SHIFT+A Processing > Resynchronize A-Scans
Performs the synchronization of A-scans based on the crossing 
in the resynchronization gate. 

CTRL+C Copies the selected text onto the Clipboard.
CTRL+E Tools > Clear Envelope

Resets the envelope mode.
CTRL+SHIFT+E  – Tools > Envelope

Toggles the envelope mode.
CTRL+F Tools > Freeze

Alternately freezes and resumes the display update of the active 
A-scan view.

CTRL+SHIFT+F Tools > Freeze All
Alternately freezes and resumes the display update of all views.

CTRL+H Hides the menu and the toolbars.
CTRL+I File > Import OmniScan File

Opens the Open dialog box to select an OmniScan data file to 
load.

CTRL+M  – View > Maximize/Minimize
Alternately maximizes and restores the size of the active view.
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CTRL+N File > Load Default Configuration
In Inspection mode, creates a new configuration using the 
default values. 

CTRL+O  – File > Open
Opens the Open dialog box to select a file to load.

CTRL+S  – File > Save Configuration As
Opens the Save As dialog box to select the path, name, type, 
and content of the file to save.

CTRL+V Pastes the text previously copied onto the Clipboard into a text 
box.

CTRL+X Cuts the selected text and copies it onto the Clipboard.
CTRL+ click and

drag
On a C-scan, draws a rectangular zone, independently from the 
selected tool.
On a cursor, moves two cursors together.
For a zoom bar, changes the bar start and end values. 

CTRL+SHIFT On a cursor, moves the cursor label.
ALT+C Processing > Automatic Volumetric Merge by Group

Performs the automatic volumetric merge by group on the 
opened data file containing more than one beam per group and 
more than one group.

ALT+V Processing > Automatic Volumetric Merge
Performs the automatic volumetric merge on the opened data 
file containing more than one beam.

F1 Help > Help
Opens the User’s Manual

F2  – View > Splitting > Split Horizontally
Horizontally splits the active view into two views.

F3  – View > Splitting > Split Vertically
Vertically splits the active view into two views.

Table 17  Shortcut keys (continued)

Shortcut key Toolbar button – Menu command
Function description
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F4 View > Save as Preference
Saves the current view properties as the default property 
settings.

SHIFT+F4 View > Apply Preference
Applies the default settings view properties.

ALT+F4 File > Exit
Terminates the execution of TomoView after validating if you 
want to save unsaved data. 

F5 Tools > Previous Group
Selects the previous group.

F6 Tools > Next Group
Selects the next group.

F7 Tools > Previous Beam
In a view containing more than one beam, selects the previous 
beam.

F8 Tools > Next Beam
In a view containing more than one beam, selects the next beam.

CTRL+F8 Tools > Change Group
Opens the Change Group dialog box where you can select one 
of the groups.

F9  – Tools > Zoom
Enables the zoom tool.

F10  – Tools > 3-D Cursor
Enables the 3-D Cursor tool.

F11  – Tools > Zone
Enables the zone tool (see also “CTRL+ click and drag” on 
page 431).

F12  – Tools > Move
Enables the move tool.

Table 17  Shortcut keys (continued)

Shortcut key Toolbar button – Menu command
Function description
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ALT+ENTER  – View > Properties
Alternately opens and closes the Properties dialog box.

SHIFT+ENTER  – View > Contents
Alternately opens and closes the Contents dialog box.

DELETE Layout > Delete Active Note
Eliminates the active note from the view.

CTRL+DELETE  – View > Delete
Deletes the active view.

CTRL+SHIFT+
DELETE  – View > Empty

Clears the content of the active view.
PAGE UP Selects the next gate selection.

PAGE DOWN Selects the previous gate selection.
TAB Selects the next box or option in a dialog box.

SHIFT+TAB Selects the previous box or option in a dialog box.
CTRL+TAB Selects the next tab in a dialog box.

CTRL+SHIFT+
TAB

Selects the previous tab in a dialog box.

ALT+Up, Down,
Left, or Right

Moves the reference (red) cursor.

SHIFT+ALT+Up,
Down, Left, or

Right

Moves the measurement (blue) cursor.

Table 17  Shortcut keys (continued)

Shortcut key Toolbar button – Menu command
Function description
Shortcut Keys    433

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
434    Chapter 8

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
9. Troubleshooting

This section contains troubleshooting information that can be helpful when you 
encounter a problem with TomoView. 

9.1 TomoView Only Starts with the File and the Help Menus

TomoView starts in the TomoViewer edition skipping the Startup Selection dialog 
box when no security hardware key is connected to the computer. In the TomoViewer 
edition, only the File and Help menus appear.

If you expect to start TomoView in one of the other editions, ensure that the security 
hardware key is connected to the computer before starting TomoView (see section 1.4 
on page 28 for details).

9.2 About Firewalls and TomoView

A firewall generally blocks the communication paths between TomoView, acquisition 
units, and the Bootp Server program. If you need a firewall on the computer running 
TomoView, you need to configure the firewall to allow communication between these 
Evident products.

The TomoView installer deactivates the Microsoft Windows XP and Windows Vista 
firewalls for the network adaptor selected for the connection of the acquisition unit. 
This is to prevent the firewall from blocking the communication between the 
acquisition unit, TomoView, and the Bootp Server.
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If you are using a third-party firewall, refer to the documentation of the firewall 
software, and then configure the firewall to allow TCP/IP packets communication 
from the acquisition unit IP address for the following applications:

• TomoView210.exe (default folder: [Installation Folder]\TomoView210)
• _srvbootp.exe (default folder: [Installation Folder]\Bootp).

9.3 Resolving Communication Problems Between the TomoView and 
the Acquisition Unit

You might encounter cases where TomoView fails to detect or looses connection with 
an acquisition unit. For example, when you start TomoView, the list in the Select 
Device Configuration dialog box might be empty even when your acquisition unit 
appears is connected and turned on. 

To restore the communication between TomoView and the acquisition unit

1. Verify that you performed all steps of the TomoView installation (see section 1.5 
on page 30).

2. Verify the configuration of the network adaptor used to connect the acquisition 
unit (see section 9.4 on page 439).

3. Close TomoView and turn off your acquisition unit.
4. On the Windows toolbar, in the Navigation area, if the Bootp Server Monitor icon 

includes a red indicator ( ), perform the following actions:
a) Right-click the Bootp Server Monitor icon. 
b) Click Check Status in the contextual menu. 
c) In the Bootp Status dialog box (see Figure 9-1 on page 437): 
d) Read the Problem, Type, Description, and Possible cause. 
e) Follow the Resolution information.
f) Click Click here to open the Bootp Server Configuration at the bottom of the 

dialog box. 
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Figure 9-1  Example of the Bootp Status dialog box 

g) In the Bootp Server Configuration (Administrator) dialog box, when the 
Bootp or the FTP (file transfer protocol) indicator is red, click Restart (see 
Figure 9-2 on page 438). 
The Bootp Server restarts and the error condition should disappear.
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Figure 9-2  The Bootp Server Configuration dialog box in error state

h) When the Bootp or the FTP indicator remains in error condition (red) after 
restarting the server, restart the computer.

i) If the Bootp Server Monitor icon still includes a red indicator ( ) after 
rebooting the computer, reinstall TomoView. 

5. On the Windows toolbar, in the Navigation area, if the Bootp Server Monitor icon 

includes a no indicator ( ), start your acquisition unit, following the steps in the 
procedure found in section 1.8 on page 36 for the OmniScan and in section 1.7 on 
page 34 for the FOCUS LT.

Bootp and FTP 
indicators in error 
state
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9.4 Configuring the Network Adaptor

The configuration of the network adaptor, to which you connect an acquisition unit, is 
normally done during the TomoView installation. However, you cannot 
simultaneously use a network adaptor to connect to an acquisition unit and to a local 
area network (LAN). 

If your computer has only one network adaptor, as described in the following 
procedure, you need to change the network adaptor configuration each time you 
physically change the network connection of your computer from the acquisition unit 
to the LAN, and vice versa.

To change the network adaptor configuration

1. On the Windows task bar, in the Navigation Area, right-click the Bootp Server 
Monitor icon (see Figure 9-4 on page 440). 

2. In the contextual menu, click Network Adaptor Selection.

Figure 9-3  Opening the Network Adaptor Configuration dialog box

3. In the Network Adaptor Configuration dialog box perform the following tasks 
(see Figure 9-4 on page 440):
a) Click Configure for acquisition (Static IP) when you want to configure your 

computer to connect to the acquisition unit. 
b) Click Configure for Internet (DHCP) when you want to configure your 

computer to connect to a network.
c) Click Finish. 

Bootp Server Monitor icon
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Click Skip to cancel the operation.

Figure 9-4  Configuring the network adaptor to connect to an acquisition unit

9.5 Handling Large Data Files with East Asian Languages

Microsoft Windows provides text service that you can use to enter text in East Asian 
languages using a standard keyboard (see Japanese example in Figure 9-5 on 
page 440). Windows loads the text service modules in the middle of the virtual 
address space. This fragments the available memory space and causes problems for 
large TomoView data files (up to 1 GB).

Figure 9-5  The Japanese language bar

To avoid this problem, you must start TomoView before loading the East Asian text 
service modules. The solution is to set English as the default input language in 
Windows (see section 9.5.1 on page 441), and then start TomoView (see section 9.5.2 
on page 443).
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9.5.1 Setting English as the Default Input Language

The following procedure uses Japanese screen captures to illustrate the tasks. 

To set English as the default input language

1. On the Windows taskbar, click Start, and then click Control Panel.
2. In the Control Panel, click Regional and Language Options (see Figure 9-6 on 

page 441).

Figure 9-6  Regional and Language Options

3. In the Regional and Language Options dialog box (see Figure 9-7 on page 442):
a) Click the Language tab. 
b) In the Text services and input languages group box, click Details.
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Figure 9-7  The Language tab

4. In the Text services and input languages dialog box, on the Settings tab, in the 
Default input language group box, select English (United States - US) [see 
Figure 9-8 on page 443].

5. If no English keyboard is installed, in the Installed services group box, click Add 
to install the English (United States - US) keyboard, and then execute the task in 
step 4.
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Figure 9-8  Setting English as default input

6. Click OK, and then close all dialog boxes. 
7. Restart the computer. 

9.5.2 Starting TomoView to Handle Large Data Files with East Asian 
Languages

The following procedure uses Japanese screen captures to illustrate the tasks.

To start TomoView to handle large data files with East Asian languages

1. Ensure that English is set as the default input language in the Windows taskbar 
(see Figure 9-9 on page 444). 
Troubleshooting    443

 



DMTA-20029-01EN [U8778536], Rev. B, September 2022
Figure 9-9  Ensure that English is the default input language

2. If English is not the default input language, refer to section 9.5.1 on page 441 to set 
it.

3. Start TomoView by double-clicking its icon (see Figure 9-10 on page 444). 

Figure 9-10  Starting TomoView

4. Once TomoView is started, change the input language to Japanese from the 
language bar. See Figure 9-11 on page 444.

Figure 9-11  Switching the input language to Japanese from the language bar

TomoView can now handle large data files (up to 1 GB) with Japanese as the input 
language. 
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10. Additional Features

10.1 Working with the Import PASS Files Utility

This section describes how to use TomoView to visualize and analyze .mnp data files, 
generated by PASS software.

The import PASS function is not available in the Lite edition

10.1.1 Importing and visualizing an .mnp File

To visualize an .mnp file

1. Open any data file in TomoView.
2. In the menu, select File > Import PASS file. 
3. In the Open dialog box that appears (see Figure 10-1 on page 446), select the PASS 

file you want to open, and click Open.
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Figure 10-1  The Open dialog box for opening a PASS file

4. In the menu, select View > Contents.
5. In the Contents dialog box (see Figure 10-2 on page 446), select the desired view 

or views for the imported PASS file.

Figure 10-2  Example of the Contents dialog box with a PASS file

6. Display a Side (B) view to visualize the PASS files. (Figure 10-3 on page 447 shows 
an example of a possible layout, including the echo dynamics along the reference 
cursor.)
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Figure 10-3  Example of layout for a PASS file

Several .mnp files can be imported into the same .rdt file.

10.1.2 Saving PASS Data in an .rdt File

To save PASS data in an .rdt file

1. Follow the steps described in the previous section for importing a PASS file into 
TomoView. 

2. In the title bar of the document window, click  to close the data file. 
3. In the message box that appears (see Figure 10-4 on page 448), click Yes to save 

the imported PASS data in the Blank.A01 file.
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Figure 10-4  Message box for saving imported PASS data

To save the .rdt file under a user-defined name, you have to rename the file 
Default.rdt in Windows Explorer either before or after importing the PASS data.

10.1.3 Determining the Characteristics of an Ultrasonic Beam

To determine the characteristics of an ultrasonic beam simulated with PASS software,
you can use either TomoView graphical tools (cursors) or several of the different
available readings. Make sure that the Expert mode is activated to have all the
readings visible (for more information on the Expert mode, see section 3.16 on
page 220). 

• The Statistics > [MaxPASS]: Maximum soundfield amplitude in AU (only for 
PASS files) parameter provides a measurement of the sound field amplitude in 
the acquisition unit.

• The Favorite Readings > Zone > [A-Zone]: Maximum Amplitude inside Zone is 
the position of the maximum amplitude in the sound field inside the zone.

• Using the 3-D cursor, the Favorite Readings > Segment (seg.) > [Length (seg.)]: 
3-D segment length between extremities reading can be used to determine the 
length and width of the focal spot.
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10.2 Changing the Color of an Element

To change the color of a selected element

1. On the File menu, click Preferences.
2. In the Preferences dialog box, click the View Colors or Tool Colors tab.
3. Click the button corresponding to the element for which you want to change the 

color.
The Color dialog box appears (see Figure 10-5 on page 449).

Figure 10-5  The Color dialog box

4. In the Color dialog box, click the color you want in the Basic colors palette or in 
the Custom colors palette.

5. If none of the available colors are appropriate, click Define Custom Colors.
The Color dialog box unfolds to reveal more options (see Figure 10-6 on 
page 450).
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Figure 10-6  The Color dialog with full color palette

6. Click the color in the Basic colors palette that best corresponds to the color you 
want.
The selected color appears in the Color > Solid zone.

7. To select a custom color: 
 Press the mouse button and, while holding it down, drag the pointer to select 

the color you want from the color matrix. Use the slider at the right of the 
dialog box to modify the brightness.
OR
Specify the color by setting the Hue/Sat/Lum or Red/Green/Blue parameters.

8. Click Add to Custom Colors.
The new color appears in the selected color box of the Custom colors palette.

9. Click OK.
Back in the Preferences dialog box, the selected color appears on the selected 
button.

10.3 Configuring Links Between TomoView Elements

With TomoView, you can link the behavior of elements. For example, moving a cursor 
in one view automatically moves the same linked cursor in another view.
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You can set the general link configuration for all views in the Link tab of the 
Preferences dialog box (see section 3.14.2 on page 214). You can also customize the 
link configuration for a specific view. 

To set the general link preferences

1. On the menu, select File > Preferences.
2. Select the Linking tab.
3. In the two-column list on the left, select the element for which you want to 

configure the linking behavior.
4. For cursor and ruler items: 

a) Under Uncorrected Views, select the desired linking behavior to be applied 
for all uncorrected views.

b) Under Corrected Views, select the desired linking behavior to be applied for 
all corrected views.

5. For the other elements, select the desired linking behavior to be applied for all 
views.

To customize the link configuration for a specific view

1. Select the view for which you want to customize the link configuration.
2. On the menu, select View > Properties.
3. In the Properties dialog box (see Figure 10-7 on page 451), select the View 

Linking tab, and then select the check box for the items that you want to be linked 
for this view.

Figure 10-7  The View Linking tab of the Properties dialog box

4. On the menu, select View > Save as Preferences to save your view linking 
changes in the display setup (.rst) file. 
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You can press the F4 and SHIFT-F4 shortcut keys to respectively save view 
preferences to the display setup (.rst) file and load view preferences from the display 
setup file.

10.4 Working with the Excel Exchanges Process

TomoView can exchange data with a Microsoft Excel worksheet using its Excel 
Exchanges component. You can use this tool to create user-defined readings in the 
information groups. 

The Excel Exchanges components dynamically exports selected TomoView reading 
values to a Microsoft Excel worksheet. You can configure your Excel worksheet to 
perform computation on the imported data. You can also configure the Excel 
Exchanges component to dynamically import the result back into TomoView, into an 
information group Custom info field. 

You can use the Excel Exchanges component in Setup or in Analysis mode, provided 
that the selected readings are available. Once created, your user-defined readings are 
saved when you save a hardware setup (.acq files) or a display setup (.rst file). When 
you load these setup files, they become immediately available for a new data file.

The TomoView Excel Exchanges component only works when Microsoft Excel is 
installed on the computer.

In the defect sizing example used in the following procedure, you can use the Excel 
Exchanges to calculate in Excel the actual scan size [S*(m-r)] of a defect in a cylinder 
(see Equation (1) on page 452 and Figure 10-8 on page 453), using the S(m-r) and U(r) 
values provided by TomoView. 

(1)S* m-r 
r U* r – S m-r 

r
------------------------------------------------=
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Figure 10-8  The actual scan size of a defect

To exchange data between TomoView and Excel

1. In Microsoft Excel:
a) Create a file containing information similar to what is shown in Figure 10-9 

on page 454.
b) Type the value for the radius in cell C8. 
c) In cell B8, type following formula for Equation (1) on page 452:

=(A8*(C8-D8))/C8

The values in cell A8 and D8 will be imported from TomoView.

d) Save the Excel spreadsheet with an appropriate name, in the folder of your 
choice.

Probe

rφ

Actual scan size S*(m-r)

Indication scan size S(m-r)

Reference (r) cursor Measurement (m) 
cursor 

U*(r)
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Figure 10-9  Example of an Excel worksheet content

2. In TomoView, open and setup the appropriate data file similar to the example 
shown in Figure 10-10 on page 455:
a) Select a layout and a view where you clearly see the indication that you want 

to size. 
b) Select to show the U(r) and S(m-r) readings in the view (see section 4.10 on 

page 276 for details).
c) Position the reference (red lines) and measurement (blue lines) cursors on 

each side of the indication.
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Figure 10-10  Setting up the view and the readings

3. On the menu, select Processing > Excel Exchanges.
4. In the Excel Exchanges dialog box (see Figure 10-11 on page 455):

a) Click the browse button ( ) on the right of the Excel file text box.
b) In the Open dialog box, select the Excel file that you created in step 1.d, and 

then click Open.
c) Click Add Export.

Figure 10-11  The Excel Exchanges dialog box
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5. In the Information Groups dialog box, select the field you want to export [U(r) 
and S(m-r) in the case of this example], and then click OK (see Figure 10-12 on 
page 456).

Figure 10-12  The Information Groups dialog box with available readings for the 
Excel Exchanges

6. Back in the Excel Exchanges dialog box, in the Export view info. to Excel file list:
a) Double-click the Cell column on the line of the added export field, and then 

enter the corresponding Excel worksheet cell [D8 for U(r) in this example].
b) Select the cell to export, and then click Select View.

7. In the View Selector dialog box (see Figure 10-13 on page 457), highlight the view 
in which you want the field to appear, and then click Select.
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Figure 10-13  The View Selector dialog box

8. Repeat steps 5 to 7 for each exported information field.
9. In the Excel Exchanges dialog box, click Add Import.
10. In the New View Info dialog box, type the appropriate information for the 

reading you want to import, and then click OK (see the example shown in 
Figure 10-14 on page 457).

Figure 10-14  The New View Info dialog box 
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11. Back in the Excel Exchanges dialog box, in the Import data from Excel file to 
custom info. field list:
a) Double-click the Cell column on the line of the added import field, and then 

enter the corresponding Excel worksheet cell [B8 for S*(m-r) in this example].
b) Select the cell to import, and then click Select View.

12. In the View Selector dialog box, highlight the view in which you want the field to 
appear, and then click Select.

13. Repeat steps 9 and 12 when you have other imported information fields.
14. When your configuration is complete: 

 Close the Excel Exchanges dialog box to close it.
OR
Leave the Excel Exchanges dialog box open.

In both cases, the dynamic data exchange remains active until you change the 
Excel Exchanges dialog box configuration. Similarly, you can close Excel or leave 
it open without affecting the dynamic data exchange. The Excel Exchange 
configuration data is saved in the .rst file.

15. Activate the Expert mode to see all available readings:
a) On the menu, select File > Preferences.
b) On the General Settings tab, under Interface, select the Expert Mode check 

box, and then click OK.
16. Add the reading imported from Excel to the information groups:

a) Double-click the readings on the active view.
b) In the Information Groups dialog box, expand Group 3, select [ExlS*(m-r)]: 

Actual Scan Size, and then click OK (see Figure 10-15 on page 459).
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Figure 10-15  Selecting the reading imported from Excel

The imported reading appears in the Information Groups and its value is 
dynamically linked to the position of the cursors (see Figure 10-16 on page 460). 
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Figure 10-16  The dynamic data exchange between TomoView and Excel

10.5 Editing System Preferences

To edit system preferences

1. On the File menu, click Preferences.
The Preferences dialog box appears (see Figure 10-17 on page 461).
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Figure 10-17  The Preferences dialog box

2. Display the category of preferences you want by clicking the corresponding tab.
3. Modify the options and properties as required.

For details on each tab of the System Preferences dialog box, refer to the 
following subsections.

4. Click OK to save your modifications and close the dialog box.
OR
Click Apply to save your modifications without closing the dialog box, to 
continue modifying properties on another tab.
OR
Click Cancel to close the dialog box without saving your modifications. 

10.6 Working with the Screen Capture Utility

TomoView features screen capture functions that are useful to quickly copy the full 
screen, windows, or a rectangular area. You can save the captured image to a file or 
copy it to the Clipboard to easily paste it in another application.

To capture a TomoView image with the Screen Capture utility

1. On the file menu, select File > Save Screen as Bitmap. 
The Screen Capture utility window appears. 

2. In the Screen Capture window, perform the following tasks:
a) To capture the whole computer screen as it currently appears, on the menu, 

select Capture > Screen. 
b) To only a specific TomoView window:
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(1) On the menu, select Capture > Window.

(2) Move the capture pointer ( ) over the window you wish to capture.
An outline appears around the window below the pointer. 

(3) Click the outlined window.
c) To capture a selected rectangle area on the screen:

(1) On the menu, select Capture > Rectangle.
(2) Click and drag from one corner of the rectangle area you wish to capture.

A contour appears indicating the number of pixels of the selected
rectangle area.

(3) Release the pointing device button at the opposite corner of the desired
rectangle area. 

The image of the selected image appears in the Screen Capture utility (see 
Figure 10-18 on page 462).

Figure 10-18  Example of a window capture with the Screen Capture utility

d) On the menu, select Edit > Copy To Clipboard to copy the captured image to 
the Clipboard.

e) On the menu, select File > Save to open the Save Image dialog box to save the 
image to a bitmap (.BMP) file of your choice.
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To save the active view to an image file

This function only works in Analysis mode.

1. Open a data file and select the desired layout.
2. Select the view with the content that you want to save in an image file.
3. On the menu, select File  > Save Active View as Image.
4. In the Save Image dialog box that appears: 

a) Select a folder, a file name, and the file type (BMP Files or TIFF Files) to 
which you want to save the image.

b) Click Save.

10.7 Working with the Beam Simulation Component

The Beam Simulation component is an ultrasonic beam simulator working on-line, in 
Setup mode with a .acq file, or off-line in Analysis mode while analyzing a specific 
.rdt file. Using this component, you can:

• Simulate the trajectories and dimensions of ultrasonic beams generated by 
conventional and phased array probes in a user-defined geometry. 

• Evaluate the examination coverage provided by the ultrasonic beam 
configurations programmed in the current TomoView setup. 

• Simultaneously simulate beams from multiple groups.
• See the beam spread and the rebounds on the defined part. 

The Beam Simulation component is not available in the Lite Aero and Lite Weld 
editions.
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10.7.1 Enabling a Beam Simulation View

Use the Beam Simulation component with the following skew angles: 0°, 90°, 180°, 
and 270°. Attempts to visualize other skew angles generates invalid images.

To enable a beam simulation view

1. In Setup mode, open a setup file (.acq), or create a new setup.
OR
In Analysis mode, open a data file (.rdt).

2. On the menu, select Part & Overlay > Part Definition.
3. In the Part Definition dialog box, in the Thickness text box, enter the thickness of 

your part.
The entered value is used to define both coordinates of the Specimen properties 
table (the Depth values). These points define the default border of the specimen.
The default Scan (or Index) values are automatically defined by the projection of 
the ultrasonic beams with the considered skips and the Scan Settings (scan or 
index axis Start and Stop values).

4. Click the Beam Simulation button ( ).
5. In the Beam Simulation dialog box, select the Enable simulation check box.

10.7.2 Displaying a Beam Simulation View

To display a beam simulation view

1. In the TomoView Manager dialog box, select the layout you have reserved for the 
beam simulation (for example, layout 8), and then select the view in which you 
want to see the beam simulation. 

2. On the menu, select View > Contents.
3. In the Contents dialog box, locate the Beam Simulation data group, and then 

double-click one of the available views. 
The corresponding beam simulation appears in the view (see example shown in 
Figure 10-19 on page 465).
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The selection of a view depends on the skew angle used to define the ultrasonic 
beam.

Figure 10-19  Beam simulation example

10.7.3 Description of the Beam Simulation Dialog Box

The Beam Visualization tab is used to display the parameters related to the 
visualization of the calculated beam (see Figure 10-20 on page 465).

Figure 10-20  The Beam Visualization tab
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The Beam Visualization tab contains three group boxes: Beam visualization, Colors, 
and BSC file.

Beam visualization group box

Figure 10-21  The Beam Visualization dialog box 

The Beam Visualization dialog box contains the following. See Figure 10-21 on 
page 466. 

Current group only
Select this check box to display only the focal laws of the current active group 
in the beam simulation view.

Current law only
Select this check box to display only the current active focal law in the beam 
simulation view.

Skips
This list box defines the number of half skips to be displayed in the beam 
simulation view.

Ray
Select this option button to display the ultrasonic beam as rays (one line per 
beam).

Beam
Select this option button to display the ultrasonic beam as a beam with its 
opening.
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Beam group box
When the Beam option button is selected, the parameters in the Beam group 
box are enabled and are used to define the beam characteristics for the Beam 
Simulation calculations:

• Probe frequency: This text box sets the frequency of the probe.
• Probe aperture: This text box sets the aperture of the probe. For a phased 

array group, the aperture is set by the Advanced Calculator (considering 
the number of active elements and the pitch). In conventional groups, the 
aperture must be defined by the user.

• Empty beam aspect: Select this check box to display the ultrasonic beam 
with just two lines at the edge of the beam opening.

• Zone: Select one of the three option buttons to define the attenuation at 
which the beam opening edges (zone) is to be considered.

Colors group box

Figure 10-22  The Colors group box 

Colors group box
The Colors group box can be used to change the color of the elements inside 
the beam simulation view. See Figure 10-22 on page 467. 

When you click one of the colored squares, the standard Color dialog box that 
appears is used to select a different color for the associated item.
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BSC file group box

Figure 10-23  The BSC File group box 

The BSC (beam simulation configuration) files are used to save the part construction 
parameters defined on the Part Construction tab. See Figure 10-23 on page 468.

Load
Opens a standard Load dialog box; used to load a .bsc file.

Save As
Opens a standard Save As dialog box; used to save the beam simulation 
configuration.

The Part Construction tab is used to display the parameters related to the part 
construction (see Figure 10-24 on page 468).

Figure 10-24  The Part Construction tab

The Part Construction tab contains two group boxes: Part properties and Weld 
properties.
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Part properties group box

Figure 10-25  The Part Properties group box 

The Part Properties group box contains the following. See Figure 10-25 on page 469.

Table
This table is used to define the part border shape.

Scan (or Index)
This column indicates the position of the points on the scan (or index) axis.

Depth
This column indicates the position of the points on the ultrasonic axis.

Insert
Click this button to insert a new point in the table defined by the position of 
the reference cross-hair cursor in the beam simulation view.

Replace
Click this button to replace the selected point in the table by another one that 
has been defined by the position of the reference cross-hair cursor in the beam 
simulation view.

Remove
Click this button to remove the selected point from the table. This action alters 
the part border shape.
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Weld properties group box

Figure 10-26  The Weld Properties group box 

The Weld Properties group box contains the following. See Figure 10-26 on page 470.

Table
This table is used to define the part border shape.

Left
Select this option button to define the left side of the weld.

Right
Select this option button to define the right side of the weld.

Scan (or Index)
This column indicates the position of the points on the scan (or index) axis.

Depth
This column indicates the position of the points on the ultrasonic axis.

Insert
Click this button to insert a new point in the table that has been defined by the 
position of the reference cross-hair cursor in the beam simulation view.

Replace
Click this button to replace the selected point in the table by another one that 
has been defined by the position of the reference cross-hair cursor in the beam 
simulation view.

Remove
Click this button to remove the selected point from the table.
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Symmetric
When one side of the weld preparation is defined (for example, left) and the 
other is selected (for example, right), click Symmetric to automatically define 
this side symmetrically to the other using the reference cross-hair cursor 
position as the weld centerline.

10.8 User Fields

This section describes how to define the customized information fields that can be
added to the file content. These additional elements of information are called user
fields. You can use the User fields to enter specific, user-defined information that is not
predefined in TomoView (for example: name of the acquisition operator, name of the
power plant, weld identification, etc.). 

To define user fields

1. In the menu, select Tools > Edit User Fields.
2. In the Page Name dialog box, click in the text box and type the appropriate name 

for the first user field page, and then click OK.
The Edit User Fields dialog box appears (see Figure 10-27 on page 472).
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Figure 10-27  The Edit User Field dialog box

3. Using the mouse, select a click here to edit box label and enter the parameter 
name.

4. Click in the box to the right of the parameter name you just typed, and then type 
the value that corresponds to the parameter or leave the box empty to define the 
value later.

5. In the right column:

• Select the  check box to protect the parameter against any modification in 
Analysis mode. 

• Select the  check box to make the parameter mandatory for every 
acquisition. 

6. Click Close.
The user field page is saved in the current setup.
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10.9 Working with the Fast Fourier Transforms (FFT) Component

The Fast Fourier Transform (FFT) tool can be used to determine the spectral 
components of the signal received by an ultrasonic transducer. The FFT tool can be 
used at any time but will require data files acquired in the following conditions to be 
used in analysis mode. See Figure 10-28 on page 473.

To configure a setup for the FFT component

1. In the Pulser/Receiver tab of the UT Settings dialog bar, set Rectification to RF. 
2. In the Digitizer tab of the UT Settings dialog bar, set Compression to 1. 
3. In the TomoView Manager, set the scan mode to Free running. 

4. In the Component toolbar, click  (FFT). 
5. In an A-scan view, place the Reference and Measurement cursors around the 

portion of the signal that you want to analyze. 

Figure 10-28  The Fast Fourier Transforms dialog box
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