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Setting Up the OmniScan for a Weld Inspection Using 
the COBRA Scanner

The purpose of this document is to show you how to quickly set up and use the 
OmniScan to perform a weld inspection using the COBRA scanner. This document 
includes the procedures used to prepare for the inspection, perform the inspection, 
analyze the data, and produce a report.

Figure 1  The OmniScan MX and the COBRA scanner
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Required Material and Software

The procedures in this document describe the inspection of a weld using the COBRA 
scanner with 7.5CCEV35-A15 probes.

The inspected weld used as an example in the procedures is on a 14 mm thick, mild 
steel pipe. You can easily adapt the procedures to the scan plan of your inspected 
pipes by changing the values of a few parameters.

You need the following items to perform the procedures contained in this document:

• A COBRA scanner (including two 7.5CCEV35-A15 phased array probes)
• A Y-adaptor (P/N: OMNI-A-ADP05) to connect two phased array probes to the 

OmniScan
• An OmniScan MX with a 16:128 or 32: 128 phased array module

(P/N: OMNI-P-PA16128 or OMNI-P-PA32128)
• The OmniScan MXU 2.0 software with Multigroup option

(P/N: OMNI-SO-MGROUP) and wedge update
• A manual water pump (WTR-SPRAYER-4L or 8L) for irrigation

Related Documents

For more information concerning the COBRA Scanner, the OmniScan instrument, and 
the OmniScan software, refer to the following Evident documents:

• COBRA Scanner: User’s Manual (P/N: DMTA-20006-01EN)
• OmniScan MXU Software: User’s Manual (P/N: DMTA011-01EN)
• OmniScan MX: User’s Manual (P/N: DMTA071-01EN)
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Preparing for an Inspection

After defining your scan plan, use the procedures contained in this section to set up 
the OmniScan for a weld inspection using the COBRA scanner. The setup requires 
you to define two groups, one for each phased array probe.

Perform the following procedures in the order that they appear:

• “Starting the OmniScan” on page 7
• “Defining the First Group with the Group Wizard” on page 8
• “Calculating the Focal Laws with the Focal Law Wizard” on page 11
• “Calibrating the OmniScan with the Calibration Wizard” on page 11
• “Configuring Various Parameters” on page 12
• “Configuring the Second Group for the Second Probe” on page 15

To reduce the setup time, load an existing COBRA scanner OmniScan setup file that 
you created for a similar inspection, and then make the necessary adjustments. 

Press  or choose File > File > Open to open an existing setup file.

Starting the OmniScan

The following procedure describes how to start the OmniScan with the MXU 2.0 
software and to validate that the required components are installed.

To start the OmniScan

1. Ensure that the OmniScan storage card contains the OmniScan MXU 2.0 software.
2. To be sure to have the COBRA probe and wedge definition on the storage card:

a) Visit the software download section of the EvidentScientific.com Web site and 
download the latest Wedge Update.

b) Install the wedge update on the OmniScan storage card.
3. Insert the storage card into the OmniScan instrument.
4. Connect the phased array probe located on the encoder side of the scanner, to the 

P1 (channels 1 to 64) connector of the Y-adaptor.
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5. Connect the other phased array probe to the other connector of the Y-adaptor.
6. Connect the Y-adaptor to the OmniScan MX instrument.

7. Start the OmniScan unit by pressing the Power key ( ) at the lower-right 
corner of the OmniScan front panel.
The instrument displays the OmniScan logo.

8. When more than one application is installed on the storage card, a screen presents 
corresponding buttons in order for you to choose which application you want to 
start. Choose OmniScan [MXU - 2.0]. 
The OmniScan MXU software starts.

9. To verify that the Multigroup software option is installed:
a) Choose Preferences > Service > System Info.
b) In the OmniScan MX System Information report that appears, use the Scroll 

knob to scroll down to the Acquisition Module section.
c) Verify that Yes appears in the Enabled column for the Multigroup support 

[OMNI-SO-MGROUP] option.
d) Choose Close to close the report.

10. If the Multigroup option is not enabled, contact Evident to purchase the option.

Defining the First Group with the Group Wizard

The following procedure describes how to set up the group for the first COBRA 
scanner phased array probe (located on the encoder side of the scanner) using the 
Group wizard.

To define the first group with the Group wizard

1. On the OmniScan, choose Wizard > Group > Start to begin defining the setup.
The first wizard step help appears, showing you how to proceed with the Select 
Operation step (see Figure 2 on page 9).
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Figure 2  The Select Operation step of the Group wizard

Press Cancel ( ) at any time if you need to quit the wizard.

2. In the Select Operation step, select Operation = Modify, and then choose Next.
3. In the Validate Material step:

a) Select Geometry = Plate.
b) Choose Thickness, and according to your scan plan, enter the value 

corresponding to the thickness of the number of skips required to cover the 
entire weld. For this example, two skips times 14 mm equals 28 mm.
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You will change the thickness back to the real inspected pipe thickness after the 
calibration.

c) Select Material = STEEL, MILD, and then choose Next.
Adapt this choice if it is different from your inspected pipe.

4. In the Select Group Type step, select Group Mode = PA, and then choose Next.
5. In the Select Connection step, for the first group, Connection P is always set to 1. 

Choose Next.
6. In the Select Probe step:

a) Select Select = Select Tx/Rx.
b) Select Auto Detect = OFF.
c) Choose Probe.
d) In the dialog box that appears, select A15 in the list on the left, 7.5L16-A15 in 

the list on the right, and then choose Select to close the dialog box.
e) Choose Next.

7. In the Select Wedge step:
a) Select Select = Tx/Rx.
b) Choose Wedge.
c) In the dialog box that appears, select SA15 in the list on the left, 

SA15-N60S-IH in the list on the right, and then choose Select to close the 
dialog box.

d) Choose Next.
8. In the Set Position step:

a) Set Scan Offset = 0 mm.
b) For this example, set Index Offset = –22 mm. 

For your inspected pipe, adapt this value according to your scan plan.
c) Set Skew = 90°, and then choose Next.

9. In the Accept step, choose Finish to complete the Group wizard.
10. Save your setup (.ops format):

a) Choose File > Save Setup As.
b) In the file manager that appears, select an existing setup file.

OR
Choose File name, and then enter the desired file name.
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c) Choose Save to save the setup file and close the file manager.
The file is saved on the storage card in the \User\Setup folder.

Calculating the Focal Laws with the Focal Law Wizard

Once the group is defined, calculate the focal laws for the first COBRA scanner 
phased array probe using the Focal Law wizard.

To calculate focal laws with the Focal Law wizard

1. Choose Wizard > Focal Law, and then choose Start in the Law Wizard step.
2. In the Select Law Configuration step, select Law Config. = Sectorial, and then 

choose Next.
3. In the Set Wave Type step, select Wave Type = SW, and then choose Next.
4. In the Select Probe Elements step:

a) Set Element Qty. = 16.
b) Set First Element = 1, and then choose Next.

5. In the Set Beam Angle step, set the following parameters according to your scan 
plan. For this example:
a) Set Min. Angle = 40°.
b) Set Max. Angle = 70°. 
c) Set Angle Step = 0.5. Consider increasing this value when using higher scan 

speeds.
d) Set Focus Depth = 28 mm (as in step .3.b in section “Defining the First Group 

with the Group Wizard” on page 8).
e) Choose Next.

6. In the Generate Law step, choose Generate.
7. Choose File > Save Setup as to save your setup.

Calibrating the OmniScan with the Calibration Wizard

With the group defined and the focal laws calculated, you now need to calibrate the 
instrument sensitivity, the ultrasound velocity, and the wedge delay, as well as define 
a sizing curve. You can easily do this using the Calibration wizard. 

Refer to the OmniScan MXU Software: User’s Manual (P/N: DMTA011-01EN) for more 
details on the calibration procedures.
Setting Up the OmniScan for a Weld Inspection Using the COBRA Scanner    11
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To calibrate the OmniScan with the Calibration wizard

1. Detach the encoder-side probe/wedge assembly from the scanner.

2. Press the Calibration key ( ).
OR
Choose Wizard > Calibration to access the Select Calibration step.

3. Calibrate the ultrasound propagation velocity within the material of the inspected 
pipe:
a) Select Type = Ultrasound.
b) Select Mode = Velocity.
c) Choose Start, and then follow the other wizard steps.

4. Calibrate the sound propagation delay within the material of the wedge:
a) Select Type = Ultrasound.
b) Select Mode = Wedge Delay.
c) Choose Start, and then follow the other wizard steps.

5. Calibrate the sensitivity of the instrument to ensure the detection of a small 
reference reflector:
a) Select Type = Ultrasound.
b) Select Mode = Sensitivity.
c) Choose Start, and then follow the other wizard steps.

6. Define a sizing curve:
a) Select Type = Ultrasound.
b) Select TCG, time-corrected gain, and perform the calibration to cover the 

depth of the reflectors encountered during the inspection.
7. Choose File > Save Setup as to save your setup.

Configuring Various Parameters

Following the completion of the wizard steps, you need to configure some other 
ultrasonic, gate, display, part, scan, and encoder parameters.

To configure various parameters

1. Set Probe/Part > Parts > Thickness = 14 mm, the real pipe thickness for this 
example.
Adapt this value to the real thickness of your inspected pipe. 
12    Setting Up the OmniScan for a Weld Inspection Using the COBRA Scanner

 



DMTA-20009-01EN, Rev. B, September 2022
2. Choose UT Settings > General, or press the appropriate shortcut keys to verify 
the other settings:

a) Set Gain = 18.4 ( ).

b) Set Start = 0 ( ).

c) Set Range = 50 ( ) to cover the thickness for all focal laws.
d) Set Wedge Delay = 0.

3. Choose UT Settings > Pulser:
a) Select Voltage = High.
b) Select PW = Auto.
c) Select PRF = Optimum.

4. Choose UT Settings > Receiver:
a) Select Filter = 7.5 MHz.
b) Select Rectifier = FW.
c) Select Video Filter = On.
d) Select Averaging = 1.

5. Choose Gate/Alarm > Gate, or press  to set the gate parameters:
a) Select Parameters = Position.
b) Select Gate = A, and then adjust the gate parameters so that gate A covers the 

entire inspected section according to the scan plan (two skips equal two times 
the thickness). For this example:
(1) Set Start = 3 mm.
(2) Set Width = 30 mm.
(3) Set Threshold = 25%.

c) Select Gate = B, and then adjust the gate parameters so that gate B covers the 
middle of the weld, without detecting the geometry reflectors. For this 
example:
(1) Set Start = 16 mm.
(2) Set Width = 10 mm.
(3) Set Threshold = 10%.

d) Select Gate = I, and then adjust the gate parameters to hide gate I:
(1) Set Start = 0 mm.
(2) Set Width = 0.05 mm.
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(3) Set Threshold = 10%. 
6. Choose Display > Overlay:

a) Select UT Unit = True Depth.
b) Select Grid = Off.
c) Select Sizing Curves = On.
d) Select Gate = On. 
e) Select Cursor = On. 
f) Select Overlay = On.

7. Choose Display > Properties, select Source = Highest (%), and then choose Yes in 
the dialog box that appears.

8. Choose Scan > Inspection:
a) Select Type = One-Line Scan.
b) Select Scan = Encoder 1.
c) Set Max. Scan Speed to the maximum accepted value (98 mm/s for this 

example).
9. Choose Scan > Encoder:

a) Select Polarity = Normal.
b) Select Type = Quad.
c) Set Resolution = 32 Step/mm.
d) Set Origin = 0.

10. Choose Scan > Area:
a) Set Scan Start = 0 mm.
b) Set Scan End = 400 mm.

Adapt this value to the length of your inspected pipe circumference.
c) Set Scan Resolution = 1 mm. 

With the COBRA scanner, you can set the scan resolution value to as low as 
1/32 mm. However, a small scan resolution value leads to a slower inspection.

11. Choose File > Save Setup as to save your setup.
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Configuring the Second Group for the Second Probe

If you performed all the previous procedures, the settings and calibrations are done 
for the first group; that is, for the probe on the encoder side of the scanner. You now 
need to configure the second probe. You can do this quickly by copying the 
parameters of the first group (including calibration) and making adjustments to a few 
parameters.

To configure the second group for the second probe

1. Select Probe/Part > Select > Group = Add. 
2. In the dialog box that appears, which asks if you want to copy the settings from 

the current group, choose Yes.
The OmniScan creates Group 2.

3. Choose Wizard > Group.
4. In the Group Wizard Step, choose Start.
5. In the Select Operation step, select Operation = Modify, and then press Next.
6. In the Select Group step, select Group = 2, and then choose Next.
7. Choose Next until you reach the Select Connection step, and then select 

Connection P = 65.
8. Choose Next until you reach the Set Position step, and then:

a) For this example, set Index Offset = 22 mm.
Adapt this value to your inspected pipe according to the scan plan.

b) Select Skew deg = 270°.
9. Choose Next until you reach the Accept step, and then choose Finish.

10. Press , or choose Display > Selection to set the display:
a) Select Display = A-S-(C).
b) Select C-Scan = A%.
c) Select Group = All.
Both groups now appear as in the example shown in Figure 3 on page 16.
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Figure 3  Both groups appear with a completed setup

11. Choose File > Save Setup as to save your setup.

Encoder side probe data
and currently selected group Second probe data
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Performing Inspections

Once you have completed the preparation procedures (see “Preparing for an 
Inspection” on page 7), you are ready to inspect your weld.

To inspect your weld

1. Referring to the COBRA Scanner: User’s Manual (P/N: DMTA-20006-01EN) for 
details:
a) Configure the scanner for the pipe diameter.
b) Adjust the distance between the two scanner probes according to your scan 

plan (22 mm on each side of the weld centerline for this example). 
2. Install the scanner on the pipe with the weld centered between the two probes.

3. If needed, use the Gain key ( ) to adjust the gain so that the weld geometry 
appears on the S-scan.

4. Ensure that couplant liquid is fed to the scanner.

5. When ready to acquire data in the C-scan, press the Start/Stop key ( ), and 
then manually rotate the COBRA scanner over the complete circumference.
The acquired data appears in the C-scan view for each probe.

Analyzing Data

Once you have acquired data (see “Performing Inspections” on page 17), switch to the 
OmniScan Analysis mode to find and characterize the indications.

You can also use the TomoView software to analyze the inspection data acquired with 
the OmniScan.
Setting Up the OmniScan for a Weld Inspection Using the COBRA Scanner    17

 



DMTA-20009-01EN, Rev. B, September 2022
To analyze data with the OmniScan

1. Press the Freeze key ( ) to enter the Analysis mode.
The data view freezes in the current state, and the orange acquisition indicator 
blinks (see Figure 4 on page 18).

Figure 4  The acquisition indicator

2. To save your data for later analysis:
a) Select File > File > Save mode = Inspection Data.
b) Choose File > File > File Name, and then type the desired name.

Use “#” characters in the file name to include an automatically increasing number. For 
example Data#### becomes Data0001, Data0002, etc... Refer to the OmniScan MXU 
Software: User’s Manual (P/N: DMTA011-01EN) for details on other special characters.

c) Choose File > File > Save Data.
The inspection data is saved on the storage card in the \User\Data folder. 

3. To look for an indication:

a) Press and hold the Group Selector key ( ) to select the desired group. 
The A-scan background of the currently unselected group appears in grey 
(see Figure 7 on page 22). 

b) Use the Data cursor to scan the slices for an indication:

(1) Press the Cursor key ( ), or choose Measurement > Cursors > 
Selection, and then select Data.

(2) Set Measurement > Cursors > Scan = 0 mm.

Acquisition indicator blinks while in
Analysis mode
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(3) While looking at the S-scan view and still editing the Measurement > 
Cursors > Scan parameter value, turn the Scroll knob clockwise to scan 
the data slices until you find an unusual reflector.

4. Find the maximum signal using the Angle cursor: 
a) Choose Measurement > Cursors > Angle to select the angle cursor.
b) Turn the Scroll knob until the angle cursor in the S-scan is over the reflector 

with a maximized signal amplitude signal in the A-scan.
5. To zoom on the reflector in the C-scan: 

a) Select Display > Zoom > Display = Uncorrected C-Scan.
b) Set Start Scan where you want the zoom to start on the C-scan.
c) Set End Scan where you want the zoom to end on the C-scan.

6. To size the indication using the reference (red line) and the measurement (green 
line) cursors (see Figure 5 on page 20):
a) Select Display > Overlay > Cursor = On to ensure the cursors appear on the 

screen.
b) Select Display > Selection > Display = S.
c) Choose Display > Zoom, and then set the Start Index, End Index, Start 

USound, and End USound parameters to zoom closer to the indication.
d) Select Measurements > Cursors > Selection = Measure, and then set the 

position of UT cursor on each side of the indication.
e) Select Measurements > Cursors > Selection = Reference, and then set the UT 

cursor position on each side of the indication.
f) To display appropriate readings, select Measurements > Readings, and then:

(1) Set List = 1.
(2) Select Field 1 = A%, the maximum amplitude of the signal.
(3) Select Field 2 = DA^, the depth of the indication in the part.
(4) Select Field 3 = ViA^, the volumetric position of the indication detected in 

the gate.
(5) Select Field 4 = U(m-r), the distance on the ultrasonic axis obtained by 

subtracting the position of the reference cursor from the position of the 
measurement cursor. 

g) Consult the readings above the data to get the size and the position values for 
the indication.
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If you want, you can display many other readings available with the OmniScan.

Figure 5  Zooming and positioning the cursors around an indication

7. To include the indication in the indication table (see Figure 6 on page 21): 
a) Select Measurement > Table > Display Table = On. 
b) Choose Measurement > Table > Add Entry to add the indication to the 

indication table.

Reference cursor
Measurement cursor
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Figure 6  Adding an indication to the indication table

8. You can also measure the indication length on the C-scan:
a) Select Display > Selection > Display = C.

b) Press the Cursor key ( ).
c) Select Measurements > Cursors > Selection = Measure.
d) Choose Measurements > Cursors > Scan to set the start position on the scan 

axis.
e) Select Measurements > Cursors > Selection = Reference.
f) Choose Measurements > Cursors > Scan to set the end position on the scan 

axis.
g) Consult the readings above the data to get the size and the position values for 

the indication.
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9. Choose Measurement > Table > Add Entry to add the indication to the indication 
table.

10. Select Measurement > Table > Display Table = Off to hide the indication table.
11. Select Display > Selection > Display = A-S-(C) to display the A-scan, S-scan, and 

C-scan for both groups, as shown in the example in Figure 7 on page 22.

Figure 7  View of A-Scan, S-Scan, and C-Scan for both groups in Analysis mode

Creating a Report

With the OmniScan MXU software, you can easily create an inspection report. You 
can configure, create, review, print, and save the report from the OmniScan. The 
report is saved in the HTML format. 

Currently selected group
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The report can include a report header, up to ten user defined information fields, 
probe characterization parameters, setup parameters, user notes, a layout view, and 
the indication table content.

To create a report

1. While still in the Analysis mode, choose File > Format to select which elements 
you want to appear in the report:
a) Select File > Format > User Field = On to include user-field information.
b) Select File > Format > Probe = On to include probe parameters.
c) Select File > Format > Setup = On to include setup parameters.
d) Select File > Format > Note = On to include notes.
e) Select File > Format > View = Current Layout to include an image of the 

current data display. 
OR
Select Table to include, rather, the indication table content.
OR
Select Off to include neither.

2. If you chose to include user fields, define them as follows:
a) Choose File > User Field > Select, and then select the number corresponding 

to one of the ten possible user fields.
b) Select File > User Field > Enable = On.
c) Choose File > User Field > Label, and then type the label for the field (for 

example: Inspector).
d) Choose File > User Field > Content, and then type the value for the field (for 

example: <your name>).
e) Repeat steps 2.a to 2.d for other user fields. 

3. If you chose to include notes, define them as follows:
a) Choose File > Notes > Edit Notes.
b) In the dialog box that appears, type the desired note text, choose Close, and 

then choose Yes when asked to save changes.
The note text appears at the beginning of the last section of the report.

4. If you want to include a report header, define it as follows:
a) Choose File > Notes > Edit Header.
b) In the dialog box that appears, type the desired report header text, choose 

Close, and then choose Yes when asked to save changes.
The report header text appears at the beginning of the report, below the logo.
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5. To change the logo that appears at the top of the report, refer to the 
OmniScan MXU Software: User’s Manual (P/N: DMTA011-01EN).

6. If you want to save the report to a device other than the storage card:
a) Connect your USB storage device to one of the OmniScan USB ports. 
b) Choose File > File > Storage, and then select the desired device.

7. Choose File > Report > Build to display the HTML file of the report on the 
OmniScan screen (see Figure 8 on page 24 and Figure 9 on page 25).

8. Use the Scroll knob to scroll the screen and to see the complete report.
9. Choose Save and Close at the bottom of the report screen to save the report and 

to close the report viewer. 
The report is saved on the selected storage device in the \User\Report folder.

10. Choose File > File > Save Data to save the inspection data to an .opd file.

Figure 8  Example of an HTML report (part 1 of 2)
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Figure 9  Example of an HTML report (part 2 of 2)
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